Wifi and bluetooth not working on ubuntu 22.04

Hi I recently moved to HP laptop

I have ubuntu 22.04 running on it, however there is major issue with wifi and Bluetooth which collapses after an hour or so of use, and works on restart again.

I wanted to understand why this is happening, and if there are specific drivers I need to install for it to work.

I am attaching the system and wifi info below, if any more info is required LMK.

Host: linux Kernel: 6.2.0-26-generic x86_64 bits: 64 Desktop: GNOME 42.9
Distro: Ubuntu 22.04.3 LTS (Jammy Jellyfish)
Laptop System: HP product: HP Pavilion Laptop 15-eh2xxx
CPU Info: 6-core model: AMD Ryzen 5 5625U with Radeon Graphics bits: 64
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb Report: hciconfig ID: hci0 state: up address: 10:68:38:90:86:61 bt-v: 3.0

Network Device-1: Realtek driver: rtw89_8852be IF: wlo1 state: down mac: 10:68:38:90:86:60

output of sudo lshw -C network

 *-generic DISABLED
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       configuration: broadcast=yes driver=rtw89_8852be driverversion=6.2.0-26-generic firmware=N/A latency=255 link=no maxlatency=255 mingnt=255 multicast=yes wireless=IEEE 802.11
       resources: irq:74 ioport:f000(size=256) memory:fcf00000-fcffffff

Two possible answers …
Try updating the drivers as described

Failing that a faulty WiFi card could mean using an external WiFi usb key, but of course that would be costly especially if the first solution fixes the issue

There are no available drivers, i think ill just go with WiFi USB stick

1 Like

Sometimes it’s just easier to go with buying a solution and as they are around 15 euros not worth the pain

1 Like

Hi @Rishu_Shrivastav ,
Welcome to the forum.
I don’t know how to help you, but I did a search on google and some results came up with the same problem you have.

One question: have you tried changing the wifi powersave?

According to this link, you could try to change the powersave value to fix the problem.

Could you please check what is the value of your wifi powersave with this command?

cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

If wifi.powesafe is not 2, could you try the following procedure to change wifi.powersave to 2 (disable powersave)?

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
  • Change the value of wifi.powersave to 2
  • Save the file (ctrl + o)
  • Exit the Nano (ctrl + x)
  • Restart the NetworkManager (or just reboot):
sudo systemctl stop NetworkManager
sudo systemctl start NetworkManager

I hope it solves your wifi problem


Related links:

Can I add another useful Wifi link

1 Like

I recently experienced EXTREMELY flaky WiFi and Bluetooth on my Ryzen Thinkpad - E495 - RealTek WiFi and BlueTooth…

Ended up buying (measly $20 AUD) an Intel Chipset (AX210) mini PCIe card (for laptops) and that solved ALL of my dodgy WiFi / Bluetooth issues - RealTek are GARBAGE on Linux, mostly… The hardest part was attaching the chassis antenna cables (needed a magnifying glass!).

Proviso : “solved ALL of my dodgy WiFi / Bluetooth issues” is a bit of hyperbole… WiFi is actually pretty good on Linux, but BlueTooth has nearly always been a steaming pile of crap (on Linux)… When it works it feels like black magic, when it doesn’t work it feels like bad juju…


three times in the past fortnight - I’ve had Bluetooth issues on my Pop!_OS desktop machine :
Intel AX200 Bluetooth

Where my bluetooth mouse drops its connection (usually overnight - I don’t shutdown or standby - I just turn the monitors off) and won’t reconnect, even when I set it to “forget” the previous one and attempt to re-pair it… Nada… I’ve tried restarting, and stopping then starting, bluetooth.service via systemd - makes no difference.

Reboot fixes it - but I HATE that! And after booting up again today - my 2nd monitor stopped working - tried different DP ports on my GPU - flippped the cable around - nada… couldn’t find any spare DP cables, so decided to try HDMI instead, and it worked (plug and play)… But I’m trying to reserve that single HDMI port for my XP Pen drawing tablet…

So - just now I’ve dug through several boxes, to find a wired mouse (an optical USB mouse branded “Sun Microsystems”) :

And now keeping that plugged in on my desk (note : I still have a “mouse cursor” I can drive via trackpoint on my Lenovo Thinkpad 2.4 Ghz keyboard - but I prefer to have both - especially as it’s my Synergy server, and using a trackpoint across a “virtual” [via Synergy] desktop 7680 pixels wide is a PITA)…

That mouse has one button?

No - THREE - all UNIX graphical systems used three mouse buttons - but in the case of these more recent Sun mouses, the middle button is also a scroll wheel…

We’ve discussed this before - I cannot live with less than 3 buttons…

1 Like

Remember the good old days…?


cleaning the fuzz off the ball.


Same here :smile: and even though I am not having disconnect issues, I do have a LOT of lag using Barrier between LM & Pop OS. So much so that I am grateful I bought the 3 button switcher mouse from logitech as I often just hit the 2nd buton and use it connected via BT directly in Pop. Maybe there’s something in Pop? Cause I don’t have lag on Kubuntu.

HAHA! I still have one like that I thought to throw out, but BT doesn’t work in grub…

Sheila Flanagan


I don’t have any “lag” as such… My Synergy server is on my Pop!_OS desktop in the middle, to the left is my personal MacBook pro M1 (which I use to connect to customers) and on the right is my work MacBook pro M1 (which I rarely use to connect to customers 'cause it’s so LOCKED DOWN [e.g. can’t run Azure VPN client] - pretty much all I use it for is work email and teams) - I notice LAG in Synergy if either of the Macs are using WiFi - but when I disable WiFi and use ethernet - there’s NO LAG. I’ve also not noticed any lag when Synergy Server and Client are on WiFi, but BOTH Linux - i.e. I only notice Synergy lag if the client is MacOS and using WiFi.
That small screen next to the right MacBook, is now on the left on my personal MacBook (it’s an iPad Pro 12.9" which Apple Sidecar lets you use it as another display on MacOS)

The issue I have is not “lag” for the Bluetooth mouse, it’s that it JUST STOPS WORKING - and then no other BlueTooth devices can connect. And stopping + starting bluetooth (either from cli systemd - or on the top menu bar / system tray doohicky) doesn’t do anything… So if it happens again - I’m prepared now, and won’t have to reboot straight away (i.e. I have a wired mouse hooked up now) - but I mostly prefer to have Bluetooth working, 'cause I mostly listen to music and watch TV / movies using a BT headset…

The “three buttons” reference was simply that I use the X select buffer all the time - i.e. in a terminal (or nealy EVERY other app on X11) select some text, got to a text editor, or another terminal, press the middle mouse button (e.g. the wheel) and presto! Like magic. And Synergy even puts it into the clipboard on connected systems, and MacOS terminals also place selected text, into the clipboard - so I can select a string in a web page on my Linux system, mouse over to MacOS, press the middle button in iTerm2 window, and it pastes! If this stopped working - I’d be lost and devastated - I’m concerned that Wayland might somehow stop this from working.

Synergy sounds so cool. I’m sure I could set my middle button to some command upon click, but have not had time to research yet.

But Pop is the server for you and LM is my server and Pop (x2 notenooks) are clients. I never thought of wifi being the culprit for lag…I guess I could try disconnecting a few and see if that helps. Thanks.

As for BT disconnecting, I did encounter that today in trying to get Lubuntu setup on my old Surface Pro 7. Sheesh, the devil was in the details on that OS. Everytime I rebooted, it did not reconnect the mouse and the external monitor went wonky so I had to do “monitor” setup after each reboot. But hopefully it’s fixed now…lol.

UPDATE: Hey, I just tried the X thing and it works by default in LM. I thought you had to have a special plug in or something. Thanks for the tip. That saves so much effort.

Merry Christmas,
Sheila Flanagan

It’s an “ancient” thing from the late 1980’s on UNIX graphical workstations (and also X11 / Motif / CDE ran on DEC VMS / VAX and MicroVAX systems).


There are utils to unify the Clipboard contents, with the X Select Buffer for X11 - but I don’t bother with them - works well enough out of the box for me - and Synergy puts the X Select buffer into the shared clipboard across the computers I control using Synergy - haven’t used Windows in that sort of setup for years now - so I don’t remember how well it worked (if at all).

1 Like

Well I guess Barrier does also. It worked from LM to Pop.

Sheila Flanagan

Not sure how helpful this is in this thread, but maybe helpful later after BT is working.

After @daniel.m.tripp mentioned the wifi issue and how it relates to BT, I did some searching and since the 2.4 gHz range is mostly used, it occurred to me maybe this is why Linux does something I have not understood before now:

When I add a BT device, I will find its name appears as both 3.0 and 5.0. Yesterday in setting up Lubuntu, (and maybe I did this in Kubuntu a long time ago) when offered the mouse 3.0 and 5.0, I chose 5.0. Does this mean because I have both frequencies available that Linux gives me the option? By choosing the lesser used 5.0 does that explain no lag in Barrier?

Curious I had never thought to ask why I get two of the same device.

Sheila Flanagan

My reference to “2.4 gHz” was about wireless HID devices (e.g. keyboards, mouses, headsets) that use a USB dongle (that’s NOT Bluetooth!) - e.g. like Logitech dongles (I mostly detest these 'cause I’m ALWAYS losing them - can’t find the one for my Razer gaming headset, my “gyro” mini-keyboard / remote control, or my Steam Controller [which is now bluetooth as well, thanks to a firmware upgrade from Valve]).

However - having said that - most on-board WiFi devices (i.e.g PCIe devices inserted in desktop and laptop motherboards) also do BT - i.e. your wifi chipset is most probably ALSO your BT chipset.

Your “3.0 and 5.0” confuses me - I’ve NEVER seen anything like this using Ubuntu or Pop!_OS. When I go to pair a device, I only see it once when Bluetooth scans for new devices in pairing mode.

  1. Bluetooth is NOT WiFi
  2. 2.4 Ghz USB dongles for things like Logitech mouses, are not BlueTooth
  3. Many SOHO routers these days offer both 2.4 gHz, and 5.0 gHz, the latter being considerably faster (but still not fast enough, in my experience, for Synergy client on MacOS). I just converted my router’s 2.4 and 5.0 gHz WiFi Access Points, into a single “combo” - not sure what algorithm is used, but in theory, a device will connect on the best / fastest AP (and I’ve no idea how to verify which one).
    Anyway - I do most of my internet and LAN networking on ethernet, which still an order of magnitude, better, than WiFi, IMHO.

Agree 100%.
Try doing an install with Wifi
a Wifi LAN is a pain to setup
the only case that works well for me is wifi between modem and android devices

So after further research, I found two things related to this:

  1. The reason I get 3.0 & 5.0 options must be due to the fact that my computer or device has both BT versions. Versions 1.0-3.0 is Bluetooth Classic. Versions 4.0-5.0 are Bluetooth Low Energy. Did not know about low energy.

  2. Had also noticed when in BT pairing mode that my Sony SRS-XB33 BT speakers show up by that name as well as LE_SRS-XB33 on Pop, LM & Lubuntu. Further research shows that as related to audio devices and is the difference between BT Classic & BT LE (low energy?) and in audio these two use same frequency band but different channel layouts: BLE only has 40 channels. Don’t know much about audio/channels, but found several discussions on forums by audio techs.

So now I know why both of these show up whether it’s a mouse or speaker.

Sheila Flanagan