Wifi driver driver needed for lenovo r500

#21

Just a wild guess, but could it be, that the wifi chip simply is broken (somehow)?
By the way, I had several situations in the past, where e.g. Ubuntu doesn’t recognize a wifi card, but a Mint or SUSE did.
Soooo, maybe test it with another distro (eventually not Ubuntu based (openSUSE or Fedora)).

1 Like

#22

Chances are you will not find the driver. If Lenovo can’t help you are better off to get a USB WiFi adapter.

1 Like

#23

Hello…I did try a usb wifi adapter. The system did not recognize it…any ideas as to why?

1 Like

#24

can you run lsusb with the adapter plugged in and respond with the results?

1 Like

#25

thanks…I’ll give it a try tonight

1 Like

#26

Hi all! I’m guilty of eavesdropping, as this topic is almost identical to a problem I couldn’t solve last summer.

I was trying revive an ancient (2006) HP pavilion dv2000.x laptop. It was one of those under-powered (1.7GHz CPU; 1GB of ram) Vista machines which were too slow to actually download and install Vista service packs needed for them ton run properly: the Vista “compatible” debacle.

So this machine along with untold numbers like it sat on a shelf in a basement. In this case, however, the owner–a professional photographer–was planning a long shooting trip and wanted something for extra memory (especially external drive support) and viewing. By installing a SSD and Linux Mint 18.3 he actually got some solid use out of it.

But one problem I could never solve was wifi. Now, I don’t have access to this machine at the moment, and when I did it was mostly a social visit. I knew there were commands to at least see if the machine saw the card but was forbade from spending a couple of hours finding the right ones. My notes tell it was an Intel PRO/Wireless 3945ABG, also equipped with a manual off/on switch.

It so happened I had a USB wireless card with me and did try “lsusb”. I can’t find the actual output but the card was acknowledged as present. The kernel simply did not use it.

Anyway, I predict Corman 57 will see the same thing. I don’t think this is a driver issue. I think it’s a complication brought on by the on/off switch. I keep thinking it’s a software configuration issue.

3 Likes

#27

@davemerritt great that you’ve had an identical problem and you posted your solution here. I am sure that even if doesn’t help @corman57 then it might help others here. Thanks for posting it and it always good to look at posts to see if you can contribute so thanks for doing so here

1 Like

#28

I wish I did have a solution. Unfortunately I don’t have access to the laptop I was working on and it may have been recycled at this point. But what pricked my ears was the on/off switch. I run an old acer laptop about the same age and lacking a manual switch the wifi works fine.

I can also report–like Corman–that a usb wireless card wouldn’t work either. Literally for the first time in my experience.

I lack the skill on the bash line and the detailed knowledge of the kernel to know for sure but it’s easy to imagine how having a virtual and an actual switch could lead to trouble.

An interesting question would be whether other users running different distros and different kernels have the same problem. It would be interesting to know if anyone else out there is running Linux on a Levono R500 and isn’t having this problem!

1 Like

#29

I don’t know if BigMike has solved his wifi problem or not but this is a the article for him. There’s a very good chance that systemd thinks it’s turning network manager on, but is actually turning it off. I’m going to try some of these bash lines on on mt friends machine the next time we have a chance.

0 Likes

#30

Hello…thanks for the additional tips. I have tried some of them. The problem is I think that the Lenovo does not recognize the WiFi card.

0 Likes