Wifi driver driver needed for lenovo r500


#1

Hello…I am in need of a driver for my lenovo r500 thinkpad laptop. I’m running ubuntu 18.o4. The wifi card installed is an intel wifi link 5100, model 512AN_MMw. The lap laptop does not recognize a wifi card.
Thanks…


#2

Could you describe your problem more detailed? Did you search for the driver? What were the results?


#3

The driver for that card should be in the kernel so you should not have to install a separate driver.

But give us some more information which linux distribution are you using?


#4

Agree plug in and go or check the additional area for drivers … in the control panel

Linux (and Ubuntu as well) doesn’t have separate entity as “device drivers”, Linux has kernel modules which could be called “drivers” for real or virtual hardware depending on their functionality. But that is splitting hairs as they do the job the same and easier to say

But if all else fails direct from Intel at

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

Or email Intel support at

linuxwifi@intel.com


#5

Hello…Thanks for the reply. I am using Ubuntu 18.04 LTS. The computer does not recognize the wifi card.


#6

Again, it would be easier to help if you would describe your problem in more detail… How does it not recognize the card… What did you try to make it recognize the card… How do you know it’s not another issue…


#7

Hello…Thanks for your input. I’ll give it a try.


#8

Hello…My Lenovo R500 laptop does not recognize the wifi card. I initially installed Ubuntu 16.04 then upgraded to 18.04. Still,it would not recognize my intel wifi card model 512AN_MMw. Any chance that the card is defective?


#9

Example

Open a terminal and run this command, it will help you receive the appropriate advice.

  • inxi -ni

This is the output from my Dell 5470 laptop, see card 2, and I’m using a stock Linux wifi driver.

    Network:   Card-1: Intel Ethernet Connection (2) I219-LM driver: e1000e
                     IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full
                     mac: xx:xx:xx:xx:xx:xx

                    Card-2: Intel Wireless 8260 driver: iwlwifi
                    IF: wlp1s0 state: up mac: xx:xx:xx:xx:xx:xx
                    WAN IP: 81.105.187.15 IF: enp0s31f6 ip-v4: 192.168.0.11
                    IF: wlp1s0 ip-v4: 192.168.0.15

The Lenovo R500 has been around for some time, as @ kc1di commented it should be in the 18.04 Ubuntu kernel.


#10

Just a guess:
Does this model have a physical switch to switch wifi on/off?
Like so: https://www.youtube.com/watch?v=vvzFYP8WjXo
Sometimes a special “Fn”-key is used and recognized in GNU/Linux too.
Actually, it seems to be “Fn + F5” for this model.
Maybe it’s switched off in the BIOS?

Just askin’…


#11

i have made this particular error myself :smiley:


#12

Don’t know about the switch. I’ll check…thanks


#13

on my thinkpad t430s it is a tiny switch on the right-hand side of the laptop no longer than 1 cm by a few mm wide


#14

please go to a terminal and type this command and post the output here:
rfkill list


#15

Hello…Thanks for the advice. Nothing works yet. I’ll keep trying.


#16

hello…I just emailed Intel for a driver.


#17

Please give us the output of the rfkill list command


#18

How have you got on with this? Any update and if was solved can you let the community know how it was please


#19

Hello…Emailed Intel…was told driver should have been included in Ubuntu kernal.
Thinking about purchasing a new internal wifi card. The computer is old…just thinking about options…thanks for checking


#20

Also…tried switch and fn keys…no sucess