Win10 ISO mounted to USB but PC won't recognize

I am trying to install Win10 on a Z620 I got for free. I have tried to create a bootable USB with the Win10 ISO for several hours with no luck. I have formatted the USB as GBT then partitioned the entire thing as exfat, then transferred the Win10 ISO files over to the USB.

Also have tried using image writer…

Nothing shows besides Ubuntu in the UEFI location when trying to boot from the USB.

I am lost, I have Linux Mint (Cinnamon) currently.

Wecome to the Forum Itskrayz

Problem with Windblows is that normal USB stick ISO writers don’t work here in Linux with Windows ISO So the app you need is called WOE-USB scroll down to the bottom of this page.
Instead of formatting USB to Fat32 format it to NTFS which is Windows format, as Windows 10 is now over 5GB and Fat32 only reads up to 4GB. There is also this tutorial too Woe USB


They are still not showing as uefi bootable.

Sounds like you have not gone into Bios and picked out your USB to boot into? It won’t show up on your hard drive’s grub, you have to pick out the USB in Bios or sometimes there is a button to press to get into boot screen with all available drives. As your computer boots up with it’s logo on screen. The name of your computer once you see numlock light comes up on your keyboard try a F11 F2 F8 buttons to get into bios. Also is it setup for UEFI? Is it set to Legacy mode only? Does it even support UEFI? What memory do you have on this as a lot of these computers come with DDR3? What year was it made? Is it the latest one with support for PCI Gen3? If so you should have UEFI. Once you get into the boot screen list of drives it should say the name of your USB and underneath UEFI boot options.