Window 10 not reading Linux ubuntu installed on separeate Hard disk

Any of the tech geeks who can help solve my this problem I would be very greatful to you.

I m using Acer a515-54g as a laptop which came with i5 8gen and preinstalled windows.
I already had a harddrive with ubuntu installed and was using that in some other laptop , I decided to add that to that acer laptop with windows.
the harddrive was having both ext4(for linux installation) and ntfs(my previous windows data) partitions to it , so after plugging plugging it it as a secondary drive to the acer laptop it worked but was only able to see the ntfs partitions and the linux partitions were kind of visible only in diskmanager but unexcessible.
I wanted to boot to ubuntu on that drive but i m unable.
Kindly suggest me any solution for this.

Welcome to the group.
Give this a try;

A small bit of my advise…dump Windows and use ONLY Linux. IMHO, that is the best solution.

Thanks But my problem was majorly with not being able to boot from that drive ,
And yes I would have preferred linux over windows if linux in some near future starts having more applications like that for windows .
So for now any help how to solve that boot problem will be great.

Does the BIOS support Legacy or is it UEFI only?

Even so - you might be able to interrupt boot and select the other 2nd disk as boot device and see how you go?

e.g. it’s the same key on Lenovo and Dell “F12” will let you select some other boot device (e.g. like how one might boot off a USB thumb drive to install Linux).

bios is on uefi mode , that other thing you said about accessing the boot menu via F12 key i did that but was able to see the window boot loader option there the other booted harddisk is not even there.
but when i used that bootable pendrive i was visible in that menu and thus i was able to try out the ubuntu of that pendrive.
but Its no for the harddisk ubuntu system.
You might tell me to change the uefi to legacy but i have seen people doing it with the uefi system too, so i gess thats not the problem unless the ubuntu so installed was via the legacy mode “well I don’t know about that now” .
Also i tried disabling the fast boot option
i also tried to select a trusted uefi file but there was no ubuntu shown only the disk was visible.
i don’t want to format the haddisk again and fresh install it cuz it already have lots of programs which i installed earlier.

Sorry - can’t be of much further help to you mate - I don’t dual boot, or even run Windows, anywhere…

No worries,
thank you for your concern though
I wouldn’t have done it either if it wasn’t for lack of resources

How did you do this?
I had a notebook with win10 on it and an UEFi-only BIOS that won’t boot from GNU/Linux USB.
I had to select the uefi file from the bootable Stick in the BIOS to get to boot from USB.
Just as a hint.

Here you go hope to be an answer to your question :slightly_smiling_face:

Yes, sure. Every BIOS is slightly different, on my notebook it was in another section.
But yes, that’s what I did to get USB to boot.

And you selected the EFI-file from your HD installation?

OK, then I have no further ideas for now… sorry

The thing is that like in the video the person was able to see and select Ubuntu and that grub for it but for me there was no thing like Ubuntu or any other thing.
So basically this video was not any help for me , I thought that your case might be different from me so i suggested the video.

In my case I had to choose the file from my installation medium (USB stick).
Maybe you can try to get it from there?

Sorry but I didn’t understand ,what file you selected?

When I chose to add a trusted source, I was presented with a dialog to choose an EFI file (e.g. BOOTX64.EFI). This file was on my installation medium (USB stick).

Maybe the following threads help:
[SOLVED] Linux Mint 19.3 only boots through EFI file - Linux Mint Forums (see answer 3)
EFI — Linux Mint Installation Guide documentation

Explain what “plugging it in and using as a secondary drive means” etc, USB port or internal sata port.

I think you should do a clean re-install. It’s hard for us to guess all the information needed to properly assess the situation. For example, how does your GRUB2 look? Where is it installed? Did the installation work before?
How did you plug it in? What exactly did you do? What’s the difference between the previous and the current machine?

Too many questions. Not worth the time. Just do a clean re-install and restore a backup with your most important files.


You need to reinstall Ubuntu on that drive. As you had moved Ubuntu out of another machine, it does not know that you have Windows on another drive. If you reinstall Ubuntu on that drive it will pick up on Windows and you’ll be able to dual boot properly.

1 Like

internal sata port is what i meant.

yeah i guess that’s what i m headed for now :joy:
thanks for the suggestion by the way

thanks for solution ,
i m too thinking of doing it but if it does not work even than , then i think virtual box will be my option.