Windows boot option not showing

Taking latest NeptuneOS out for a spin.
As usual, simply installed onto unallocated space created in Windows.
This worked so far with many distros.
Simply missing option to choose Windows at start up.

1 Like

The command line would help immensely with this issue. sudo os-prober is a command to help detect the other OS’s installed. After using sudo os-prober, then you will need to update grub. There are various commands depending on your distro for updating grub. Try sudo grub-mkconfig -o /boot/grub/grub.cfg

You may need to refer to the NeptuneOS forum for the correct commands.

/dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

MX has a handy boot option app.

Come to think of it!
Grub-customizer usually does the trick, but it’s not in Neptune’s Discover.
And Discover does not have Synaptic…

Update: Grub-customizer is already installed in Neptune ha!
But Windows does not appear in the options.

Generating grub configuration file …
Found linux image: /boot/vmlinuz-6.1.0-3-amd64
Found initrd image: /boot/initrd.img-6.1.0-3-amd64
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings …

Windows still appears in UEFI settings.

One workaround (for now) is to add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub


You’re an ace Bud! :smile:


1 Like

Sure thing, sir. I’m glad I could help.