Windows partition read only in 18.10


#1

How can we allow write permissions to Windows 10 drives in a Windows 10 - 18.10 dual boot machine ? Currently, everything in NTFS is read-only.


#2

Hello.
Don’t know, if this applies here, but Win 10 does no “real” shutdown when switching it off.
Maybe you can try to shut down Win 10 by holding the shift key and then clicking “On/Off”.
Or restarting the system, that would do the trick too (I guess).
Just a guess, for I have no Win…
When trying to rescue some data on Win 10 systems I experienced this phenomenon, that Linux said, the system is “dirty” and the partition can not be mounted.

Greetings
Fast Edi


#3

Control Panel\Hardware and Sound\Power Options\System Settings
is where you can turn of fast startup. You should also be able to turn off Fast boot in your UEFI.

sudo apt remove ntfsprogs && sudo apt install ntfs-3g
sudo fdisk -l | grep /dev/sd
sudo mkdir -p /mnt/Windows10
sudo mount -t ntfs /dev/sdX1 /mnt/Windows10

should do the trick in most cases. X is the final letter of your HDD within your Linux system. Let’s say, you have 2 hard drives, one for Linux, the other one for Windows 10, then probably your Windows 10 HDD will be /dev/sdb, so you need to mount /dev/sdb1.


#4

So this is due to Windows 10 not shutting down properly ? Those 4 commands can fix it ?

I have Windows of sda2 and 18.10 on sda1


#5

Those 4 commands fix your Ubuntu’s possible incompatability with NTFS drives. If you want to fix the not shutting properly problem due to hibernation, you have to actually “shutdown” your Windows 10 and not “hibernate”. Maybe the following options could help, but I have them turned on and my Debian still doesn’t complain. But I actually shut down my Windows 10, rather than hibernating it.

I actually found an extensive confirmation of what I was saying.


#6

I have a similar situation - i.e. I have some partitions which are NTFS because I need to be able to access them from Windows, but I also need full access to them from my Linux systems. I find the best solution is simply to include the partitions in /etc/fstab. The example below (edited) is of just such a partition in my system: -

/dev/disk/by-uuid/{uuid of the partition} /media/{username}/{foldername} ntfs-3g defaults,uid=1000, locale=en_GB.utf8 0 0

I chose to have this partition mounted under /media, but I have other similar partitions mounted under /home.

The items enclosed in {…} would need to be replaced by the relevant values for your scenario.

I have quite a few NTFS partitions, and several distros from which I need to access them, and I use the same basic method for every distro (i.e. I copy the relevant lines from the fstab on my main distro into the fstab on each of the other distros).


#7

What works for me is as follows.

  1. When leaving windows for another OS don’t use ‘RESTART’, use ‘SHUTDOWN’.

  2. (This step was necessary for me in the early releases of Windows 10, but has not been necessary recently. I include it just in case.)

Do the following:
Settings
Power & Sleep
Choose what the power buttons do
Change settings that are currently unavailable
Uncheck FASTSTART
Save

(FASTSTART supposedly allows Windows 10 to boot faster by not completely shutting down in the first place. In my experience, the boot time saved is so small as to be unnoticeable so I prefer a complete shutdown)