Wine install issues

Im running Kubuntu 20.04. Following the instructions on the above page I get errors.

The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 6.0.2~impish-1)
E: Unable to correct problems, you have held broken packages.

Reading in other forums many said they used development version but that did not help me. Same issue. Another post said to install:

Ubuntu 21.10 sudo add-apt-repository ‘deb Index of /wine-builds/ubuntu impish main’

I tried it - same problem.

Using Synaptic I have 5.0-3ubuntu1. Attempting to install that will remove hundreds of packages. Attempting to install winehq-stable 6.0.2~impish-1 said broken dependencies. Trying any version other than the 5.0.3 has the same problem.

Wine install has been broken in Ubuntu for awhile. Do not follow the instructions at wineHQ they will not work on Ubuntu or derivatives. Follow this instruction set found in the Ubuntu Handbook.
How to install wine 6.0
You can also use Playonlinux to download and install different versions of wine playonlinux is in the ubuntu repositories. once installed, open it and go to tools> manage wine version from there you can install any version from old to newest. Good luck.

How do you run this:
sudo apt update && sudo apt install --install-recommends winehq-stable

and NOT upgrade Brave browser?

The handbook link didnt work. I had the same issues.

PlayOnLinux has the same problem as trying to install wine from the repos - wants to uninstall tons of packages.

This is a reasonably recent install on this new system so Im surprised Im having these issues.

You will have to go in and disable or remove WineHQ repositories before playonlinux will work properly or before the Ubuntu Handbook will work. Remove those repositories first.

Removed the repos, updated, same problem

This list is VERY long

no you don’t want all those remove for sure.

Right, but, there isnt the option to not do it.
Its either remove them or… dont install.

Try this:

First fully uninstall wine that exixts on your machine.

sudo apt-get remove wine --purge

Then update and upgrade

sudo apt update

sudo apt upgrade

Next enable “multiarch” in the terminal to define thesystem architecture. After that, update again.

sudo dpkg --add-architecture i386

sudo apt update

Then install wine

sudo apt install wine64 wine32

The following packages have unmet dependencies:
phonon4qt5 : Depends: phonon4qt5-backend-vlc but it is not going to be installed or phonon4qt5-backend wine32:i386 : Depends: libc6:i386 (>= 2.28) but it is not going to be installed

Depends: libwine:i386 (= 5.0-3ubuntu1) but it is not going to be installed
wine64 : Depends: libwine (= 5.0-3ubuntu1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Tried to install libc6 i386 but it says libc6 is not installed - however - it is.
I click to install anyway and I get this:

Depends: libc6-i386 but it is not going to be installed
Depends: libc6-dev (=2.31-0ubuntu9.2) but 2.31-0ubuntu9.3 is to be installed
Recommends: gcc-multilib but it is not going to be installed

Looked up libc-dev and it says it has to remove libc6-dbg, downgrade dev-bin, libc6, and libc6-dev … then install 25 other files.