Wine installer drops out and says I need .net 4.0 but

… when I go to install .net 40 the message says it’s already installed?
What?
Installing a MindMapper program when this message stopped me.
I just installed Wine 5.0.

Can you tell about the situation exactly? I mean, what did you do in what order?
For example:
-installed WINE (pre 5.0)
-created your wine prefix (32/64 bit?)
-installed dotnet40 (via winetricks maybe?)
-upgaded to WINE 5.0

And now you can’t install your program?
Or you started with WINE 5.0, and had nothing before?

Installing Wine 5.0 was a complete FUBAR but eventually it installed.
I don’t remember installing .net40 but it says it is - probably via another program; and from what I understand from other boards MindManager has never worked in Wine.
So, there it is; now I’m looking for another program that accepts and does a decent job with mmap files.

For an alternative I’d start looking here:
https://www.xmind.net/

For sticking with wine, first of all I’d backup my wineprefix - in case there’s anything useful in it, which works already.
Then I’d try to force reinstall dotnet, something like
winetricks --force dotnet40
Then give it a go.
If that fails, I’d start over with a brand new empty wineprefix, and retry…

I tried it; pretty disappointing.
It doesn’t look like you can actually save your work with the free option.
Just another tremendous waste of time.

I’m really sorry you’re stuck at this point.
With WINE I can’t help more remotely.
I don’t know much about mindmapping, so I may be wrong.
But I could download the program (an rpm package) from their website. I looked into it because I got courious, and now I see this is an Electron app. So I just unpacked it, and managed it to run it on my Debian system. XMind greated me, and allowed me to do something:
I added some topic and subtopics randomly, and I also could save the thing.


However, there’s a red sign, that it’s trial mode…
So, because it’s about Linux, does not necessarily mean it’s about a free of charge software.
This is a paid software. (I wasn’t aware of this fact when I suggested it, it was just a promising search result.)
You can try it, and if you like, you can buy. Maybe if you buy it, you get support with it too?
I would buy it, if I’d need it, just like I did it with Softmaker Office, and Turboprint for Linux.
If you don’t want to buy it you can have a Windows in a Virtualbox just for your mindmapping software. I do this VBox thing too, because I have a software from the past and I need it really, but that doesn’t work under WINE, and for that there are simply zero alternatives for Linux. I don’t need this software daily, only occasionally, but then it’s vital.
This Vbox approach may work for you too.

Thanks man, I guess I’ll try that VB thing next but I may try to find something open source and see what I can add to that.
I don’t know. Honestly, I’ve never been happy with any Mindmapping software that I’ve seen.
I think I’ll stay away from Xmind altogether as they seem to have no help there either as far as a manual goes.

Not at all…
Again, mindmapping is not my business, for that in first place I would need a mind :laughing:
I just noticed, that this thing creates something that makes me remember of flowcharts somehow.
So you could check Dia.
http://dia-installer.de/download/linux.html

This is a crossplatform app, which is capable of drawing a lot of things, maybe you could use it for your job?
Basically it’s for flowcharts and other diagrams, but I used it for drawing schematics a while ago.