XDA question but posting here

Greetings friends,

I know this question belongs to xda, but I’ve perused through it for my issue and no one there is bothered, hence checking with people here.

I imagine that there must a a good chance of some members here overlapping with android communities.

Ok,here it is - I’ve an old tablet, ASUS Fonepad 7 ME175CG-1A007A. I wonder if there is some way to install a lightweight custom OS on it. Lineage OS doesn’t have anything for this model. Also, if I understand correctly, phones are unlike PCs and every model has to have the custom ROM tweaked for it.

But, dear members, if you do know something–perhaps an innovation in nascent/prototype stage maybe–please do chime in.

PS: I won’t throw this device because it is very, very sturdy; dropped it scores of times and it is undamaged. No hardware, battery issues either (and exchange value is zero, if at all I can find a buyer/vendore who is willing to exchange it)!


I did a internet research which I imagine you have also done and found lots of requests but no answers, except

I don’t know how good your french is and if you are able to follow the commands or software to unblock your fonepad so you can get to the next stage…

I don’t have the same model and have never done this so cannot be much of a guide except translation from french to English.

Be warned that it can go wrong and you may end up with an non working device . Not sure if that is your intention and if it’s no good now it cannot get worse…

Thanks for the reply Paul.

Yes, I know these methods and, in fact, kingoroot doesn’t even work for my device. Used google translate to read the page.

Let me now try Towelroot, perhaps it will work.

My French is elementary, at best :smiley: (as a sidenote, I do enjoy French movies, especially the older ones, with subtitles; wonder if you could recommend some good, slow burn style movies from 80s/90s; I like Le Jetee, Three Colors Trilogy, the Double life of Veronica etc.).

Now let me check towelroot and come back here.

I’m glad someone edited the topic, I couldn’t understand how that web-comic (XKCD) related to Android :smiley:

Changed it. Never knew it was a comic strip :smiley: why did my mind confuse xda for xkcd . . . I wonder? At middle ages, you become a subconscious, involuntary remote viewer… :ghost:

1 Like

Alright, Towelroot doesn’t work :expressionless:

Sorry don’t have any other suggestions on the android front not my special area
Cannot help either on the film’s as we do not watch TV or go to the cinema
Not being native french a lot of the culture passes me by and I rely on my french wife for lots of translation in the written form
Good luck in your quest

1 Like

No problem and thank you.

Have a great Sunday!

1 Like

I am afraid I have some bad news for you, that tablet is basically unrootable after a firmware upgrade Asus pushed back in the day. I remember updating mine to that, and it would not let me unlock the bootloader. I could unlock it before that update.

If that is the case can you not do a factory reset to before that event then try to unlock it

Perhaps @sourav is right. Even if we do a factory reset, it would take you to the reset state with the new firmware. Don’t know if there is a way to downgrade the firmware.

And it is really sad because that is one of the toughtest device of any kind I’ve ever purchased. Very good build quality. If only I could get it on a lightweight ROM :frowning:

1 Like

Thought factory reset took it back to before a firmware update, as you have nothing to loose by trying

1 Like

What’s the most recent version of Android on it ?

Termux is supported on Android 5 and later… I use Termux on my Samsung Galaxy S9+ (Android 10 - won’t ever get an official Android 11 from Samsung - wayt to go Samsung EOL your flagship handset after 4 years!) all the time - I used to have huge problems with it using the app from the Google Play store - thinking I couldn’t use FDroid (F-Droid - Free and Open Source Android App Repository) on Samsung (thanks to KNOX!) - but I managed to get FDroid working and installed their version of Termux which is fully supported by the developer…

Can’t say enough good things about TermUX. You can even run SSHD and ssh to your phone and get a Linux shell. You can install a whole bunch of shell utils in TermUX too (e.g. git, rust, zsh [haven’t tried gcc though!) - and I’ve heard of people doing stuff like using TermUX to install a Linux DE ontop of Android (not sure if you need root for that or not).

I don’t need a Linux DE on my handset - screen’s too small, eyes too weak - and I find when I use DeX (i.e. Samsung’s “Desktop Mode” for Android - use a USB-C to HDMI dongle to an external monitor) - that’s good enough for me (and TermUX is “DeX” aware).

I wrote a shell script to run from my Linux desktop machines (no reason why it shouldn’t work on MacOS either) to pull today’s photos down off my Galaxy S9+ running sshd in termux :

╭─x@titan ~/bin  ‹main*› 
╰─➤  bat today-photos.bash 
       │ File: today-photos.bash
   1   │ #!/usr/bin/env bash
   2   │ # Grab today's photos off a samsung piece of crap
   3   │ # 
   4   │ DSTRING=$(date '+%Y%m%d')
   5   │ DSTRING="$DSTRING""_??????.jpg"
   6   │ YY=$(date '+%Y')
   7   │ echo $DSTRING
   8   │ echo $YY
   9   │ # source folder on the samdung crud :
  10   │ SRC="/storage/8FC6-9FA1/DCIM/Camera/"
  12   │ # e.g. 20230705_161756.jpg
  13   │ # counting on "homedung" having an entry in ~/.ssh/config or ~/.ssh/home (might be a symlink)
  14   │ # if it's at home it should be :
  15   │ HO=homedung
  16   │ # set -vx
  17   │ DEST=$HOME/ResilioSync/bigshit/Photos/$YY/Camera
  18   │ if [ ! -d $DEST ] ; then
  19   │     echo "$DEST doesn't exist... yet ..."
  20   │     echo "exiting..."
  21   │ fi
  22   │ echo "$SRC"$DSTRING" to $DEST"
  23   │ echo "Source = $HO:$SRC\"$DSTRING\" Destination = $DEST/."
  24   │ echo "rsync -av $HO:$SRC\"$DSTRING\" $DEST/"
  25   │ echo "or even : "
  26   │ echo -e "\trsync -av $HO:\"$FSTRING\" $DEST/"
  27   │ # echo "rsync -av $HO:$SRC\"$DSTRING\" $DEST/"
  28   │ # rsync -av $HO:$SRC"$DSTRING" $DEST/
  29   │ 
  30   │ 
╭─x@titan ~/bin  ‹main*› 
╰─➤  ./today-photos.bash 
/storage/8FC6-9FA1/DCIM/Camera/20230711_??????.jpg to /home/x/ResilioSync/bigshit/Photos/2023/Camera
Source = homedung:/storage/8FC6-9FA1/DCIM/Camera/"20230711_??????.jpg" Destination = /home/x/ResilioSync/bigshit/Photos/2023/Camera/.
rsync -av homedung:/storage/8FC6-9FA1/DCIM/Camera/"20230711_??????.jpg" /home/x/ResilioSync/bigshit/Photos/2023/Camera/
or even : 
	rsync -av homedung:"/storage/8FC6-9FA1/DCIM/Camera/20230711_??????.jpg" /home/x/ResilioSync/bigshit/Photos/2023/Camera/

Note : it doesn’t actually “pull” anything - but it shows me the rsync command to run manually… I’d rather use a wildcard than “???” but the shell doesn’t like that and I couldn’t be arsed debugging how to properly escape “*”…

If you need any help setting up sshd to run on your Android - hit me up… default behaviour is not to use port 22, and you can’t use root…

1 Like

Sadly, doing a factory reset doesn’t roll back the firmware, and other methods of rollback were shut out due to the new firmware.

1 Like

@daniel.m.tripp errm…most of what you wrote went above my head :smiley: ; searched and realized it is a terminal emulator, but what would I do with it, can it help me? :thinking: This tab has just 1 GB RAM (hence the need for a lightweight custom ROM).

To answer your question, android version is: 5.0 Lollipop. Also, I could install F-droid (version which is compatible with 5.0 android; does F-droid contain a lesser known master app which could root this device…? :thinking:), though it has very few apps which run on this devices – most are either incompatible or marked as anti-feature.

I don’t have any other suggestions on unlocking but wonder if you could try other software apps, for example I have an old Samsung tablet on old version of Android but to keep it working I use opera to browse the web, just for one site…

Sorry mate - didn’t realise how limited this device was - I assume it’s probably a single core as well…

I hardly ever throw stuff out - I have a drawer full of old phone handsets - if I had one of these devices - I’d probably chuck in the drawer too…

The only old handset I’d consider reviving is my Nexus 5 which was great (because it’s a Nexus - it’s not locked down) I ran MaruOS on there until the battery died (it didn’t just die, it expanded till it nearly exploded) - and the Nexus 5 was quad core with 2 GB of RAM (plenty enough to run the XFCE desktop and debian 8 chroot that came with MaruOS).

I even tried Ubuntu Touch on it (Nexus 5) - but the hoops ya gotta jump through just to get sshd listening didn’t seem worth it and went back to MaruOS.

Damnit! This just filled me with nostalgia for my Nexus 5 with MaruOS - I can get a battery for $25 for it - might get two on payday (friday)… Nexus is a bit limited - only 32 GB storage - with no SD-Card expansion - and MaruOS uses the android kernel still - which has NFS >>>REMOVED<<< (why did they do that - it broke a bunch of other stuff too - i.e. RaspberryPi alternatives using the Android Linux kernel??)

Indeed, Opera Mini is the only browser which gives decent performance (without hanging the OS).

So…until the time someone comes up with a way to root old devices, I should just, occasionally, watch videos on it (while travelling; instead of carrying bulky laptops). Sideloaded videos work just fine on it (full HD), with MX Player.

Hmm… :thinking:

Here we go: Asus Fonepad 7 - Full tablet specifications

Platform OS Android 4.2 (Jelly Bean), upgradable to 4.4.2 (KitKat)
Chipset Intel Atom Z2560
CPU Dual-core 1.6 GHz
Memory Card slot microSDHC (dedicated slot)
Internal 8GB 1GB RAM, 16GB 1GB RAM, 32GB 1GB RAM