Xubuntu 20.04.1 installed on MacBook Pro 3,2 mid 2007

Hello there, in the past I installed Xubuntu 16 and 18 on my old MacBook Pro which has not been supported anymore by Apple for years. Both versions worked for some time but one day there regularly were problems at startup and I forget about the old Apple. Last week I tried to run Xubuntu 20.04.1 on it and the tryout version worked fine!! So I chose to install the complete version instead of the Apple OS software and that went fine, too. All checks were OK and installation went smoothly. However, after trying to startup the next day, the message: /dev/sda2: clean xxx/xxx files, etc, appeared and Mac stopped there. I can still open recovery mode and all items of it seemed to work. I found out that this machine has a 64 bits processor with a 32 bits EFI. I tried everything to get it started, even tried to install version 14.04 32 bits, but I have lost control now. What else can I do before throwing this (at that time very expensive) Apple out of the window?

You should post the entire list of messages, especially the ones showing right before the crash or whatever exactly happens when you boot up.

1 Like

Hi Akito, thanx for the quick reply! I have attached two pictures of the screen that occur at bootup. That is all I can send you because I cannot go back to previous installations. The black and green lines disappeared after bootup to other versions in the past.

the green lines make it look like it could possibly be an issue with your graphics processor. after you boot into recovery mode, can you run the command
inxi -Fxz
in a terminal and post the output here?

Hi 01101111, hereby the output of inxi -Fxz.! Hope it will help you to help me! P1030946|666x500

as you can see in the line for Graphics, you have an nvidia graphics processor (gpu). sometimes these can be troublesome for ubuntu. you do appear to have a proprietary driver (340.108) installed, but it may not be working well enough to allow you to boot correctly.

my suggestion would be to try to boot with the “nomodeset” kernel option to see if that will allow you to finish booting and then better be able to try and fix things. close to the bottom of the page linked below you should find a section labeled:

How to enable nomodeset option when booting from hard disk

The nomodeset procedure via GNU Grub did not work. I will try this again with the install DVD tomorrow.
One more thing: the black and green lines were already there when it worked with Apple OS and later with Xubuntu. After booting it disappeared and stayed away till the next boot session.
Thanx for now!

What exactly “did not work”?

1 Like

After changing to nomodeset there was no difference. The computer did not boot up, so the change to nomodeset did not work.

1 Like

if you don’t have a whole lot of time invested in this installation or personal settings you are trying to recover, have you considered trying to install again to see if maybe the first time just didn’t work correctly? i noticed you said you tried to install 14.04, but not whether or not you had tried 20.04.1 more than once.

1 Like

I have the similar issue with my own Mac book pro but using Linux mint 20 mate version
First boot fails on screen similar, so I allow it to fail, then restart go into recovery mode, advanced settings, and select verbose start-up
Then it’s fine
Checked the graphics and mint tells me it’s the correct one
Run all the start up diagnostic options
're installed several times
Updated the grub
And all the same as before
Pain in the … But after all this it’s a super machine

Will be interested if you get a working fix but suspect it’s something to do with graphics cards and Apple start up which you cannot get to

I now have invested too much time on other installations and files to go back to basics on it so may just take the hard drive out and put it in another box then 're install Apple system on this one again even if it’s limited to leopard it’s better than Windows plus if I spend time may even get it to el captain…

1 Like

Amen! I’d rather use a RPN calculator than be forced to use Windows :smiley: - having said that - I am FORCED to use Windows - it drives me insane that to SSH to a Linux or UNIX server I support, from my Linux desktop at home (or at the office), I have to Citrix, then RDP to an intermediary jumphost, then I can use PuTTY or MobaXterm… enfuriating…

Sorry for hijacking this thread… rant over:
I did have great success dual booting OS X and Xubuntu 16.04 on a 2,1 iMac - 32 bit only (I’ve read its possible to upgrade these models to a 64 bit capable CPU and 4 GB of RAM - but also needs an openboot/BIOS/UEFI firmware update) - for about 12 months - using RFEind (I think that’s what it’s called - it’s some UEFI doohicky) - but then Xubuntu refused to load, and I put it down to the HDD failing, and shoved it all into the “too hard basket” because these things are a nightmare to crack open!

1 Like

Thanks for your help Paul. I am going to try it and keep you posted. So far I spent many, many hours to make the old Mac work again and at the moment the keyboard and DVD player won’t work anymore…

1 Like

Also thanks for your words Daniel! Hope to get it working again…

1 Like

Hi 01101111, I spent a lot of time getting the Mac work again! I was very happy that the tryout version of Xubuntu 20.04.1 worked fine. I decided to install the complete version of it and skipped Apple OS fully. Then the boot problem occurred and I tried to install 20.04.1 again. Unfortunately the DVD player did not work anymore so I tried an extern USB one which also did not do it. After that I tried a Prepared USB stick without success. Now I am at a loss…

Hi everybody, I have tried all your tips for which I thank you very much! All of a sudden my external USB DVD drive worked again so that I could reinstall 20.04.1. During the whole period no errors were detected and everything seemed alright. But then I had to restart the Mac and I was back where I started some weeks ago. I attached two pictures as a proof that installing was a success, unfortunately restart was not…

https://www.mail-archive.com/ubuntu-bugs@lists.ubuntu.com/msg5746100.html

So apparently the error you are getting on the first line, should not be responsible for the issue at hand.

Could you try installing a different version or distribution?

What

were there on the old version?

From the information you have provided until now, it seems like the hardware has an issue.

1 Like

Hi Akito (and others), after having changed COMPRESS=lz4 to COMPRESS=gzip, the mac finally started up!! See picture. I am only afraid to shut it down at the moment…

1 Like

You’ll have to do it eventually. Try it now and report back. If that’s the solution, might as well mark it as one for future readers.