Anyone trying it should read this

Just a few notes to all that plan to try it:
– Running it live works as expected for what it is intended.
– If you plan to install, it is important to boot into the “default” boot entry prior to installing. The installer has unpredicted behaviour breaking a few things (reboot, poweroff) if you install using the non default init entries.
– To enable the multi-init grub menu after first install from iso just run
sudo dpkg-reconfigure grub-multi-init-enabler

Username = antix
Password for user and root = antix

It applies to the Antix version.

1 Like

Latest antiX versions here:


There are two cases

  • corporate use, servers, etc. What you say applies… S6 is the best chance of replacing systemd
  • home computers. Dont require supervision, only service management. A much simpler init system , like OpenRC , is needed for home use. Home users have had unnecessary complication foisted upon them.

I feel it is unfortunate that you did not include OpenRC.
That is not a criticism. You have made an amazing step

I tried this ( in live system not an install)

cd /sbin
rm init
ln -s init-runit init
kill -1 1

I either did nothing or restarted the original sysvinit init?

So, if it is not too involved, can you show us how to switch init systems ‘on the fly’ ?

Well I actually have provided OpenRC (after I created the antiX & MX spins), which is available in my repos.
All these spins are primarily intended to be installed rather than run live.

Link to post:

Oh, that is great. It fills a big gap.

I will get to installs. It pays to learn a bit first.
We need to give this a thorough workout.
Thanks for the help.

1 Like

Tried my first install… in a VM
No problems.
It seems identical to a normal Antix install
It boots to a B&W grub screen
All 4 init options are there, plus the default (top line)
It is difficult to pick which is which, because the lines dont wrap… they are in order default, sysvinit,runit,s6-rc,s6-66.
They all boot OK.
Things I noticed

  • the pointer /sbin/init no longer is set in the installed systems… it must be
    some trick for the live system only
  • The Antix Control Centre->System->Choose Startup Services GUI works for
    sysVinit and runit, but not for s6-rc or s6-66… ie it only works for the init systems which Antix currently supports officialy.
  • No matter which init version you boot, all the files are present for all systems.
  • s6-66 is causing me some confusion. In some of the distros I have tried
    the command to start a service is of the form 66-start service, but in this
    init-diversity install it is of the form 66 start service. I think 66 is rapidly
    evolving , and the versions differ.
  • If we look at how the sysvinit version boots

    the parameter init=/lib/sysvinit/init is written into the kernel boot commandline, presumably by grub. So this is how each init version starts the
    appropriate init process. It is hardwired into grub. What follows after PID#1 is started will then be appropriate for the chosen init system.
  • One consequence of doing it this way would be that it would be difficult to mix and match - eg use the sysvinit init with the s6-rc service management.
    That is not a big issue, but people often use OpenRC as a service manager
    on top of sysvinit, so it does arise.

The VM install was no problem.
I wonder what would happen with a hard install, if there were already a grub present which one wanted to preserve? I dont see how one could have this special init diversity grub menu, and preserve an existing multiboot grub
setup. I was not game to try.


The first grub entry should (always) be booting /sbin/init

Under Applications–>Preferences you will find the s6-rc service manager. We don’t have a gui for s6-66 or OpenRC (yet)

You are right, antiX is using the brand new version of 66 (even before Obarun) in this spin which is now inependent of s6-rc.

That is correct, grub is configured to look for specific inits in specific locations, & pick them-up in an update-grub invocation.

sudo apt update && sudo apt upgrade -y && sudo apt install -y openrc lib-openrc-init && sudo update-grub

would install OpenRC & have it picked-up by grub

It doesn’t hurt to try if you can spare a 10gb partition. I have tested installation on a few real systems (& so have others), nobody has reported anything bad happening.


I tried this in my installed Antix_init_diversity.
Starting in the default boot item,I did

apt update
apt upgrade
apt install -y openrc lib-openrc-init

I ignored the install warning about what to do if replacing sysVinit with OpenRC.
On reboot I get 6 grub menu items, and the last is OpenRC…choose that
and it boots with OpenRC

$ ps ax | grep init
    1 ?        S      0:00 /lib/openrc/openrc-init
 2028 ?        S      0:00 avahi-daemon: running [antix-init-diversity.local]
 3047 pts/0    S+     0:00 grep init
$ cat /proc/cmdline
root=UUID=684ae611-4b4c-4561-a356-9fe5a8640a7b ro quiet selinux=0 init=/lib/openrc/openrc-init

There you can see openrc-init is running, and the cmdline shows it
being set as init=/lib/openrc/openrc-init

There is an extra entry in /sbin

$ ls -l /sbin/ini*
-rwxr-xr-x 1 root root 52400 Feb 25 12:22 /sbin/init
-rwxr-xr-x 1 root root 23352 Mar 16 12:22 /sbin/init-openrc
-rwxr-xr-x 1 root root 22944 Feb 25 12:22 /sbin/init-runit
-rwxr-xr-x 1 root root    71 Feb 25 12:22 /sbin/init-s6-66
-rwxr-xr-x 1 root root   120 Feb 25 12:22 /sbin/init-s6-rc
-rwxr-xr-x 1 root root 52400 Feb 25 12:22 /sbin/init-sysvinit

and the openrc commands work, eg

When I look in /boot/grub/grub.cfg there is an entry for every init version, including OpenRC.

So simple. Unbelievably easy.
This is very impressive.


I looked , there is runit and s6-rc

Under Control Centre there is sysVinit and runit.

Not surprised you dont have s6-66 yet, nor did I expect OpenRC.

BTW: Antix is the only distro ( to my knowledge) that has a GUI for service

That is a big plus for Antix. Everything else is CLI only.


I would not try on my main system. It may mess with a very complicated multiboot setup.
I have a spare PC with only Debian and Gentoo on it. Will try with that.
I want to see if it preserves my grub setup. Do backup first.

Those were only required because of a limitation (or feature) of the antiX live mastering tools. It is safe to keep /sbin/init & delete all others on an installed system if you have no intention to remaster another live iso from your installed system.

1 Like

That is what the Debian docs say

The default file path for the init program is " /usr/sbin/init " 
but it can be changed by the kernel boot parameter as
 " init=/path/to/init_program ".

Now I understand those entries in /sbin
If, in the default version, I make /sbin/init a pointer, then default will boot whatever I point it to. The other versions will be unaffected, because they
override it on the cmdline.
Changing the pointer in the non-default versions will do nothing. They override it.

I have had a a long struggle with s6-66 in Obarun. Never really got a full
understanding and could only get some commands to work.
I think I will start again in your Antix.

Something else interesting . Adelie Linux has s6 init and supervision, combined with OpenRC service management. I could digest that a lot easier than
s6-rc or s6-66.

There is a simple principle with 66.

  • NEVER copy or edit any files or folders manually (except for frontends).
  • Learn the 66 commands to make modifications.

Once you get familiar with the 66 commands & the 66 frontend file syntax, you won’t go back to another init.


ProwlerGr, this looks to be very impressive and useful! Unfortunately I can’t try it out right now, but I hope to soon.

I haven’t tried a distro yet that doesn’t use systemd. But I am very interested to try. Something like this makes it a lot easier! Thank you so much!


That is the most useful reference I have found on 66.
Thank you.

1 Like