Apt-key deprecated causing failure to update?

I know and have read the topic Apt-key deprecation - #14 by abhishek here on the forum but as it is a year old and this is a bit different, I am posting my issue here.

I saw an update in LM this morning for freedesktop platform. No matter what I did it would not “install” the update. I rebooted and same thing. It downloaded the update but will not install. Clicking refresh, I get the following message:

W: http://deb.playonlinux.com/dists/cosmic/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

So I went and removed/purged playonlinux in terminal, also used autoremove. But apparently, the deprecated key is still there.

sudo apt-key list
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
pub   rsa4096 2017-05-30 [SC]
      D853 8615 FEAC 389F DF84  8C22 73F0 D6E8 8E3D 6C3A
uid           [ unknown] PlayOnLinux debian repository key <packaging@playonlinux.com>
sub   rsa4096 2017-05-30 [E]

So my question is, obviously, is this causing the failure to update? If so, how do I get rid of the key? If not, why won’t the updates install?


Assuming you are prepared to get rid if playonlinux, so the rest of your update will work
Just go to /etc/apt/trusted.gpg and delete it by hand
have a read of
man apt-key

So that trusted.gpg file is not for all keys? Just playonlinux? There is of course a folder 'trusted.gpg.d" as well as the single file ‘trusted.gpg’ so just trying to understand. The article referenced said in the beginning deprecated keys would not prevent updates. At the end, they said you should fix it cause it could prevent updates. So I was confused.

Since the move to trash is greyed out in Nemo, how do I get root or permissions in order to delete it?


Reading man apt-key says “del keyid” but terminal says Command ‘del’ not found.


Using Nemo, I right click on the folder I want to have root access.
Then, going down the list of options, I select “Open as Root”.

That’s why I asked. In Kubuntu I had that option as well as ‘open in terminal’ using Dolphin. But new to Nemo and do not have either of those options.

I checked the settings and they are checked to show, don’t know why they do not.


UPDATE: You cannot open a file in root, I guess. I had to go up a level and open apt as root. Then those options become available.

After deleting that file, trying to update got this:

Still cannot update. Since the new error related to playonlinux, rebooted to ensure it was gone, but still getting same error and it will not update. Deleted virtual drives created by playonlinux and all folders removed. Emptied trash. Still will not update.


Another option to try that has worked for me sometimes when I got an update error.

Go to Update Manager
Under Edit select Software Sources
You will be ask for root ID
Select PPAs
Un-ckeck the blue box that looks related to playonlinux
or all the blue boxes.
You will be asked to “OK” the update
Close the window and try to perform the update again.

Updates will not be downloaded for the items that are not enable.

If this do not help, reset the the PPA’s by following the same steps, it is easy to go back and “Enable” the items you disable,

If this does work for you, you could go back and remove the PPA that is causing the problem and re-enable the PPA’s that were not the problem.

1 Like

I easily found the additional repositories for playonlinux and left it checked while unchecking others and removed it. System updated apt and update manager still shows that update to be installed. Refreshing now there are no error messages, but it still does not update as it always has in the past. Just returns to the checked freedesktop platform awaiting installation.

There is nothing under PPAs. Under maintenance, would any of those options help?

Sorry, I have no experience with those options. I suppose it would not hurt to try some of those options as long as you have a good backup / restore routine.

I looked at the update history and only found this specific package trying to update today for the first time. Other variations .Adwaita, were removed and I am wondering if this update was specific to playonlinux. Otherwise, not sure why I can see no update history for it till today,

Will try another reboot because after updating apt choosing ‘remove duplicate entries’ I got a “Cinnamon has crashed” notification, but I chose not to reboot and it is acting fine now.


Still unable to update. I looked at the installed flatpaks (which this seems necessary to run) and I guess there can be updates to same versions but here is what I show for this package already:

flatpak list
Name         Application ID        Version    Branch      Origin   Installation
Bitwarden    com.bitwarden.desktop 2023.7.0   stable      flathub  system
CalenGoo     …ngoo.calengoodesktop 936        1.0         calengoo system
Indicator-K… …indicator-kdeconnect 0.9.4      stable      flathub  system
Notesnook    ….notesnook.Notesnook 2.5.8      stable      flathub  system
Peek         …uploadedlobster.peek 1.5.1      stable      flathub  system
Sticky Notes com.vixalien.sticky   0.2.3      stable      flathub  system
Freedesktop… …freedesktop.Platform 21.08.19   21.08       flathub  system
Freedesktop… …freedesktop.Platform 22.08       flathub  system
default      ….Platform.GL.default            19.08       flathub  system
Mesa         ….Platform.GL.default 21.3.9     21.08       flathub  system
Mesa         ….Platform.GL.default 23.1.1     22.08       flathub  system
Mesa (Extra) ….Platform.GL.default 23.1.1     22.08-extra flathub  system
openh264     …op.Platform.openh264 2.1.0      2.0         flathub  system
openh264     …op.Platform.openh264 2.1.0      2.2.0       flathub  system
GNOME Appli… org.gnome.Platform               3.36        flathub  system
GNOME Appli… org.gnome.Platform               44          flathub  system
Mint-Y-Aqua… …tk3theme.Mint-Y-Aqua            3.22        flathub  system
Mint-Y-Dark… …eme.Mint-Y-Dark-Teal            3.22        flathub  system
Mint-Y-Teal… …tk3theme.Mint-Y-Teal            3.22        flathub  system
Cider        sh.cider.Cider        v1.6.2     stable      flathub  system

I see that the current package for update has ver 21.08 and 22.08 installed. Is that normal? I thought updating to a newer version removed old version. Could this be the cause?


It used to be for all keys, but it is deprecated so it probably contains a few hangovers.
If you feel uncomfortable about deleting it, just move it to a different filename, eg
mv trusted.gpg trusted.gpg.deprecated
Do that as root or use sudo at the CLI… not with Nemo
Then apt will not find it, and if it wants keys for something it will generate a new key in the new location trusted.gpg.d

1 Like

I already deleted it once @easyt50 told me how to get root to do so. I don’t know why it still won’t update.


Did you try
apt-key del keyid

@nevj The man page did not say apt-key it just said del key and told how to get the numbers. That is why I ended up deleting it from Nemo as root. I did run the list again and POL is gone so I don’t think this has anything to do with that–could be the error for POL would happen each update regardless (I think I had one of those in Kubuntu as I always updated in terminal and I just ignored it). And even if deleting that file got rid of something else, it would surely alert and there are no more alerts. It just tries to install and comes back to install with the package still sitting there waiting to be installed.


Also, even tho it is showing in system update manager, terminal says all packages are up to date. Do you think that is why the CLI ouput shows the 22.08 installed as well as 21.08? Cause the update is 21.08.19 exact same as what is already installed. I know you can ignore an update, but not sure I should.


Hi Shiela,
You need practice reading man pages
They always read like that…del is a sub-commznd to apt-key
They dont keep repeating the apt-key when presenting the sub-commands
I too have been caught with this

1 Like

LOL :rofl: Believe it or not, I have never read a man page…always wondered where to find them cause I am reminded with each reboot in a message prior to grub that says: asked for 1 man page, got 8. Now I know.

Nevertheless, I think I should just choose “ignore this update only” and be done with it since it is already installed. What do you think?


That is safe. If it gets apt working, why not.

Wow, you are missing out on a lot.
That is where all the basic information can be found
Some apps use info instead of man

1 Like