Attempting to read library loans on Linux

I have been trying for many months to read library loans which are made through Borrowbox. To do that, I apparently must either have a tablet or download Adobe Digital Editions which can be done only through Windows or Mac. I feel that I have read everything on the web and tried everything suggested to no avail.
I finally gave up, and against all my principles, downloaded Windows 10 on Virtual box. That in itself was a job for a hopeless user such as I am, but I succeeded. I also managed to download and, I thought, install, ADE. However, although it seems to be installed, and the icon appears on the desktop, I cannot, for the life of me, get it to open. Once again I have researched the web, followed various suggestions, and still can’t get it to work. Have I abandoned my principles for nought? Any help will be appreciated/

The problem here is Adobe. Adobe’s company policy is not very Linux-friendly, to put it mildly. Microsoft is Linux-enthusiastic, compared with Adobe.

However, I found two options for an installation of Adobe Digital Editions without a virtual machine:

With “Winetricks”:

With Wine for Ubuntu:

I have tried neither of them.

However, isn’t it possible to access the content in the browser? If so, Firefox (and other browsers probably, too), has a nice “reader view” function.

I also wonder: Wouldn’t it be possible to install the borrowbox Android app directly into an Android emulator?

1 Like

A good android emulator

But it does not link to Google’s Android store so you then have to go to the borrowbox site

And install from that
Not had time to try it as our local library uses a different system and I am waiting for the tech support to offer something similar … could be a while.

1 Like

Hello CallPaul and Mina. I really appreciate your advice and especially your having replied so quickly. I have to say, first, that Wine is a non-starter. I have tried it repeatedly, but it never works. With respect to an Android emulator, I am grateful to be pointed to a possibility I had never known existed. The problem with that is that I can’t seem to download any, as I am always told there is no support for focal. That seems to be because I am using LM 20.1, and I haven’t found a work around for that. Calibre, of course, isn’t any use for DRM books, and I can’t see a way to use Firefox ereader. I have been working on solving this, literally for months, so if there are any more suggestions I’d be overjoyed.

Looks like is in Florida, USA.
It seems that the BorrowBox Library app uses your id and PIN to get to your local library to pick the files you want.
It probably won’t work for all public libraries.

I certainly will not try to give my credentials to a FLORIDA based company.

I do not know BorrowBox @ljohn but I can get books from two national and municipal libraries thru ADE on Windows. I keep Win 7 on a computer just for that. As for the DRM concerns, I have installed some extensions / plugins on Calibre (v. 3) which easily opens and converts all Adobe Digital Editions ADE (v. 2 ) EPUB books and all Amazon Kindle (v. 1,16.0 ) AZW books.

I enjoy reading these EPUBs with xReader ( v.2.8.3 ) on my Linux Mint Ulyssa desktop or/and KoReader File Browser ( v2019.05 ) on my old Asus Nexus 7 tablet.

Thanks for the responses which I very much appreciate. I may not have made myself clear: the problem is that the only way that I can borrow books from my library (which covers an entire county) is through Borrowbox. I have no choice in the matter. Borrowed books apparently go directly on to most tablets, but I don’t have one (mainly because I want nothing to do with the big firms, such as Google and Microsoft).
All the solutions I have come across on the web state that it is a simple matter of downloading ADE, but that can be done only through Windows or Mac. As Mina points out, ADE are hardly examples of good customer relations, and they will do nothing to help when it is a Linux system.
I have, over several months, tried WINE, Virtual Box and, thanks to the suggestions on this forum, an Android emulator. In addition, I have attempted to use Calibre. I can get nothing to work. It is probably my lack of computer skills, but it is frustrating in a period of lock-down, not to be able to borrow books.
I am now going to try one more approach. I have ordered a cheap tablet, which I am going to de-Google and install something like Lineage os and hope that works.
Many thanks for the advice.

And what help did you get from


For help and support you can reach our team via

Would you prefer that I help you personally in PMs ?

If you need help with wine @ljohn let me know in a PM.
I am certain you can install it
because, I did so myself, on Ulyssa
and I am not a super techie.


Thank you R_G. I have been in touch with my local library and with the site you suggest. The replies are courteous and show willing, but they merely repeat that I need only install ADE, seeming to ignore my point that I cannot install it on Linux.
I shall send a private message as you propose.

Calibre requires a plug-in to read DRM protected content. See It can also be helpful if you get books from your library that are not correctly formatted for the loan.

Hello Marc,
Thank you for that interesting information. It sounds precisely what I need, and I have read the source information. Unfortunately, I really don’t know what to do when I get to the git hub page. I’d be very grateful if you could enlighten me.
Best wishes

When you say wine is no go ?

Have you installed it and tried the Adobe product as the wine hq site says it works

Perhaps more details would help …

Great you are getting offers of support from others but if it’s all done on private messages we don’t get to learn from your experience and suggestions for a fix, so personal request is that it’s shared

is of no help to me either.

There are two different issues here :

  1. ade on wine on linux
  2. drm on calibre.

My offer was to help @ljohn first and report the solution here after.

Accordingly, please be patient.

ADE should open itself when you click/open an acsm file.

Did you try that @ljohn ?

If you can bear with me, I’ll try to outline the state-of-play. I have appreciated all the attempts to help, and I can only think that it is my own ineptitude that has kept me from succeeding with anything. There has also been a slight digression owing to R_G’s kind offer to help in personal messages. I can see his point and am grateful that he is willing to put in more effort, but I also understand that the process itself can be instructive, so I shall continue with this thread.

First of all, I think it can be taken as read that one cannot use ADE on Linux; all the items I have read on the web agree to that. The alternative approach is to use Windows, which is against my principles but might be necessary.

To use Windows, it is necessary to install either WINE or Virtualbox. I have done both, with little reward. I know from my experience over the past months that I do not want to use WINE. I can install it and can even download ADE, but that is where it stops working. And I have had so many problems with it, having to re-install my OS (Linux Mint 20.1) several times, at great cost in time and loss of information.

So, excluding WINE, I have successfully installed Virtualbox and am running Windows10 in it. I have downloaded the latest edition of ADE, as well as ADE 3, and both appear as icons within Windows, but they won’t open. I then read that I should install an even earlier edition (2.0), which I have done, and to my delight, it opened. However, as seems to be normal for me, another obstacle arose. I tried to download a book and got the message: Error: Unable to download: error getting licence.

I am grateful to Marc for having suggested plug-ins for Calibre, but I haven’t yet been able to accomplish that.

I have also had a go with android emulators but with no better luck.

I’m sorry for so much detail, but it might open up some new avenues for someone. If I had spent as much time reading as I have trying to get books, I’d probably have emptied the library by now!

Been a while since I “borrowed” an e-book from a “public” library - gave up - never did get my head around Adobe “digital editions” on Linux…

Yonks ago I used to read all my e-books on an old iPad3 - mostly through Google Play books… I think that was the last time I borrowed an e-book from a public library.

Then I bought a Kobo e-book reader in 2018 - and I buy stuff from them occasionally, with that hideous DRM extortion hard coded into my purchases - however - given that I bought a copy of the book - I either :

  1. decrypt it using my Windows 10 laptop for work (to store in my archives)
  2. find a copy with DMR removed for my “archives”

Almost always, invariably, Option 2 works out vastly simpler… There’s really just one site I hit to get DMR free copies of books I own (PM me if you want the link)… I treat it like a library too - i.e. I’ll “borrow” an e-book from them - and if I find I’m turning past the last page of the first chapter - I’ll buy the thing!

I’ve had cases in the past, e.g. Neal Stephenson’s rather massive collab with 4-6 other writers : “The Mongoliad” - books 4 and 5 couldn’t be “had” for love or money on Kobo, or my favourite e-book download site for free - so - I had to buy them from Amazon, then use my Windows 10 laptop (over RDP as I just keep it at my desk at work) and opened the Amzn ebooks into the Amazon Windows only reader application, then found some Windows only app that could decrypt them and remove the DRM so I could convert to epub format - load into Calibre, then upload to my Kobo - that was painful…

I’ve seen guides about using Calibre to remove DRM - but never found any success doing this on Linux…

1 Like

The free Kindle app from Amazon is pretty useful. My local library will email electronic media to the Kindle account for the three week loan period.

How is it “free”? Not paying money does not equal “free”.

1 Like