BackInTime config restore?

Hello all!
This is my first post! It is great to discover the IT’ FOSS has a forum!

I use BackInTime as my primary backup software on my machines.
I have only seriously had to use it twice. When one machine went down I reinstalled with a Redo Rescue clone and then re-installed my last BackInTime backup! Easy!

I recently had another laptop go down. I did not have a Redo Rescue clone so I did a fresh install of the distro, Kubuntu, and then went to install my BackInTime backup.

Upon first opening of BackInTime I choose the restore config option after installing BackInTime in order to load the list of all my dated backups/snapshots.
It is crashing.
When it does not crash and I can select a dated backup, it is green, and I get to the settings window. Under ‘Advanced’ the Full snapshot path looks correct. nb It also picks up the previous user name.
When I click OK however it says in a pop up ‘/media/justin/Cosmic-Kup is not a folder.’ This is the path stated under ‘Where to save snapshots’
Snapshots are not loaded and I cannot restore.

I entered the filemanager and tired copying over the config file from a dated backup directory to the new installl .config/backintime folder. This did not work.
I then went into the backup .config/backintime/ directory and copied over config file to the new installl .config/backintime directory. This did not work either.

Anyone familiar with BackInTime? How can I restore the config file to view snapshots and restore?

Kubuntu 21.04 with backports.

Greetings and Welcome! :smiley:

Thank you for this detailed description. Despite the issue being pretty well described, I would recommend to still add screenshots of what you actually did or tried to do, so it’s easier to understand what is actually happening and to make it even clearer, than any words could describe. It’s easier to “read” pictures than lots of text. :grinning_face_with_smiling_eyes:

Regarding your actual issue:
Please run the following command and post its output in this thread.

file /media/justin/Cosmic-Kup

Hi Akito,
Yes, without pics it is hard to grok, hence my asking

I have taken a series of pics now and put them on a USB to upload from my personal machine on which I am logged into this forum from.
The laptop in question that is having trouble with BackInTime is a work device and I keep it strictly for work matter. Unfortunately, I am having ongoing issues mounting USB sticks in my personal laptop.
Once I get that sorted I will post the pics.
nb Starting a new thread for the USB problem.

1 Like

On first load of BackInTime I get the following and select ‘Yes’ in order to restore the snapshot list.

After selecting 'Yes" I get access to the file system and navigate to the attached drive where the snapshots are backed up.
BackInTime crashes over and over.
When it does not I get the following and click restore.

This takes me to the Settings page.

I then get the following after clicking OK.

I click OK and it takes me back to settings.
In settings if I click ‘Restore Config’ it takes me back to the filemanager to select it again.
If I click cancel I get:

If I click ok I get the following with an empty snapshot list and the ‘Restore’ button greyed out.

Does it crash as soon as you press “Yes” or does something happen in-between?

Nevertheless, I think this problem seems to be related to this:

So, first let’s fix that and then try again with the back up issue.

It can crash straight away or seconds later or make it to a file to select. There does not seem to be a pattern.
I wonder if I add the uuid of the backup drive into fstab whether it would solve the issue of ‘/media/justin/Cosmic-Kup is not a folder.’? That is, could the non-recognition of it as a folder be because of a permissions issue? I am not game to try this as I borked my other machine yesterday with what I thought was a correct uuid entry.
nb. The sudo version of BackInTime fared no better. Same situation.
ps. The USB issue was on my other laptop. The USB mounting and read/write on BackInTime problem machine is fine!

Sorry, for the slow reply, my rookie status here gave me a post limit and I had to wait 16 hours before I could re-post.

Okay, well, didn’t sound like it’s fine when it’s clearly supposed to be a folder, especially when you can access it manually, anyway.

That said, I have asked you to do the following:

no such file or directory!
huh! OK!

The new mounted path is /media/bandicoot/Cosmic-Kup

so, hmmm, do I change both ‘Where to save snapshots’ and ‘Full snapshot path’ mount ref from ‘justin’ to ‘bandicoot’? Maybe change my username back to the previous one - will that change the mount point ref?
I hope it will not overwrite the current backup though.

Could you please run the command on every folder that is interesting in this situation?


file /media/justin/Cosmic-Kup
file /media/bandicoot/Cosmic-Kup

And all others that might be related to your snapshot (of course, except massive amounts of sub-folders).

Then we can check if they work, before starting the backup, anew.


sub folders also read as ‘directory’

Okay, then retry the backup operation with altering the backup path from




both paths or just ‘Where to save snapshots’?

Since the Justin path does not work, as we worked out previously, we have no choice but to remove the Justin path from everywhere. So, yes, you need to replace all the Justin paths.

Ok, I changed the ‘Where to save snapshots’ section and it automatically changed the ‘Full snapshot path’

then…snapshots loaded!!! :smiley:

Thanks for your help!

1 Like

Clicking on the last snapshot also highlights the restore button - it is no longer greyed out either!