Bluetooth under Kubuntu 20.04 not working

I’m running Kubuntu 20.04 and I can’t get Bluetooth to connect. My headphones are recognized and they can be paired, but they can’t be connected. A similar problem occurs in Windows 10. The Bluetooth software is based on the Kinivo BTD400 chip. The folllowing transcrpt shows the problem:

pwa@HP-Pavilion-Laptop-17-ar0xx:~$ bluetoothctl
Agent registered
[CHG] Controller B0:35:9F:DC:86:14 Pairable: yes
[bluetooth]# devices
Device 5C:F3:70:A1:E6:9A btd400
Device EB:06:EF:BA:06:40 Mpow H10
[bluetooth]# paired-devices
Device 5C:F3:70:A1:E6:9A btd400
Device EB:06:EF:BA:06:40 Mpow H10
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# trust EB:06:EF:BA:06:40
Changing EB:06:EF:BA:06:40 trust succeeded
[bluetooth]# show
Controller B0:35:9F:DC:86:14 (public)
Name: HP-Pavilion-Laptop-17-ar0xx
Alias: HP Pavilion
Class: 0x0000010c
Powered: yes
Discoverable: yes
DiscoverableTimeout: 0x00000000
Pairable: yes
UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
UUID: Generic Access Profile (00001800-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
Modalias: usb:v1D6Bp0246d0535
Discovering: no
Advertising Features:
ActiveInstances: 0x00
SupportedInstances: 0x05
SupportedIncludes: tx-power
SupportedIncludes: appearance
SupportedIncludes: local-name
[bluetooth]# connect EB:06:EF:BA:06:40
Attempting to connect to EB:06:EF:BA:06:40
Failed to connect: org.bluez.Error.Failed

This problem has been discussed in several fora, without a definitive solution. The answer seems to depend on which release the victim is using. Many people report success in curing the problem, only to have other users report that the solution doesn’t work for them. Kinivo, the chip maker, has also got involved in the discussions.

It would be great to have a definitive solution to this problem.

Correct term for sure! bluetooth mostly seems like a “dark art” somewhere on the spectrum between occultism and satanic necromancy…

Sorry - I can’t be of much help here…

I was using a Targus BT 4.0 USB dongle for a while, with lacklustre unreliable BT support, worked sometimes, seemed like black magic when it did, and bad juju when it didn’t… Unless you maybe wanted to try a USB BT dongle?

This was on a desktop machine - ended up buying a PCIe WiFi + Bluetooth 5.0 card and haven’t had a single issue since… it all just seems to work (touch wood and fondle my taxidermied rabbit foot)…

Also - don’t usually have too many problems with BT on Dell hardware… but I never push it too far (BT audio isn’t quite ready for prime time on Linux it’s been my experience)…

I’ve spoken to Bryan at Kinivo who seems to understand the situation very well, since Kinivo makes the chip that has caused the problem. It seems that Bluetooth was working just fine until Microsoft started revising the relevant code. The situation was inherently unstable because that chip tried to combine wifi functionality with Bluetooth functionality. The solution, as I understand it,
is to disable the Intel functionality of the chip.

That requires some BIOS changes that can be installed at system boot time, using the BIOS functionality that’s supposed to be there – except that in the case of my machine (an HP Pavilion aptop) it seems not to be there. Bryan thought I night have some success if I called HP directly, but he can’t do that himself because of corporate rules about calling other companies. (My laptop has one of those brain-dead BIOSes that has very limited functionality.)

So I haven’t given up. but I haven’t had the time so far to pursue this further. I dread trying to navigate the HP phone system to solve a problem that most people don’t understand. It’s a sad case of a bug that manifests itself at a high level (Bluetooth doesn’t work) but requires trudging through the woods to fix. something that few pwople are aleto do.

The problem shows up both in Windows and in Linux, and like many other folks, I’m running a dual boot system. You should st stay tuned to postings on the Kinivo website. My heretical advice as a Linux person is to solve the Windows side of the problem first.