Boot hanging in grub

History: I am relatively inexperienced with trouble shooting linux.
I RUN a HP OMEN desktop with two internal, SSD, 1TB drives. I have windows 11 installed on one drive and had Ubuntu 3.04 installed on the other drive. Ubuntu was giving me audio issues that nobody seemed to be able to diagnose and the conventional wisdom was install 22.4 LTS,

I decided to tryout linux MINT on a USB drive so that 1 could see if it would run freeCAD and a few other respected utilities. I was satisfied with what I saw and shut down. When I decided to restart my computer, with the USB drive disconnected, I selected my Ubuntu drive from the boot menu (not grub) and it tried booting. It hung up with the following message. How can I fix this issue.

Maybe you just need to reboot normally and choose Windows or Ubuntu from the Grub menu?

I’m assuming Windows 11 was installed on the first SSD and then Ubuntu installed second in a dual boot on the second SSD. If that’s true then your system would normally boot off the first SSD using Grub and you choose Windows or Ubuntu or let the default boot after a timeout.

When you chose to boot directly from the second SSD using your BIOS or an F2 key press or some other key (guessing) there are no Grub options on that drive to boot an OS.

Hopefully this helps. Maybe you’ve already tried that.


Many thanks for your reply and you are correct on your assumptions.
Here’s the “Fly in the ointment”, according to HP Tech Support, this model has a dumbed down bios and does not allow the bootloader menu to pause and allow selection (yes, unbelievable!) therefore I have to rely on using the F9 key to access the menu.

I have absolutely no knowledge relative to configuring GRUB; is there a way to configure grub as the default boot menu?

Oh man. That probably is. Someone with more mutli-boot experience than me should advise you. There are a few forum members that seem to multi-multi-boot. Hopefully one of them can help you out.

I think maybe if you can boot from a USB stick using a live trial of a distro you could possibly run a Grub update of some sort that could fix the one that seems to not be working.

It seems odd that the BIOS doesn’t support a Grub prompt.

1 Like

My friend KenS,
Please allow me to clarify something I read in this thread.

You wrote the following:

In the last post we talked about this, I told you to use the LTS kernel and not UBUNTU 22.04.3, because you had errors with that distro:

and I was waiting for your feedback after testing the LTS kernel…


I found the information that I needed.