BUG in Linux Mint 18.3 kernel update?

My laptop was running fine and I decided to check ‘Update Management’ for updates. I went ahead and applied all of the updates and there were quite few.
I re-booted my PC and got to my logon screen and typed in my PW. The screen blink and I was back to the logon screen. I tried again with same results. I try logging on as guest and same results.
Then I try typing in an incorrect PW and the PC came back and told me it was not correct.
I booted from my Mint 18.3 USB flash drive and was able to restore the laptop using Timeshift.


I went back and applied all the updates again except for the ‘Linux Kernel 4.15.0-64.3~16.04.1’
The PC boots fine and I am able to log in.

I have not seen any recent reports of this Howard. The last ones recorded were in 2018. I can’t find any solution that is up to date on it either. @abhishek wrote this ; https://itsfoss.com/upgrade-linux-kernel-ubuntu/ I don’t know if that is of any help.

If my memory serves me right there were a few problems caused down stream with 18.3 when Ubuntu upgraded. I can’t remember if the kernel was one of them.

At least you got it sorted which is a good thing

1 Like

Interesting article about upgrading / changing kernels using Ukuu. I was just using the Update Manager and applying what I thought was a patch. Looking at it again, yes, it is a kernel replacement. I am just going to ignore this update.

2 Likes

Interesting. I was ‘afraid’ to install kernel updates for a long time but since I did the ‘first one’ I wait a few weeks to see if anyone has had problems then just go ahead. At present I’m running 4.15.0-64 and don’t seem to have any issues (other than the one’s I already had - missing terminal)

1 Like

Each Mint Version comes with a “native” kernel version. You can update the kernel if you wish to do so, but there are some risks with it. Personally I have never had a problem doing so, but always use timeshift to protect myself in case there is

1 Like

12 posts were split to a new topic: Timeshift in Linux Mint 18.3

@1crazypj and @ElectricDandySlider is there a utility or program in mint that is specifically for updating the kernel? i just did it in antiX with synaptic and have read it can be done through the terminal, but was wondering if there was an easy/helpful way specific to mint.

1 Like

@cordx, in Mint 19.1 (not sure about the kernel) but going to Mint 19.2 (which would include a kernel update) is as easy as rolling off a log. There is an option in Update Manager and for me it worked great.

1 Like

so a point release like that comes with a kernel update. interesting. i do appreciate the info :slight_smile:

i am still working with 18.3 and was wondering if there was a usual/accepted method of upgrading the kernel to make sure i have one that includes protection from the most recent vulnerabilities (meltdown, spectre, etc). using synaptic was easy peasy in antiX, but their admin is kind enough to post forum updates letting users know which kernels (apparently they create their own that are antiX-specific) are ready to deal with the new bugs and stable for the system.

2 Likes

While I was reading this Update Manager popped up with new kernel upgrade,
4.15.0-65.74-1604.1. Safe to install?

mine is still on 4.15.0-64 which seems stable and like it is playing nice. just checked updates and don’t have the -65 option, but you know they say things happen slower in texas :cowboy_hat_face:

i’d definitely re-recommend some kind of backup before the install, but seems like it should be worth a go. doesn’t seem like mint often suggests kernels that are incompatible.

the -64 also goes to disprove my previous post. mint did in fact upgrade to -64 from -55 after a few days (i don’t boot into it daily). seems like that question is solved for me.

1 Like

@1crazypj I had a problem with kernel 4.15.0-64.3 and Mint 18.3, but now see kernel 4.15.0-65.74 has replaced it on my system for update. But I have not try it.

2 Likes

You do it through the Update Manager Cordx - Just press view and when the box comes up it is the 4th item down. There is a specific separate thing that I know of. I have never used the terminal to do any updates or kernel removal

1 Like

" I have never used the terminal to do any updates or kernel removal "

I have, I had so many prior kernels the boot screen was full when I hit ‘advanced’ option.
I’ve had a Linux distro on this laptop since 2014 and even done major updates through Update Manager (that is pretty scary first time around)

i had seen that before and think it is a great resource to have (bodhi doesn’t have anything similar so i never really worried about kernels there). what threw me off is that i had newer kernels, but wasn’t booting into them.


i finally took the time to watch the update and boot process a little more closely. turns out it was a grub update issue caused by multi-disto booting. my grub is set by my most recent install (antiX) so it didn’t get the memo that mint just installed the new kernel. makes sense now.

thanks for the tip pointing me in a helpful direction :slight_smile:

4 Likes

Thank you, that was nice of you to say

2 Likes