Can anyone recommend a Arch distro with a GUI installed by default?

Like the subject says “Can anyone recommend an Arch distro with a GUI installed by default” ?
With a live version preferred.

1 Like

What’s the point of using Arch, when it isn’t used the way it is supposed to be used? Customised by the user, on first installation.

Having said that, did you check out Manjaro?


I’m a novice at Linux, that’s why I asked, using the cmd etc. to install whatever I’m not up too… I will check out Manjaro.

1 Like

Then you should try out Ubuntu or Kubuntu.


Maybe Manjaro.
Perhaps you might have a look here:

You can always use other Arch based distributions:


I can recommend the arch based garuda. I use it on my new slimbook. It has a lot of flavours and you install from a live disk. See on
It was my first arch based distro after years on rpm or deb based

100% Agree with you @jhansen63
Garuda is just AWESOME
It has lots of flavours ( In simple words: Different kinds of looks and abilities to customize )

Thank You!!

I’M novice too however I have seen YouTube videos that claim manjaro is the easiest of the Arch distros, in general Arch is best left to more experienced users that are comfortable with customization and troubleshooting. It maybe in your best interest to earn your stripes with a more stable distro before moving on to Arch.

1 Like

Exactly, better start with Linux Mint or Ubuntu.

1 Like

I’m using Manjaro for gaming on, it comes with everything you possibly need, well Steam wise anyway.
XFCE is my environment of choice, but with Manjaro you also get KDE Plazma, Mate, Gnome, Cinnamon, Budgie, Deepin. Manjaro Official Downloads
Manjaro Community Downloads

It’s quite hard to know what to suggest, as Manjaro especially has made it easier for new Linux users to start on, but with the technical part of making your own Arch from scratch for beginners, yes start on a Ubuntu based system first, then once experienced with terminal commands or coding then move onto Arch.

1 Like

My first, and currently only one, experience with Arch was Manjaro (I’m using both the GNOME and the KDE version). I do recommend that :slight_smile:

It’s not my daily driver (which is still Ubuntu and Kubuntu) but it’s close to!


What some of my other esteemed peers recommended previously in this thread : Manjaro…

Interestingly, even though the Steam Deck portable gaming console runs Valve’s ‘own’ Arch - Valve recommend Manjaro as the closest thing to their Steam Deck (And I’m still pissed off it’s NOT available in my shitty country, where we’re also still waiting for f–king Google Stadia! That’s mostly thanks to our “state of the art” hybrid 19th century broadband network).

If I knew how to get my work’s VPN client working in arch or manjaro I’d be tempted to give it a whirl… But probably more Manjaro, than arch…

But for me personally, I’d still prefer to entrust my compute to DEB or RPM based distros, 'cause that’s what I manage for my job… I’ve yet to see an arch / aur based distro running a production workload for a corporate customer, and I wouldn’t go holding my breath to see that happen.

If I wanted the kudos for running something as tricky as arch, I’d run Slackware, which is harder than arch and what I cut my teeth on 25+ years ago… I’ve had LFS and Gentoo users tell me that Slackware sits somewhere between Gentoo and Arch, on the level of difficulty.

I’m going to re-visit Manjaro … may try distrohopping again…

ZFS encrypted disk on my Ubuntu 20.04 Thinkpad E495 is a piece of crap - don’t seem to be able to alleviate the symptom where it turns into a zombie then comes back (which, by deduction and elimination, does seem to be ZFS related)…

Plan :

if [ "Install Manjaro latest in a virtbox VM, using LUKS full disk encryption, get Checkpoint\'s HIDEOUS SNX VPN client working" == success ] ; then
     exec "do it for real on this Stinkpad E495..." 
    exec wipe Ubuntu 20.04 on encrypted ZFS ; install ubuntu 20.04 on LUKS / ext4

I use Manjaro XFCE for gaming on and tried also Endeavour OS, as soon as I updated Endeavour OS after two weeks of using it, it griped saying it could not install all the updates, as running into conflicts. Installed same updates in Manjaro never griped once. Just goes to show Manjaro is tested and looked after better by their community.

1 Like

Try newly created (Dec 21) Arch Installation GUI (4 Desktops options) isos by Erik (Founder of ArcoLinux) without the glimpse of ArcoLinux.
Official Link

1 Like

Arco is a good choice.

I’m just test-driving Garuda KDE “Gaming” Edition - latest - and I’m VERY impressed…

By default it has a similar (or same) theme to the one that @Mina has shared with us in the past, i.e. it looks very appealing.

Given I’m about to trash this device (not happy with certain things that I attribute to using ZFS encryption on Ubuntu) - Lenovo Thinkpad E495 - I think I might try out Garuda for a few days or more, even a week. Default compositor is still X11, so I won’t have issues running Synergy on it… Definitely tempted (hey it even defaults to MacOS style window control widgets on the left - which I got too used to in Unity to change my muscle memory - even more so now I’m also using a Mac).

Given also that my employer is about to decommission their Checkpoint VPN solution, if I can’t get the SNX VPN client to work on Garuda, it’s not a “show stopper” (it would have been 3 months ago!) as I still have my Ubuntu desktop - and - my MacBook Pro (where ALL the VPN clients work : Checkpoint, Cisco, Pulse, GlobalProtect, OpenVPN, Azure P2S)… I don’t think installing Microsoft’s Azure P2S VPN on Garuda will be any more difficult than on Ubuntu (which I’ve given up on already) - and - the ArchWiki is one of the greatest sources of Linux info on the planet. But I won’t be one of those knobs (nobody here I swear!) who think 'cause they’re running Manjaro, they can utter “BTW I used Arch…”. I’ve used Manjaro XFCE in the past (32 bit on a Samsung N150 Netbook, it was the best Linux experience I’d ever had on that hardware.

But I do have an Arch logo sticker in my UNIX stickers collection - so I might whack one on the Thinkpad if it lasts more than a fortnight before I go back to Ubuntu :smiley: .

So - I’m going to boot back into Ubuntu, purge inkscape, install 1.1. from a PPA and see if I can make InkStitch work :smiley: … then I will trash the whole thing and install Garuda.



After full installation, the “Assistant” (ASS-insistent) asked me what IDE I wanted and I said vim and VSCode… It then said it had to remove gvim to allow vim, so I let it…

Several reboots later - I’m trying to edit my sudoers, and it says no vi :angry: - so I “export EDITOR=vim” and that worked… So I update my entry in sudoers (via visudo) with NOPASSWD (hey it’s my system and I’ll compromise it if I want to)… Save… Exit… STILL ASKS me for my password!

Turns out “VISUDO” is some dumb hangover one of the “team” forgot to remove… it’s there, but it does SWEET F.A.! Why leave it there?

Anyway I found /etc/sudoers.d/10-blahblah or whatever (it’s since been removed - I think by “Garuda Setup Assistant”) and that fixed it 'cause I was a member of wheel (I removed the comment next to wheel in /etc/sudoers.d/10-blahblahblah) and it worked…

So - several reboots - lots of REALLY UGLY repository errors (straight out of the box) - that seem to be resolved by TRY and TRY and TRY again till it works (which flies in the face of logic) - there’s all sorts of wizards running all over the place (like the Garuda “Setup Assistant”) trying to do stuff, and update stuff, AT THE SAME TIME! I wouldn’t recommend it for a beginner anyway - not that ANY of my Ubuntu / Debian / Red Hat experience is of any use here :

I don’t think this has been very well thought through, or tested. And it seems incredibly bloated, and that’s coming from a primarily Ubuntu user! There’s a like a gazillion applications installed that I’ve never heard of, so I doubt I’ll ever use them.

Installed oh-my-zsh - works fine over SSH remote - but in Konsole? I seemed be stuck in fish shell, even though /etc/passwd said ZSH! No! Why? What? YOU PUT THE SHELL IN THE X-Terminal application (Konsole)??? WTF? Seriously? Is this also routinely the case in KDE ? I had to get ZSH working properly so I could create an alias “vi” to “vim” (why couldn’t they do this by default???).

Seriously considering going back to Ubuntu… But I’ll persevere for a bit longer I reckon…

What else do I hate? That’s a long list… don’t get me started :smiley:

P.S. Nope - can’t work with this… too used to Ubuntu / Debian ecosystem… ran into a bunch of systemd issues on Garuda that I couldn’t resolve (or couldn’t be arsed digging too deep to resolve) - i.e. the “systemctl --user $ARGUMENT $SERVICE” subsystem. I need this to work for resilio-sync. No ResilioSync IS a showstopper for me. Downloading Focal Fossa 20.04.4 now…


OK… Sorry.

TBH, I didn’t experience any of these issues with a fresh installation (I would have never tried “Gaming”, though - for fear it would be “overengineered”) - worked great out of the box.
I still ditched Garuda after a couple of months, because after installing more apps, they started to have issues with each other and in Arch it seems to be OK to release untested software into the repositories, so I had to rollback quite often.

Debian-based distributions seem to be more stability focussed, indeed.