Cursor frozen and cannot open terminaltib

Hello everybody.

I recently decided to change to Linux Mint Cinnamon 20.1 on my Lenovo Convertible Yoga 7 14itl15. I booted Mint onto my Notebook and have started a live session, but now I am facing several problems. First, my cursor is frozen. To solve this problem I could do something on the terminal which I of course cannot open by clicking on the icon, neither I can use the terminal shortcut. Also, when pressing the windows button a list of apps pops out. I can navigate through the list by using arrow keys but when I press enter, it loads for a while but then returns to the desktop. If anyone knows how to handle this problem, please tell me. Thank you!

If it is not moving from the middle or the top left corner of the screen, then it probably lacks the necessary driver for touchpad support.

It would help us a lot in trying to help you, if you explained very precisely and extensively what exactly would help. This way we can understand your situation a lot better.

You don’t need anything like that. Just use one of the keyboard shortcuts for entering a terminal.

Yes, just as in Windows. It’s the same behaviour.

It seems like the application you chose fails to start and then crashes, which may seem to the user like you are “returning to the desktop”.

What exactly do you need solved?

In your case, since everything seems so broken, I would verify that your installation is correct.

See Q6 in the FAQ:

It explains how to verify that the ISO you put on the USB stick or DVD isn’t faulted. If the verification fails, this could be a reason for the live session to go as you described. In that case, you need to re-download the ISO, make sure it matches the corresponding hash, then re-flash it onto the USB stick or DVD. Then try using the live session, once again.

1 Like

Hi.
All that @Akito said, plus just a little (maybe odd) question:
Aren’t these Yogas Notebooks/Tablets (just like my Asus TaiChi)?
Does it behave like that in both states (Notebook-Mode / Tablet-Mode)?

Maybe we’re dealing with a similar problem like my Display/Tablet-Mode problem here. Just with the mouse not the display.

I dont think my Yoga has a Notebook and a Tablet mode. You only can fold your screen in way it can be hold like a tablet.

I reflashed my USB and booted it again. Now the terminal shortcut works and I even can use applications. My touchpad still has problems though so I used the terminal to change from libinput to synertics but it showed an error message.

May I ask how much ram you have? I know with my Lenovo Yoga 500 it came with 4GB of ram, I upgraded the ram to it’s max, put 8GB inside it. I don’t use the touchpad on any of my Laptops, as vibration causes words when typing to get muddled or the cursor would suddenly jump, so I use an external mouse lazer one not the old ball type. If it is Cinnamon you’re trying to run, then maybe a good idea to switch off all the effects. I use XFCE it’s lighter on resources and just as customizable as Cinnamon. If XFCE isn’t your bag, then maybe look for a lighter OS all together.

What is the specs of your Laptop?
In a terminal type or copy and paste:

inxi -F

This’ll list everything about your computer, could you please copy the list and post it, for us to see what could be the problem? It’ll give us a better idea of what you’re running. Thank you :grinning:

I have 16 GB Ram, 15.8 available.

I couldn’t copy the specs in the mint terminal so I copied the specs on windows. I hope that’s sufficient.

Operating system name Microsoft Windows 10 Home
Version 10.0.19041 Build 19041
Further operating system description Not available
Operating system manufacturer Microsoft Corporation
System name DESKTOP-SEBASTI
System manufacturer LENOVO
System model 82BH
System type x64-based PC
System SKU LENOVO_MT_82BH_BU_idea_FM_Yoga 7 14ITL5
Processor 11th Gen Intel (R) Core ™ i7-1165G7 @ 2.80GHz, 2803 MHz, 4 core (s), 8 logical processor (s)
BIOS version / date LENOVO F5CN37WW, 10/12/2020
SMBIOS version 3.3
Version of the embedded controller 1.37
BIOS mode UEFI
BaseBoard manufacturer LENOVO
BaseBoard product LNVNB161216
BaseBoard version SDK0J40709 WIN
Mobile platform role
Safe startup state On
PCR7 configuration extension required for display
Windows directory C: \ Windows
System directory C: \ Windows \ system32
Start device \ Device \ HarddiskVolume1
Germany locale
Hardware abstraction level version = “10.0.19041.423”
Username DESKTOP-SEBASTI \ Sebastian S
Time zone Central European Summer Time
Installed physical memory (RAM) 16.0 GB
Total physical memory 15.8 GB
Available physical storage 12.3 GB
Total virtual memory 18.7 GB
Available virtual memory 14.9 GB
Page file size 2.88 GB
Paging file C: \ pagefile.sys
Kernel DMA protection On
Virtualization-based security Not enabled
Device encryption support Extension required for viewing
Hyper-V VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation (SLAT) extensions Yes
Hyper-V - Virtualization activated in firmware Yes
Hyper-V DEP Yes

Just asking: Does the cursor move if you plug in a mouse?

Other question: Have you tried to search whether somebody on the internet is using Mint on the same device? If so, it’s likely to be an issue of the live version, bound to vanish, once you do a real installation.

You have loads of power to run Cinnamon. When you boot from the USB does it automatically choose UEFI (Unified Extensible Firmware Interface) or do you manually have to choose? If I remember rightly in the bios of Lenovo Laptops it reads automatically UEFI and you can choose Legacy boot. Keep UEFI on though. Linux has never liked fast boot or secure boot, as it boots differently so switch that off. That PCR7 configuration extension for display or Platform Configuration Register, which all it is is to read and encrypt keys, passwords and online passwords too, another bit of telemetry for Windows to collect. Is there a way of turning that off? All this rubbish they keep adding to bios, where Linux does not need all this, as it does not spy on you and stores login passwords differently.

I may have to get myself one of these Laptops, just to trial installing Linux on it. Sorry I can’t be of any more help but switching off fast boot and secure boot should help. Also try installing Cinnamon like Mina says and once installed problems may go away.

1 Like

I only can choose between Windows Boot Manager and EFI. Is that good?

You obviously have chosen USB before when you loaded live version of Cinnamon. Install Cinnamon fully over Windows and see if any of the niggles you had with the live USB go. Before that though make sure you backup anything in Windows you want to keep? As I do not want to be to blame if you should lose anything important. Lenovo are generally good with Linux, as they have started or are going to start to distribute Laptops with Linux on them.

I installed Mint completely last week,the touchpad still wont work, but a mouse does now.

Although I’m not completely sure but you can install xf86-input-synaptics or any other touchpad package if it supports (check your Laptop Manual to confirm it.)

Try to install through Synaptic Package Manager, if the package is not available there then install from the above link.