Dark screen after login

Hi all, :wave:

I have a question regarding a certain problem a friend of mine ran into lately.

She uses an HP laptop running Linux Lite 6.4 as a sole OS. So no fancy setup at all.

The day before yesterday it still booted alright and she could use the login screen to enter her credentials.
As of yesterday after this procedure, however, there was just a black screen with nothing on it. “CTRL+Alt+F3” didn´t work either. :frowning_face:

I spoke to her on the phone today and it seems there was an update the day before.

Well, in the end she could could get it working again by using an older kernel.
Version 5.15.0.-84 didn´t produce the black screen.

I guess that´s just some sort of workaround for the time being and there seem to be a few points to consider: :thinking:

  • We suppose upgrading to a newer kernel introduced the problem described. Does this seem to be correct?

  • What might the underlying problem be? Login-manager? Something else?

  • While using the older kernel 5.15.0.-84 should she apply any upgrades?

  • Is it likely the problem will be fixed with upgrades to come?

  • How should she proceed for the time being/in the near future?

Thanks a lot in advance for your help

Many greetings from Rosika. :slightly_smiling_face:

Hi Rosika,
We have to resolve this question first… then what to do will be obvious.

All that the login manager does is accept your password and start X11 or the DE. If the password part fails it usually brings up the login screen again. You got blank. Therefore I think maybe X11or DE is not starting.
Why?

  • the video drivers in the new kernel are missing or wrong
  • the new kernel is not talking to X11 properly
  • some mixup with X11 and Wayland
  • other

I am sure you can sort it out
Start by disabling the login manager so you can see what is going on.
Look at dmesg
lshw -c display
lsmod

Regards
Neville

2 Likes

Hi Neville, :wave:

thanks a lot for your help.

O.K., running these commands may provide some valuable information.

But the system has to be running and a graphical DE has to be present in order to run these commands in a terminal.

As my friend couldn´t log into a virtual console when using the newer kernel she´d have to execute the commands in the OS running the older kernel. And here she got no problems… :thinking: .

Another general question, if I may ask:

Suppose she´s using her system with the older kernel for a while.
What about systerm updates in this case :question:

Should she apply the updates?
If at some point in the future a newer kernel will be released and if this kernel fixes the problem introduced by the present one…

… will sudo apt update && sudo apt upgrade install it then?

Many greetings from Rosika :slightly_smiling_face:

1 Like

Hi Rosika,
I’m not familiar with Linux Lite, but let me ask you a question just out of curiosity: doesn’t Linux Lite have virtual consoles?

Jorge

1 Like

No. You an use recovery mode and get a console login… like before, remember.

2 Likes

Hi Jorge, :wave:

thank you for your reply.

Yes, it does, as it´s based on ubuntu.
She can log in but gets just a black screen, and:

… for some reason.
That´s what she told me on the phone. I myself couldn´t verify it, of course. :blush:

Many greetings from Rosika :slightly_smiling_face:

1 Like

You can nearly always leave an older kernel, and just apply updates to packages. People with Gentoo do that all the time.
but
If your friend does updates of packages, she would probably not know how to avoid a kernel update, if one came along.
so
hanging onto the old kernel may be difficult
You need to solve the issue with the new kernel

2 Likes

Yes, that will work.
You will need to know when it is available, or you will get the faulty kernel again.

2 Likes

Hmm, according to her description when selecting recovery mode she gets this:

Wiederherstellungsmenue

Where would the console login be :question:

Right. And in the end she might need a newer kernel version (with the fix) after all.

Thanks, Neville. That´s what I wanted to know.

Well, due to the fact that she lives far away from me I can help her just by telephone (and anydesk, if she has a graphical DE).
Not an easy situation, it seems… :thinking:.

Thanks a lot for your help, Neville.

Many greetings from Rosika . :slightly_smiling_face:

1 Like

Under grub, then choose recovery mode.

1 Like

Isn’t there an option on boot time to select the former kernel? This would address a faulty kernel upgrade.

1 Like

Yes, in the grub menu, in Recovery or Advanced mode, it will list all the available kernels.

2 Likes

Ah, I see. Thanks, Neville.
I didn´t know that. :blush:

Yes, I know of advanced mode. This way she could get the older kernel to work.
I didn´t know one could choose different kernels in recovery mode though.

Many greetings from Rosika :slightly_smiling_face:

2 Likes

@abu :

Hi Alfred, :wave:

I´m so sorry. I completely forgot to reply to your comment. :bowing_man:

My friend contacted me only yesterday askíng whether there was something new regarding her problem.
So I looked up the thread and noticed my mishap. Sorry again.

Yes. We could get her laptop going by selecting the older kernel this way.
It´s 5.15.0.-84.

In the meantime there´s 5.15.0.88 available.
Yet she claims that the latest one would still introduce the problem. :frowning_face:

Thank you very much.

Cheers from Rosika :slightly_smiling_face:

Hi @nevj @Tech_JA @abu and all, :wave:

after quite a while I had the opportunity to meet that friend of mine last Wednesday again.
She visited her mum and brought her laptop along.

Now she wanted me to take a look at it and hoped we could resolve the black screen problem after all.

Well, the problem presented itself last October for the first time and as a workaround she booted her Linux Lite system using the older older kernel 5.15.0.-84 ever since.
Any newer kernels would trigger the black screen problem.

After doing some more online research (using her mum´s laptop) I came up with the idea of adding the nomodeset parameter in the line
GRUB_CMDLINE_LINUX_DEFAULT
in /etc/default/grub. After that: sudo update-grub.

Of course I first tried it by adding the option manually when grub appeared after switching on the laptop. The results looked promising. :wink:

In actual fact nomodeset seems to have done the trick.

The laptop boots perfectly even with the latest kernel (for Linux Lite), which currently is 5.15.0-101-generic.
No black screen anymore after the login procedure. :blush:

But I noticed the desktop wallpapers were gone after that. Well, I just needed to define 4 different wallpapers for the 4 virtual desktops again. Nothing more to be done.

Everything seems to be working just fine now:

My research provided some insights as far as nomodeset is concerned:

  • The nomodeset parameter instructs the Linux kernel to not load video drivers during the boot process.
    Normally, the kernel will attempt to initialize and use video modes provided by the hardware or configured drivers.
    However, in some cases, these modes might not be compatible with the system’s hardware or may cause issues such as the black screen problem my friend experienced. By specifying nomodeset, the kernel avoids attempting to set any specific video mode and instead leaves the display in a more basic, unaccelerated mode.

  • The black screen issue she encountered after a kernel update could be due to compatibility issues between the updated kernel and the graphics drivers or hardware on her HP laptop.
    By adding nomodeset, she effectively bypassed the automatic loading of video drivers during boot, preventing any potential conflicts or issues related to the graphics drivers. This allows the system to boot successfully and display the login screen properly, even with the problematic kernel versions.
    At least that´s the hope :wink: .

Yet I also found out this:

  • It’s worth noting that while nomodeset can be an effective workaround for boot-related graphics issues, it may also result in reduced graphical performance or limited display resolutions, as the system will be using a basic, unaccelerated video mode.
    In some cases, it might be necessary to investigate further and address the underlying cause of the compatibility issues, such as by updating or reinstalling graphics drivers, to achieve optimal performance and compatibility with newer kernel versions.

Well, for the time being I think she should use her system the way I set it up now.
If she ever experiences any (new) issues she´ll surely let me know. :wink:

Let´s hope for the best.

Many greetings to all of you and (if you´re celebrating): Happy Easter :egg: .

Many greetings from Rosika :slightly_smiling_face:

2 Likes

Hi Rosika,
What nomodeset reverts to is allowing X11 to set the video mode. That was always the way it was done, up until about 5 years ago, so it should be quite acceptable.

Well done

Regards
Neville

2 Likes

Hi Rosika,
Congrats on your tireless insistence on finding the fault.
Well done, my friend.

Happy Easter to everyone

Jorge

1 Like

Thanks @Tech_JA and @nevj for the praise. :heart:

Seems I (hopefully) could resolve her problem…

So what´s left for me to do is taking care of my own grub entries to solve my kernel panic issue I posted here.

Just happened to me again today.
For now I´m trying to add rootdelay=10 manually as a boot option.
Hope it helps. :neutral_face:

Happy Easter to all. :egg:
Many greetings from Rosika. :slightly_smiling_face:

1 Like