Day 0 with PopOS on Ryzen Thinkpad (E495)

I know I wrote that I would wait for day 3 - but there’s so much to unpack about PopOS - that I’m going to start on day 0.

Wayland not even installed - good - I need to use legacy X11 for Synergy (the laggard piece of crap) to work.

Few glitches here and there installing ResilioSync (didn’t even bother on MX - cause I didn’t know if it was going to be a keeper - but after an hour of PopOS I decided it would be a keeper for at least a fortnight)… Also Brave seems to be a bit flaky on PopOS, and I’ve no idea why, when it sync’d find on MX and I’ve not had problems with Brave on Ubuntu…

Steam installed without any dramas - installing Borderlands 2 now (i.e. native Linux “top shelf” game) - but I’m still busy trying to install Brave again after purging it - and - it’s taking forever the piece of crap.

MEIN GOTT! Getting ANY browser to play nicely with Gnome Extensions is a RIGHT PITA on PopOS (to be fair, it’s an addled / curdled mess on ANY distribution!).

I like the look of rounded corners on stuff - some Gnome 4.x does it - most apps don’t… By default on Gnome 42.5 on PopOS NOTHING has rounded corners! I installed the rounded corners extension and now on Ubuntu (on my main desktop machine) even stuff that refused to do it before with libadwaita on Gnome 41 (Ubuntu 22.04) are doing it - i.e. rounded corners at the TOP and the BOTTOM of ALL application windows, even ones that didn’t before like Brave and MS Teams - like on MacOS - but it JUST REFUSES to do anything on PopOS - the hideous SNAP of gnome-extension-manager shows it as installed - but it’s doing SWEET FA!

Nevermind - I don’t want rounded corners desperately enough to risk destroying my desktop (one solution involves re-building mutter)…

Why would System76 and PopOS veer away from rounded corners everywhere when it’s the way MacOS has been for decades, and Windows 11 is going that way??? Just to be different?

Anyway ended up trying rounded corners by rebuilding mutter and it sorta worked :

One thing about PopOS 22.04 - it’s already on Kernel 6 by default if anyone’s interested…

also - not just Borderlands 2 - also Serious Sam 3 and also another CroTeam (developers of Serious Sam series) title “The Talos Principle” (another pair of native Linux game titles)…


Day 3 now - and - I’m really enjoying it… Hmmm… I’m impressed actually…

Can’t remember what I found fault with my previous attempt…

If this keeps up - I’m probably going to trash my gaming desktop machine Ubuntu 22.04 and replace with PopOS…

I’ll just “fling” (the same way a simian flings poop) my ~/.steam/ folder onto my NAS, easier / quicker than re-installing 256 GB of games from the cloud!

I’m such a lazy bastard… I’ve got TWO 6 TB external HDD’s and I never use them! Having a NAS makes me exceedingly lazy indeed!

Now I’M serious worried :rofl:

We all enjoy ‘Daniels Daily Distro Diary’
so I might selfishly suggest you not enjoy Pop!OS too much, so that you continue with further episodes.


Day 4 now ?

Still liking it - probably a keeper - looking at doing the same on my desktop machine in the coming week…

One disappointment : tried the Pi4 build of PopOS 22, and it won’t boot… I’m guessing maybe 'cause they default to SD-Card boot, I’m wanting to boot off USB 3 drive… And unlike with Raspbian or Ubuntu itself, I can’t access the fat32 /boot partition to edit the config.txt or the cmdline.txt. Maybe PopOs doesn’t use those, but I think that very unlikely as PopOs is Ubuntu based, and Ubuntu (like Rapsbian) has those files in /boot…

Pile of crap! System76 make too many assumptions with the Pi4 - like “nobody would ever want to boot off external USB3 'cause SD-Card booting and running is perfectly acceptable on a system that’s already WAY slower than a 10 year old PC or laptop” … Disappointing… And the pile of crap won’t let me use the keyboard and trackpad on my NextDock (because that requires modified /boot/cmdline.txt and config.txt) - and when I plugged in an external keyboard / mouse combo, it let me mistype my password TWICE, then wouldn’t let me change the password 'cause I didn’t know what I’d mistyped twice (it did the same with the f-cking WiFi login - I noticed it had done some kinda “sticky keys” and kept the SHIFT key down for part of my WiFi password login)…

Yeah - it’s not even really “beta” software - it’s fecking pre-Alpha garbage not ready for primetime… Reckon I’ll cut back to Ubuntu on this thing (Raspbian Pixel is a seriously UGLY desktop and the defaults that Debian ship with stock Bullseye for XFCE are nearly as ugly). Ubuntu do a better job IMHO with a desktop OS for the Pi4…

Anyway - I just took a look at the SD-Card outside of the Pi4 (on my Ubuntu 22 desktop) and now I can see and access /boot - so it seems on first boot /boot is some kinda bullshit encrypted rubbish - but I can read it on another system later on - which is kinda uttler f–king pointless…

Oh well… Second time around… I’ll keep yas posted :laughing:

I’m hoping I’ll get it to a usable state, where I can then hopefully edit the /boot/cmdline.txt and /boot/config.txt to (double check every SING F–KING KEYSTROKE!) :

  1. boot off USB 3 device
  2. use Keyboard and Trackpad on my NextDock 2.x

But nevermind my rants - this is WAY easier than the torture that elementary have teased Pi4 owners with over the last 2-3 years… and it will NEVER get better 'cause they fired the project founder…

Wait - elementary? You want me to pay $25 to a crowdsource fund that ceased functioning 2 years ago? Pay $10 a month to keep your github afloat? F-CK OFF!

Diabolical pile of c@rp!
Was just getting comfy with f–king PopOS on my Pi4 - had a remote SSH session to it… blah blah blah…
PopOS yells out “Hey - screen - can we go into power saving mode right now?”
I yell out “NOOOOOOOO!”
PopOS yells back “F-ck you - I’m going into powersave”
So then my shitty NextDock 2 powers off (as instructed by shitty PopOs on my Pi4 piece of crap)

1 Like

I should probably get in touch with them - System76 - and let them know my thoughts on Pi4 running PopOS…
Needless to say - I wouldn’t use such colourful language…
Getting my head around the limitations now - but - some stuff is still seriously f–ked - e.g. I can’t even fire up settings now so I can tell the piece of c@rp DO NOT F–KING GO INTO POWER SAVE 'cause you will power OFF YOU STUPID DUMB GREAT PILE OF EXCREMENT!

I think I found a work around to stop PopOS going into powersave mode!


I purchase some topshelf amphetamines, consume them and never EVER EVER go to sleep again so that I can twitch the mouse when PopOs starts dimming the screen before going into powersave…

And then there’s this moronic :

I am a stupid moron and “I barely understand how computers work” guide to PopOS on Raspberry Pi 4:

all of which reminds me, invariably, of the Simpsons :

I barely have ANY empathy with oxygen thieves who waste the public “commons” with such inane GARBAGE! And that’s putting it mildly… I’m going to bed now… I can barely feel my legs such inanity makes me feel giddy… Who even gave them their computer license?

Oooh dear! No idea what about that article jerked my chain…

Suggestion : lay off the booze midweek!
Me : What? Even on red wine Tuesday???

Anyway - lost count of the days with Pop!OS - I started this thread on Day 0, and I’m sure it was way longer than 2 days ago - but - Discourse says I started that 2D ago…

Pretty sure that’s wrong and it’s about Day 4 or 5…

:heart: Pop!OS on my Thinkpad (and still seriously considering it to replace Ubuntu 22.04 on my gaming desktop machine) - but not so happy with it elsewhere… read further below :

Man - Pop!OS on the Pi4 on my NextDock 2 was starting to really get my goat… Soon as it went into powersave mode, it would send power down signal over HDMI and turn off the NextDock which was ITS POWER SUPPLY :angry: :angry: :angry: :angry:

Tried to get Synergy (arm64 for Raspbian) installed - it refuses - tells me unmet dependancies - and “apt install -f” doesn’t fix that… I was happily running the Raspbian arm64 build of Synergy when I used Ubuntu 20, 22.04 and 22.10 on this same Pi4… Doesn’t like Pop!OS for some reason…

Tweaked it (/boot/config.txt) to let the NextDock trackpad and keyboard drive the Pi4…

Also - Pop is slow as a wet week on SD-Card - took the SD-Card out and started a “dd” from SD-Card to a fast USB 3 thumb drive - about FOUR HOURS AGO and it’s STILL going!!!

Don’t know why it wouldn’t boot when I directly wrote the Pop!OS 22.04 arm64 build onto USB3 drive - I suspect there’s some kinda encryption going on - as the first partition wasn’t readable…

You can almost, just, nearly, use a Pi4 as a daily driver, especially with 8GB RAM and booting off something faster than SD-Card…

You cannot, just, nearly, use Pop!OS on a Pi4 as a daily driver, 'cause it’s very unready for primetime - feels like alpha software (to be fair to System76 - I think they actually label it “preview” or something)… There’s too much that’s broken. I can’t even install firefox esr arm64 (sudo dpkg -i *arm64.deb) - too many unmet dependancies (that NEITHER apt install -f or apt --fix-broken install fix). When I attempt to install firefox (sudo apt install firefox) it tells me it’s already installed! WTF? But it’s NOWHERE to be found in the menuing system. Open a terminal type firefox and get

╭─x@bebhionn ~/tmp  
╰─➤firefox                                                                                                                                                     1 ↵

Command '/usr/bin/firefox.real' requires the firefox snap to be installed.
Please install it with:

snap install firefox

I REFUSE to use the snap version of firefox - mainly because one extension I need “Gnome Shell Extensions” DOES NOT WORK ON SNAP versions of browsers!
Shame… I really like Pop!OS on my Thinkpad, and I’d really like to have it on arm64… But I reckon I’m going back to Ubuntu 22.10 on the Pi4, then probably 23.04 when it’s released…


OK - revisited Pop!OS on the Pi4 - now I figured out how to make Synergy work on Buntie 22.04 and 22.10 on ARM64 (I just realised - libssl1 is still available to install on x86_64).

It “seems” okay - but one thing I noticed that Pop!OS never does that a WHOLE bunch of other distros do on ARM SBC’s (Armbian, DietPi, Raspbian/Debian and Ubuntu) - check if there’s a bunch of empty space and grow the FS… I guess they’re giving the user more control - but - I say BULLSHIT! You just forgot to do that!

  1. my Pop!OS started off by being written to a 128 GB SD-Card (using dd)
  2. I got it all setup - then shut it down.
  3. I used “dd” to clone that SD-Card onto a 256 GB USB 3 thumb drive (from my main desktop which has a whole bunch of USB 3 ports and a good USB 3 card reader)

I just discovered - “/” is only 8 GB!!!

Powered it down now and will resize it from my Ubuntu 22.04 x86_64 desktop machine (using Gparted)…

1 Like

Is it day 12 already?

Really liking the x86_64 version of Pop!OS 22.04 on my Ryzen Thinkpad with Vega8 graphics (using open source drivers).

But on arm64 on my Pi4 8GB? Leaves a lot to be desired… too many incompatibilities - you saw what I went through just to get libssl1 installed for the sake of Synergy… Just hit another massive snag. if I want the default Pop!OS experience, my only source for firefox is a snap… What if I don’t want to run it from a snap? What if I want to install firefox-esr from an arm64 deb file?

The main reason someone like me would NOT want to run Firefox as a SNAP is that f–king gnome extensions Firefox Extension is BROKEN utterly on SNAP versions of Firefox.

And the other option? gnome-extensions-manager? THAT’S F–KING SNAP too!


No evading f–king snaps! A pox on them I say! Thing is on the quad cores / eight threads on my Thinkpad, or even my Ryzen 7 desktop (with eight cores / eight threads) I barely detect the sluggishness of SNAPs - but on the 4 underpowered cores on a Pi4? It’s noticeable!

40 seconds just to render the Firefox window as a SNAP, another 20 seconds to get a response… that’s one minute - that’s unacceptable!

Just noticed - there’s now a beta of Brave for arm64 linux - gonna give that a trial (prefer Brave anyday - 'cause I’m pretty much in a committed relationship with her 'cause I’ve got so much sync’d in Brave across devices, we stay together for the kids [my sync’d data]).

Worked for me and started up considerably quicker than Firefox snapcrap…

Well - that was a pleasant surprise - Brave on arm64 Linux is quite performant! And sync’d all my stuff proper like… Awesome!
Pop!OS on a Pi4B with 8 GB RAM (running on USB 3 storage) is actually a viable daily driver desktop solution! Coupla little tweaks here and there (e.g. natural srolling) and we have a winner! And I’ve still got 4GB available RAM!

Day #13
It’s a keeper…

In the coming fortnight I’ll be wiping my desktop machine and going Pop!OS on the there too!

By the end of March - should have these running Pop!OS :

  • Ryzen 7 Desktop 32 GB RAM 8 GB AMD GPU (Radeon 6600)
  • Ryzen 5 laptop (Thinkpad E495) 16 GB RAM and AMD GPU (Vega8 on CPU die / APU)
  • Raspberry Pi 4 8 GB RAM arm64 - having Brave available makes a WORLD of difference here - hence why it really could be a “daily driver”… Note - it struggles a bit on audio, and video streaming in a browser - but that’s no a showstopper - I’ve got 4 other computers on my desk for that!

Can you explain why one might choose an AMD Ryzen processor rather than an
Intel Core I7?

Easily - for purely contrary reasons - i.e. don’t want to go with the flow… there’s a couple other things, AMD don’t have Minix running in firmware in a tiny slice of CPU time - that Intel deliberately decided to NEVER TELL anyone about until they got outed… (and I can’t categorically deny that AMD don’t have something simliar).
I don’t trust Intel…
I’m not saying they’re evil :
and it’s a HUUUUUGE irony that Mac users, when Apple used PowerPC from the IBM/Motorola/Apple consortium, Apple users used that logo (evil inside) but had to switch quick smart when Steve Jobs cut them over to Intel (which he’d already been doing at NeXT)…

In technical terms, no, I can’t and point blank refuse to - I just prefer AMD to Intel - always have… probably always will…

AMD invented amd64 / x86_64 computing - and left Intel with it’s strides down its ankles… NOBODY, but NOBODY wanted to re-invent the wheel and use a new instruction set with Intel’s IA64 (with stacks of stuff from HP’s PA RISC and Digital’s Tru64 - which was kinda good, but nobody gave a rat’s arse - amd64 became defacto)…

AMD invented 64 bit mainstream, and Intel had to play a HUGE VAST game of catchup…

That’s why…

AMD are pretty big, but they not a VAST monolitth like Intel…

That sounds like me.
I used to like Motorola 68000 series, but they never survived.
I originally chose Unix because everyone else had CP/M

I dont know where this idea of not conforming comes from, but I used to do it in research and I upset a number of establishment thinking bodies over the years.
People dont like being informed that there is another way of doing things

Back when I built my desktop, I found that AMD processors had more bang for the buck than the Intel CPU. Don’t know if it is still true today.

1 Like

I think it is still true, but not a large difference.
I have been looking recently. Upgrade time is approaching for me.

1 Like

With the AMD Ryzen Threadripper - you get BUCKETS of BANG for your BUCK - but they’re probably considerably more expensive than the nearest Intel I9 or whatever… Needless to say - I don’t need that kinda grunt, or have that kinda money, but I can see how Linus Torvalds would want, and need a Threadripper…

Just for curiosity - I checked out the local comptuer outliet I buy stuff from for prices on Threadripper CPU and motherboards, Ryzen series use socket AM4, Threadripper socket TR4… They dont sell / list TR4 motherboards, but the Threadrippers? One model they have, with 64 cores and 128 threads is $11,299 AUD!!! And the cheapest one with 24 cores and 48 threads is $4K AUD!

Compare that to the ~$509 (AUD) I spent 2 years ago for my Ryzen 7 3700x, 8 cores and 16 threads!

I just updated my Pop!_OS laptop this evening and it’s now running a 6.2 kernel.

Linux pop-os 6.2.0-76060200-generic #202302191831~1677858327~22.04~3cea1be SMP PREEMPT_DYNAMIC Fri M x86_64 x86_64 x86_64 GNU/Linux

So far so good. No ill effects in the first couple hours. There were supposed to be some performance gains, but I can’t really confirm that. I have no benchmark from before the update to compare with.

1 Like

Just doing mine now :heart: :smiley: :

The following NEW packages will be installed:
  linux-headers-6.2.0-76060200 linux-headers-6.2.0-76060200-generic linux-image-6.2.0-76060200-generic

Long weekend here in WA weekend just gone - I could do with another one - spent Monday recovering from an “all day” music festival on Sunday, at 60 (pushing 61) 2pm to nearly midnight might as well be “all day”. My back cramped walking away from the last gig of the evening, and it’s still buggered (my lowerback).

So - I need a longish weekend to wipe my Ubuntu 22.04 desktop machine and go to Pop!OS on there!

I guess I could do it anytime - as I mostly use either / both of my MacBooks for work.

Dang - I reckon I might to it tomorrow. Gonna kick off a backup of ~/.steam/debian-installation to my NAS now - it’s only 231 GB, and my NAS still has ~1700 GB available…

I did some rule of thumb benchmarks a few years ago… tar actually works better quicker than rsync with lotsa data (used it to migrate 15 TB of NetApp NAS data in 2019, to another NAS solution) :

╭─x@titan ~  
╰─➤  cd .steam
╭─x@titan ~/.steam  
╰─➤  tar cf - debian-installation | ( cd ~/BNZ/STEAMBKUP ; tar xf -)

~/BNZ is a symlink to an NFS mounted folder on my FreeNAS…
And not that much will have changed between now and tomorrow, tomorrow I may refresh using rsync :

╭─x@titan ~  
╰─➤ cd .steam
╭─x@titan ~  
╰─➤ rsync -av debian-installation/. ~/BNZ/STEAMBACKUP/debian-installation/.

So I’ve kicked off the preparation… (about ~5 mins ago) and it’s already done 1 GB… so should be done (fingers crossed) by same time tomorrow… Then while I’m working tomorrow - will be installing Pop!OS on my desktop machine…

Pencilled in Thursday and Friday working from the office in the central business district…

Hmmm - my thinking is all arse about …

I’ve got a 512 GB and a 1024 GB USB 3 SSD… I reckon that will be faster than to NFS over gigabit ethernet!

You wouldn’t read about it! “Safely” removed the 512 GB SSD (USB 3) from Thinkpad - hooked it up to my desktop machine - doesn’t show up… Try another USB 3 port - shows up but :
an operation is already pending
when I try to look at it from Files / Nautilus… Can’t access it from CLI. Tried to delete, or check in GParted - no dice!
So - I’ve kicked off the tar over NFS to my NAS again… Doh!
(can’t find the 1 TB USB 3 SSD - but don’t want to mess to much with that - as I mostly use it for Time Machine backups for my Macs)…