Display error in virtual machine

Hi all, :wave:

I ran into some weird problem as of late.

For my second virtual machine - Bodhi Linux - I now opted for the command-line approach in order to get rid of the permission error virt-manager threw at me with my debian vm.

So according to kvm virtualization - Permission error in virtual machine manager - Ask Ubuntu I also can do it thus:

sudo chown libvirt-qemu:libvirt-qemu <image-file>

That I did and thus could easily import the existing img-file for Bodhi. :blush:
The vm starts alright but when logging in I´m presented with an error message:

Error found when loading /home/rosika2/.xprofile:
xrandr: cannot find output “Virtual-0”

Hmm…:thinking:
I then started Bodhi using the i3 tiling window manager and thus at least could get a smaller window in which I could make use of the terminal.

xrandr -q informed me about Virtual-0 being used. So I changed into /home/rosika2/ and looked at .xprofile:

 cat .xprofile
#!/bin/sh
xrandr --newmode  "1696x953_60.00"  133.75  1696 1800 1976 2256  953 956 966 989 -hsync +vsync
xrandr --addmode Virtual-0 1696x953_60.00

Hmm… xrandr -q said “Virtual-0 connected primary […]”.
So I changed the config file to use “Virtual-1”.

I rebooted and indeed everything´s o.k. now :+1:
… as long as I make use of the i3 tiling window manager.

However the problem remains when trying to use the Moksha DE. Still I´m presented with a popup. It says:

Display output is not active

I guess there´s a dedicated config file for Moksha which needs changing but I don´t know where to start here. :slightly_frowning_face:

Does anybody have a clue and can help me :question:

Thanks a lot in advance.

Many greetings from Rosika :slightly_smiling_face:

Hi Rosika,
You need information. This might point you in the right direction

It covers configuring, but it uses gui… doesnt tell you where the files are.
Maybe you should just search… their names should be obvious. They will be dot files, either in your home directory, or in /etc.

Regards
Neville

1 Like

Hi Neville, :wave:

thanks so much for your help and for providing the link.

I was reading around quite a bit but couldn´t find the right place for my problem it seems.
Perhaps I wasn´t thorough enough… :slightly_frowning_face:

Anyway, I now posted the issue in the Bodhi forum:
display error in virtual machine | Bodhi Linux Forums .

Perhaps somebody over there knows how to tackle the problem. As soon as I come up with anything substantial I´ll post it here.

Thanks a lot, Neville and many greetings.
Rosika :slightly_smiling_face:

Hi again, :wave:

in the meantime I was able to get my second VM (Debian) also running on Linux Lite.

Curiously enough this one didn´t make any trouble at all.
After changing the ownership the img-file could easily be imported by virt-manager.

And Debian works great. I can launch it with i3 tiling window manager AND the default DE (Debian xfce). Yes, lauching Debian with an DE works. :+1:

In contrast to Debian Bodhi Linux only works with i3 tiling window manager, as you know.

So now I decided to do a comparison of the settings of the two systems. I was thinking: there has to be some difference somewhere… :thinking:

Here are the settings (all xrandr -q):

  • Debian:
xrandr -q:

Screen 0: minimum 320 x 200, current 1696 x 953, maximum 8192 x 8192
Virtual-0 connected primary 1696x953+0+0 0mm x 0mm
   1024x768      59.95 +
   1920x1200     59.95  
   1920x1080     60.00  
   1600x1200     59.95  
   1680x1050     60.00  
   1400x1050     60.00  
   1280x1024     59.95  
   1440x900      59.99  
   1280x960      59.99  
   1280x854      59.95  
   1280x800      59.96  
   1280x720      59.97  
   1152x768      59.95  
   800x600       59.96  
   848x480       59.94  
   720x480       59.94  
   640x480       59.94  
   1696x953_60.00  59.95* 
Virtual-1 disconnected
Virtual-2 disconnected
Virtual-3 disconnected
  • and Bodhi:
xrandr -q
Screen 0: minimum 320 x 200, current 1696 x 953, maximum 8192 x 8192
Virtual-1 connected primary 1696x953+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      59.92 +  60.00
   4096x2160     60.00    59.94
   2560x1600     59.99    59.97
   1920x1440     60.00
   1856x1392     60.00
   1792x1344     60.00
   2048x1152     60.00
   1920x1200     59.88    59.95
   1920x1080     60.00
   1600x1200     60.00
   1680x1050     59.95    59.88
   1400x1050     59.98    59.95
   1600x900      60.00
   1280x1024     60.02
   1440x900      59.89    59.90
   1280x960      60.00
   1366x768      59.79    60.00
   1360x768      60.02
   1280x800      59.81    59.91
   1280x768      59.87    59.99
   1280x720      60.00
   800x600       60.32    56.25
   848x480       60.00
   640x480       59.94
   1696x953_60.00  59.95*

The only difference I can spot is that Debian uses “Virtual-0” whereas Bodhi uses “Virtual-1”.

Originally Bodhi also had the “Virtual-0” setting applied but I had to change that to “Virtual-1” in ~/.xprofile:

cat .xprofile
#!/bin/sh
xrandr --newmode  "1696x953_60.00"  133.75  1696 1800 1976 2256  953 956 966 989 -hsync +vsync
xrandr --addmode Virtual-1 1696x953_60.00

otherwise I would get the error message shown in my post #1.

Alas I couldn´t take a look at ~/.xprofile in Debian (for comparison´s sake) as it doesn´t have that file.

So that´s how far I got. :slightly_frowning_face:

It´s a shame that I cannot get Bodhi to work it used to. With the settings listed above I still get the error message “Display output is not active” unless I opt for i3 tiling window manager

Many greetings
Rosika :slightly_smiling_face:

Is Debian maybe using global xprofile somewhere in /etc or maybe /usr/share/… ?

1 Like

Hi Neville, :wave:

thanks for the suggestion.

I looked it up but couldn´t find either “xprofile” or “.xprofile” anywhere. Such a file doesn´t seem to exist in /home.
Nor does it exist in the paths you suggested.

I even initiated a search starting from the root directory:


 cd /
rosika2@debian /> sudo find -iname ".xprofile"
rosika2@debian /> sudo find -iname "xprofile"
rosika2@debian />

… couldn´t find anything. :slightly_frowning_face:

Still, thanks a lot, Neville.

Many greetings from Rosika :slightly_smiling_face:

1 Like

Hi all, :wave:

I´ve given up now on trying to fix the error virt-manager throws at me after booting Bodhi Linux. I´ve done a lot of research on the matter but couldn´t come up with anything substantial. :slightly_frowning_face:

Finally I thought: why not giving ChatGPT a try and see what it comes up with.

In essence the chatbot suggested a lot of things I had also found out via research myself but none of them proved to be successful.

I know running Bodhi VM with just i3 tiling window manager works, so there shouldn´t be any fundamental obstacles.

Well, in the end ChatGPT suggested installing a different desktop environment, like xfce:

I’m sorry that none of the previous solutions worked for you, but trying a different desktop environment like XFCE might help to isolate the issue. Here’s how you can install and switch to XFCE in Bodhi Linux:

Open a terminal window and enter the following command to install XFCE:

sudo apt-get install xfce4

Once the installation is complete, log out of your current desktop environment.
At the login screen, click the gear icon to see the available desktop environments.
Select “XFCE Session” from the list.
Enter your username and password and click “Login”.
XFCE should now start up.

And indeed Bodhi Linux using the xfce DE works perfectly. :+1: :smiley:

Well, could´ve come up with this solution or workaround myself but I simply haven´t thought of it. :blush:

So at least I was able to isolate the problem to Moksha and find a solution.

And I´m pretty comfortable with using xfce.

Thanks to all of you for your help and input.

Many greetings from Rosika :slightly_smiling_face:

1 Like

Hi Rosika,
My guess is that the way kvm communicates with the xserver is not compatable with Moksha DE.

Did you uninstall Moksha. ?
I dont know whether it would interfere with xfce, but it might do so.
I know I3 is OK mixed with xfce.

Regards
Neville

1 Like

Hi Neville, :wave:

Hmm, altough hat sounds plausible I wonder what triggered that behaviour all of a sudden…

It used to work perfectly. Bodhi Linux had no problem whatsoever with displaying the Moksha desktop environment when using KVM/qemu/virt-manager on Lubuntu.

It was only after I had set up my new system (Linux Lite 6.2.) that this became a problem.

No, actually not, but I re-installed it with sudo apt install --reinstall moksha

Alas, it had no effect and I still got that error-message.

Well, at any rate, I´m glad Bodhi Linux runs well with xfce4, and that´s still a resource-friendly DE.
htop (Bodhi Linux VM) says after cold start:
179 MB / 1005 MB

That´s not a bad value considering I get
123 MB / 1005 MB

with running Bodhi Linux headless and ssh-ing into it via terminal. :wink:

All in all I think xfce is a DE I can live with. :blush:

Cannot say it does, so far. But I´ll make sure to be on the lookout for anything untoward.
Thanks for the hint, Neville.

Many greetings from Rosika :slightly_smiling_face:

Another guess… the xserver in Linux Lite is different from Lubuntu

Xfce is my favourite

Cheers
Neville

2 Likes

Hi Neville, :wave:

I see. Well, that would make sense. Thanks for the suggestion.

I´ve grown to like xfce a lot myself. As Linux Lite (my productive system) makes use of a modified (by Jerry Bezencon) version of xfce my experience with it grows on a daily basis. :wink:

Thanks a lot and many greetings

Rosika :slightly_smiling_face:

1 Like

UPDATE:

Hi all, :wave:
Hi @nevj :wave:

believe it or not: I finally could solve the problem regarding Bodhi´s display error in the VM. This resulted in no GUI desktop environment being available.

My research finally led me to moksha resetting. Here I found the right clue:

If you’d like to get back to the “default first boot moksha profile” you can do so by removing / renaming your ~/.e directory.

So I booted into an xfce session (xfce and i3 sessions work very well in my Bodhi setup) and from here I renamed the folder /home/rosika2/.e to /home/rosika2/.e.bak and restarted Bodhi, this time choosing the Moksha session.

During boot (or at login) the folder .e was rebuilt from scratch and was now using its default settings.

Now everything works as expected as per default. Here´s a screenshot:

As you can see Bodhi uses just 190 MB of RAM after a cold start. :wink:
Very well suited for use in a VM.

Many greetings from Rosika :slightly_smiling_face:

4 Likes