Enlightenment weirdness

Hi altogether, :wave:

presently I´m flirting with installing enlightenment as another desktop environment on Linux Lite.
Normally I try out such things with a virtual machine first in order not to come across any nasty surprises . So I did this time. :wink:

I installed enlightenment on my Debian VM, which uses the xfce DE per default. I already had installed i3 tiling WM, which I use most of the time.

Well, the installation of enlightenment went well and I´m presented with the different login options at the login screen.

First of all I compared RAM usage with all three options:

  • xfce: 468 MB
  • enlightenment.: 435 MB
  • i3 tiling WM : 366 MB

(all measured after cold start with nothing running except htop in a terminal)

That comes pretty close to what I had expected.

After that I tested enlightenment in the VM and it works very well and meets all my demands. Actually I like it a lot. :smiling_face:

I tested the vast majority of installed applications/programmes and they work as expected… except of one:
I ran into problems with anydesk. :neutral_face:

As soon as I started anydesk the whole of the VM froze immediately. I couldn´t use the mouse any longer, nor would any keyboard input have any effect.

Of course I couldn´t open a terminal. Fortunately virt-manager provides the possibility of opening a number of virtual terminals by clicking on dedicated keyboard shortcuts. So I logged into virtual terminal 2 and here I could kill the anydesk process.

Curiously enough I was logged out of Debian as a result of that. :astonished:
After logging in again everything worked as expected.

I repeated the procedure a few times more, always resulting in the same outcome.

When using either xfce or i3 tiling WM anydesk works without fail. :+1:

So what´s preventing anydesk from working with enlightenment :question:
Why would starting the programme make the VM freeze :question:

Thanks a lot in advance.

Many greetings from Rosika :slightly_smiling_face:

Hi Rosika,
It looks like someone has been there


It cant be someting that enlightenment is missing, because you have xfce and i3 installed and they support it. So any libraries, etc would be there.
I would fiddle with the e20 settings. You may just need to turn something on.


1 Like

Hi Neville, :wave:

thanks for your quick reply and the link.

Hmm, I wouldn´t know what these commands would entail with respect to anydesk.

# chmod 777 /root
# chmod 777 /root/.anydesk

Well, I could try.

Yes, that´s my understanding as well.

That´s a good idea. I only wish I knew where to start. Well, I´ll keep digging.

Thanks a lot, Neville.

Cheers from Rosika :slightly_smiling_face:

I think that is unlikely to help.

I would look for something related to communication or encryption… eg TLS

1 Like

Thanks for the tip, Neville. :heart:

I´ll do some research on that.

Cheers from Rosika :slightly_smiling_face:

Do the logfiles tell you anything?

I looked at them with lnav yesterday. I think it refers to /var/log/syslog by default.
It didn´t find anything with regard to anydesk.

I don´t know whether anydesk has any log-files at a different place… :thinking: .

1 Like

@Rosika I thought you practiced some advanced meditation, had a powerful otherwordly experience and are now facing difficulty adjusting with reality…!

Silly me!

1 Like

Hi Rosika,
Can yoy tell us in more detail how you did that? It is something virt-manager users need to know.

1 Like

Hi Neville, :wave:

Yes, actually it´s pretty simple and straightforward:

In the upper row it says: “Taste senden”, i.e. “transmit key”.

I chose “CTRL+Alt+F2”. That´s just an example of course.
It´s just the same procedure you would apply when running a physical system.

Now I was in the virtual terminal:

Just an example again. At this time anydesk wasn´t running, of course. Hence the result of the example command.

With “CTRL+Alt+F7” I was back in the normal GUI session again.

For some reason I was logged out after doing that… sometimes, but not always… :thinking: ,

You may have to log in again.

Hope it might be of help to somebody.

Cheers from Rosika :slightly_smiling_face:

Hi @Rosika ,
That “Taste senden” is a virt-manager button?
is it an enlightenment button?

I like the look of e20. Much improved on the e16 I tried.
When you get over your issue, how about a little demo of enlightenment’s features, just enough for everyone to see what it is like ?


Yes, of course. Sorry I forgot to mention that explicitely.

This button is available irrespective of the virtual OS installed.

Not quite sure what you exactly mean by that?
I guess there are better explanations on the web for such purposes. :thinking:

BTW: I posted the issue to enlightenment support but haven´t received an answer so far.

Cheers from Rosika :slightly_smiling_face:

I just mean show us a few screenshots illustrating what it can do… especially anything unusual. People like to see. That screenshot you posted shows a lot…There are icons at the top, and a panel at the bottom… did you configure that or did it come that way?
What things can you change? where is the menu? is there a system tray?

Get it?

1 Like

I see.
Well, I´ll look into it. As far as “anything unusual” is concerned, that might be bit hard to evaluate. I´ll give it a try though.

O.K., the icons at the top were transferred from my original Debian installation, I guess.
I actually put them there using Debian´s default xfce DE. So enlightenment must have taken them over.

As for the dock at the bottom of the desktop… I´m not quite sure.
xfce DE put a dock there by default but enlightenment placed the clock and and a few mor items in it. With xfce it was just a matter of 4 or 5 applications by default.

O.K., I hope I can come with something useful. :blush:

Cheers from Rosika :slightly_smiling_face:

Hi all. :wave:

sub-topic: enlightenment

As Neville suggested in post #12:

here´s a quick (and of course simplified overview of enlightenment.
It´s by no means exhaustively treated as I´m pretty new to enlightenment myself. :blush:

Enlightenment is known for its unique design, lightweight nature, and customizable features.
Here´s a list of some of its qualities:

  • Lightweight and Fast:
    Enlightenment is designed to be highly efficient and lightweight, making it suitable for both old and new hardware. It’s optimized for speed and responsiveness.

  • Customizable:
    Users can personalize many aspects of the desktop, from themes and fonts to icons and window decorations. It lets users create a unique desktop environment

  • Efficient Use of Resources

  • Compositing Effects:
    Enlightenment offers a range of compositing effects such as window animations, transparency, and shadows.

  • Window Management:
    Users can choose from a variety of window layout options, including tiling, stacking, and more. (# haven´t ried that one yet)

  • Stable and Mature:
    Enlightenment has a history dating back to 1997, and it has undergone continuous development and improvement over the years. This maturity translates to a stable and reliable desktop environment (# well, at least that´s the theory behind it)

  • Cross-Platform Compatibility:
    While Enlightenment originated on Linux, it’s also available for other platforms, including BSD and Windows.

O.K. this sounds good so far.

Notice: the screenshots below a from a German language setup, so they will show anything in German. Sorry for the inconvenience. :neutral_face:
You may still get the gist of what my remarks are referring to, I hope.

Now to something unusual:

Normally you´d expect to get the context-menu via a right-click on the desktop. That´s done by a left-click in enlightenment:

What you see is indeed achieved by left-clicking on the desktop.

But: right-clicking caters for something else.

At first a right click on the desktop won´t produce any entries at all. This option is meant for adding personally preferred applications. You can add to the right-click any apps you like.
I added just two for the moment.
The following is achieved by a left-click on the desktop:


Managing left and right click surely takes a little geting accustomed to in the beginning. :wink:

There´s a dedicated setting console (“Einstellungskonsole”) which can easily be accessed by a left-click on the desktop:

Once opened you have access to a huge variety of personalized settings:

BTW: the dock at the bottom of the desktop comes installed and is active per default.
You have quite a few possibilities of placing it :


A right-click on the shelf itself gets you going.

One problem I ran into was placing a gadget or widget on the desktop.
Enlightenment comes with a variety of them and you have to activate them and place them anywhere on the desktop. A clock is one of them.

Well, I could place it and arrange it to my liking but once you´re done with it you have to stick with it. I couldn´t find a way to move it to any other position afterwards and I couldn´t delete it either.

I looked around on the internet and reralized there were other users too who experienced this very issue and couldn´t get it soved.

I finally managed to get rid of it by resetting the PC´s profile (“Zurücksetzen” in the screenshot below).


Of course resetting the profile indeed resets a few of the other personal settings as well.
So you´d have to start anew with them.

One other thing:

Enlightenment´s default font size is rather small, almost tiny. So the first thing for me to do was to take care of that in the settings.

Of course the issue with running anydesk discussed above in something worth mentioning.
In my setup enlightenment is running x11 (not wayland), so that can´t be it.

I disabled composite effects and thus at least could switch desktops with “CTRL+Alt+left/right arrow”.
But that´s all I could achieve and this isn´t any good as everything else stays virtually frozen.

That said anydesk seems to be the only programme producing this freezing effect. I haven´t come across any other programme that would run into difficulties like that.

Well, these are just a few first impressions of enlightnement.
As using it progresses there may very well be more to report. :wink:

Finally here are some (hopefully informative) links:

Many greetings to all of you

Rosika :slightly_smiling_face:

Hi Rosika,
That is a really top class effort… well done.
I missed it last night, had an early night.

I seem to remember, that behaviour with objects on the background happens with plasmids in KDE too. It happens in Lumina too. In Lumina I can delete them by going back to the menu that created them.
I think objects on the background are regarded as sticky… ie they dont move like windows
…they are part of the background picture.

I wonder if E22 would run in hyperbola? E16 was disappointing, but your E22 is vastly improved
Update: It will not run in Hyperbola, it uses dbus. Checked on your link
It would be a good option for BSD though.

Did you get an answer from Anydesk? We are stumped on that.


1 Like

Hi Neville, :wave:

thanks so much for your praise. :heart:

I´d be glad if anyone could benefit at lest a bit from my post. Perhaps we could get someone interested in enlightenment…

Thanks for the info regarding KDE and Lumina. So this “special” widget behaviour is not an enlightenment-only issue.

It´s a shame E22 doesn´t run in hyperbola. But BSD is supported, you´re right, Neville.

Actually not. I didn´t receive an answer from enlightenment yet, nor from the German-speaking ubuntuusers forum. Seems to be a real puzzler.

But I got a reply from user enigma9o7 at linuxquestions.
He was referring to a potential wayland issue. Yet it didn´t lead to anything as I have an x11 session running.

Thanks a lot, Neville

Cheers from Rosika :slightly_smiling_face:

You have got me interested… I want to try it in BSD.

I think background widgits are still very new and finding what the best behaviour is.
Have a look in the menu where you created the widget… does it have a remove option?


1 Like

Hi Neville, :wave:

Yes, I´ve tried that already, yet I always got an error message.

But I´ve got the solution now:

step 1:

access "“Add Gadgets To Desktop” this way:


step 2:

select the widget you want by left-clicking on it:

step 3:

move the widget to the place on the desktop where you like it to reside

step 4:

if you want to delete it, do as suggested in the picture above.
I used the backspace button.

However it´s important to push the backspace button when pointing the mouse-pointer on the widget you want to remove within the widget selector window, not on the actual widget itself, which resides on the destop.

Otherwise you get the following error message:


… and the widget remains in place.

Well, I seemed to have misunderstood the description.
Or they should´ve been clearer about that. :blush:

Many greetings

Rosika :slightly_smiling_face:

1 Like