Epson SureColor P800 printer & Ubuntu 18.04.4 LTS

Hey,

For some reason there is no picture on the paper I print. There is ink, there is some form of communication between the OS and the printer:

I can select the printer from my photo editor and print, the printer prints but it prints a blank…

Any ideas anyone?

Cheers
Peter

has anything changed on your system recently? have you done any updates or upgrades?

if you go to http://localhost:631/printers/ in a web browser, select your printer, click “Maintenance” and then “Print Test Page” does that produce anything.

can you run lpinfo -v in a terminal and post the output?

1 Like

can you also include a screenshot of the window that appears if you click on “Additional Printer Settings”? your printer being described as a generic dot matrix printer makes it seem like it probably doesn’t have a driver assigned to it.

1 Like

Apart from the regular updates nothing has changed. This is the first time Im using the printer though.

When I print a test page that does produce a test page with some text.

Here is the output:
network http
network beh
network ipp
network https
network lpd
file cups-brf:/
network ipps
network socket
serial serial:/dev/ttyS0?baud=115200
direct hp
direct usb://EPSON/SC-P800%20Series?serial=555A58453030353517
direct hpfax

I assume it is with my photo editor the problem is then? Also, I have to run that photo editor using Wine… and I thought that could be the issue. However, if I print the same photo with Shotwell it also just prints a blank paper. I don’t get this?

1 Like

thank you for a shot of the printer properties as well. it looks like the printer got set up with a generic driver which isn’t appropriate at all. if you click on the “Change” button to the right of where it says “Make and Model: Generic…” you should be able to choose a driver and there should be one specific to your P800.

1 Like

It started to print something out (something that resembles the photo) but failed pretty early on. Also, I got this:

Leading to this site: https://help.ubuntu.com/community/Repositories/

Bad news?

it would be helpful if you could describe what actions you took that lead to that window being displayed.

2 Likes

Ah. Sorry. I found the driver the way you instructed.

I discovered that alert next to the clock at the top middle of the screen.

Just to clarify, as far as I can tell I chose the model first. And when I closed the printer windows I discovered I had an alert.

1 Like

was there a specific driver for your P800 and has it changed in the printer properties window?

Yes:

1 Like

given that the driver was assigned, i am not sure what that notification was supposed to mean.

in the window before printer properties (titled Printers - localhost) if you right-click on your printer (or click on Printer in the menu i believe) you should see an option to view the printer queue. can you check to see if it is still holding some previous jobs that wouldn’t print?

It was, but I think it was the job that failed so I cancelled it… should this work?

troubleshooting is a multi-step process that works when it works. each system and piece of hardware gets fixed in its own time. hopefully this works, but there are other steps to try if it doesn’t.

have you tried printing again after clearing the queue?

to avoid one step (wine) in between, i would definitely try printing from shotwell first.

I did a search for a Epson P800 Linux driver and to my knowledge no Linux driver has ever been released. Linux may assign a generic driver, but I doubt it will do what the Windows driver for that
printer will do. In the past 20 or so years I have been using Linux, I think I might have had one printer
that installed and ran correctly. Their are a few printer manufactures who will take the time to develope
Linux drivers for their products, but they are few. Another good reason to keep Windows around, when
playing with Linux. Good luck.

1 Like

I tried from Shotwell now… it printed the image but its all messed up. I might try this:
https://www.turboprint.info/printer_Epson_SureColorP800.html?fbclid=IwAR1MNC43Ed-_QVskXBFcCm9cITVwf5o_1aY86VOGNHi1Gi2_OxPN0-rgJC8

where did you search?

$ lpinfo --make-and-model “epson surecolor” -m
gutenprint.5.2://escp2-p400/expert Epson SureColor P400 - CUPS+Gutenprint v5.2.13
gutenprint.5.2://escp2-p600/expert Epson SureColor P600 - CUPS+Gutenprint v5.2.13
gutenprint.5.2://escp2-p800/expert Epson SureColor P800 - CUPS+Gutenprint v5.2.13

everywhere IPP Everywhere

were you interested in other troubleshooting options?

I am, but I have no idea what to do. Preferably Id get to the point so that I can print directly from my photo editor. Do you have any other suggestions though?