F'ing wifi again - PITA (the acronym not the unleavened bread!)

Spent hours from Friday and over the weekend trying to get WiFi working on my Lenovo E495 (Ryzen 5) with Pop!_OS 22.04. I prefer to use my 5 Ghz WAP - but it just won’t work (constantly type the CORRECT password it but it always comes back asking for password - DOES NOT happen on my 2.4 Ghz WAP).

Patched / updated / rebooted (patched using ethernet)- nada - zilch… I have LUKS encryption on “/” so I let autologin in the GUI work… Logs in just fine to my 2.4 Ghz WiFi… i.e. after boot - and DE start (Gnome on Pop!_OS) - my WiFi is connect to the 2.4 Ghz WAP (WiFi Access Point).

But I want 5 Ghz - I can tell the difference between 2.4 and 5 Ghz and ethernet…

And to top all that off - Alderon Games Launcher won’t run on EITHER of my Pop!_OS machines so I can’t play Path of Titans (dinosaur simulator MMO).

Seriously considering Ubuntu 23.04… Might try it on a VM and see how hard it is to get Alderon Game Launcher to run (only available as a SNAP or AppImage).


I prefer the bread.
Really, if it says the pw is wrong, the modem must be requiring something different. They are normally in hex… is it set to something else?

WI-FI on Ubuntu 22.04 based Distros does seem buggy as hell. I installed my custom Linux Mint Vera on my laptop. Could it connect? Answer is always a lemon. So installed ArcoLinux Xfce Arch onto it and connected in no time. I’m finding Ubuntu based Distros, especially the 22.04 versions to be buggy, yet normal Ubuntu is stable. The WI-FI not connecting properly on Linux Mint, led me to a bug they had years ago with Realtek Laptop WI-FI driver not being recognized. To do with the 5.15 Kernel. But in Linux Mint 21.1 Vera cannot downgrade Kernel, or upgrade to 6 kernels. Unless there is a PPA somewhere? Then again what else will break, if managed to upgrade to kernel 6? As Linux Mint like to keep their software and environments held slightly back to the rest of the Ubuntu based Distros.

I had the problem of configuring WiFi in Gentoo. I opted to setup wpa_supplicant by hand , using the simplest possible configuration that would work. I have had no trouble after that, it autoconnects every boot.
The big problem with all tools for setting up networking is that they overcomplicate the issue by trying to deal with every possible contingency. A single user usually only wants a couple of simple settings, but he cant get it from a tool without answering 20 questions.

Daniel needs to throw away all his setup,tools and just edit the config files.

Pretty sure my Pop laptop works on 5Ghz. I don’t login automatically. Did you say yours logs in automatically?

I don’t have encryption on my disk either. Looks like yours does. I saw another thread somewhere talking about not having certain modules available in the boot environment due to an encrypted disk. They were given a method of updating initramfs to include the needed modules.

It was in the June 2023 issue of Linux Format magazine on page 12. It was a problem with Pop!_OS on a tablet where there was no virtual keyboard to login. They had to use a physical keyboard which kind of defeats a big advantage of a tablet, portability.

Do you have a usb WiFi dongle ?
I had. Similar problem so stuck a Netgear usb dongle in, connected first time no problem.
I then restarted the matching the following day after doing a system update just like magic the internal WiFi started working without the need for the Netgear key.

My Pop! desktop works just fine - can connect to 5 Ghz… But I hardly ever use WiFi on it - I’m old school, I prefer good old ethernet on UTP cables… I run an Ethernet over Power from my home office to the kitchen where my Router is…

It’s just this ThinkPad (same version and patch level as the desktop) running Pop!_OS… I hardly ever use it really - decided to sit out the front of the house and watch the sunset (behind me, i.e. I’m facing East) and the changing light of the bushland across the road, and the distant hills - but online - and it refused to connect (it actually refused to connect to BOTH 2.4 and 5 Ghz that time!) - gave up and grabbed my MacBook…

I don’t like passersby seeing I have a MacBook - lotta undesirables about my area - and a MacBook is a highly desirable item for thieves…

It’s lying - there’s probably a case statement (on the Linux client) and the last entry :

    echo "wrong password"

for every other case it can’t identify the cause… I’m using WPA (personal, not enterprise), not WEP (WEP used a hex string - highly insecure and most modern devices don’t even have this as an option any more)… I KNOW the password was correct. It’s the same password for BOTH 2.4 and 5 WAPs - same password all 25+ devices on my home network using WiFi!

Probably exaggerating - but - both my daughters and missus have their devices - and I have way too many :
Missus : 3 : iPad + iPhone + Nintendo Switch (which she hardly ever uses)
Daughter 1 : 8 : iPad + iPhone + Nintendo Switch + MacBook + Mac Mini + Playstation 4, 5, Xbox One + work laptop (Win10)
Daughter 2 : 4 : iPad + iPhone + Nintendo Switch + MacBook
(and stuff I use on Wifi)
Me : 3 : iPad mini, iPad Pro, Android phone
Us : 1: Brother MFC
Also “Us” : smart TV with NetFlix and Stan and stuff, and an Apple TV thingie
(nearly everything else I have on ethernet, i.e. 2 x RPi, OrangePi, TrueNAS, Pop! desktop, MacBook x 2, and mostly the ThinkPad’s on ethernet too - i.e. I keep the two MacBooks on ethernet most of the time - with USB C dongles that also drive HDMI monitors).

When Covid first hit us 3 years ago, and I started working from home M-F - hit an issue with my router - it was limited to 8 devices on each WAP! And we hit the limit - the most it can go up to is 32 on each WAP - so - max 64 devices on my WiFi that’s more than enough…

I would prefer error messages that are accurate and meaningful

Never reached a limit with our modem. We have 7 devices … only ever used 2.4Ghz.
5Ghz is supposed to be faster… Is that true?
I have my main computer and the modem in same room, so I can use ethernet cable direct to modem. That means modem is at one end of the house, but not a problem… its range is huge… I can use the tablet outside up to about 50m.

A LOT faster…

What triggered this post was I was trying to use my Thinkpad while sitting on the front “stoop” with a beer (Cooper’s stout) and everything was so much slower using 2.4 Ghz, delays loading images on web pages, buffering on streamed content…

5 Ghz feels a lot more like gigabit ethernet…

1 Like

The way I understood it though your internet is rated at what speed for download? Isn’t 2.4 Ghz faster than whatever that is?

The 2.4 Ghz might have more range due to being able to pass through walls and other obstructions better than 5 Ghz.

I’m sure you can see the difference or you wouldn’t complain. I guess if we didn’t have issues like this a lot of us tech folks would be out of a job.

Well - just saw some massive updates for Path of Titans from my favourite Game News website “Gaming On Linux” (https://www.gamingonlinux.com/) so I had another go at trying to get it to run…

Then I gave up and installed it using Lutris - there’s a “wizard” for each game or game launcher on Lutris’ website - click it, and if you’ve got Lutris installed - it will try and do your thing you wanted done that your O/S wasn’t doing out of the box : https://lutris.net/ - highly recommend it… I’ve used it before to run Windows only games with a non-Vendor Linux native game engine (e.g. Quake III and IV and Doom 3 [all of which were once “native” on Linux - but ID Software have SUCKED BALLS ever since they sold out to Bethesda)…

Anyway - run the Lutris wizard - it will over to download the AppImage for you, or you can point it at one you prepared earlier…

Woohoo! Prehistoric Planet Season 2 is here now (S2E1 anyway) - fantastic show, best thing on TV…

Also - 5 Ghz WiFi still not working on my Thinkpad with Pop!.. I can live with that I guess, so long as 2.4 Ghz works, and I’m not trying to stream some hi-def or “buffer-prone” stuff…

Can you explain why games apps seem to require more help to get them installed and keep them running, compared to most other popular apps?

If I was a game developer - perhaps I could…

I suspect the studios care less about us than other PC gamers, and really only care about consoles mostly (PlayStation, XBox, Nintendo)…

Given the rise in popularity of Valve’s Linux powered SteamDeck - it’s kinda surprising, you’d think they’d try harder…

Note also : Steam is mostly 100% trouble free - I barely have issues with Steam on Linux… If you’re lucky enough to live in a country where you can get, and use, the SteamDeck - which is also capable of running some top shelf Windows only game titles (thanks to Wine + Proton = SteamPlay) - you’ll mostly have a trouble free experience, even if SteamOS 3 is “based” on Arch Linux (downloadable SteamOs is still version 2 and Debian based)…

Yes that makes sense. Its a bit like nvidia cards. Serve the mass market and let the Linux dregs look after themselves.
Other app makers coming from a Unix background, like Mozilla, dont neglect us to the same extent.

“WiFi being an arse” issue just raised its ugly head again! Man this enfuriating!

Thinkpad E495 (Ryzen 5) running latest Pop!_OS with all updates… disconnect it from ethernet - spent afternoon working in the yard, so sat out on my “stoop” (front “porch” area) with a beer (Swan Draught if you must know) sit down with a cushioned milk crate to watch the gum trees across the road change colour as the sun sets (I love that golden glow on white gum trunks [which are not native to this area of Australia]) - music off my phone over bluetooth - crack open the tinnie - sit down - NO WIFI! WTF?

IT was working 24 hours ago in the SAME LOCATION (never got it to work on 5 Ghz)!

“ESKSUWZE ME! Didn’t we just have this out?” This was the 2.4 Ghz WAP - so I tried 5 Ghz - ZIP! I go into the house, into the kitchen - 3 foot from the router - NADA on both WAPs!

So - I enabled wifi tethering on my phone - and it worked and connected STRAIGHT away… FFS! I can remember having similar issues with WiFi on Kobo e-book reader (2 feet away from the router - would REFUSE to connect!)…

So - I’m sitting out on my stoop, with my 3rd beer, typing this on one of my MacBooks… a big FU to Lenovo and/or Pop!_OS / Ubuntu… I don’t remember issues like this with Fedora - so - I may yet go back to Fedora… Fed 38’s out now, I feel a distro-hopping experience coming on… Only thing I don’t like about Fedora - having to do a major update when it comes out - no more updates once a new one’s out… Maybe I should look at SilverBlue or one of the rolling releases… I don’t want to try anything else - I know I can get Steam running on Fedora…

Can you dig up a WiFi dongle and try another interface?
It sounds like your hardware may be defective, given that nothing has changed in your software.
You have to get it ready for state of origin

Was gonna try Ubuntu 23.04 via Ventoy stick but it won’t even boot on this piece of crap…

So - it’s Fedora 38 Silverblue for the next couple of weeks while I try and get stuff working - I’ll be WFH for the next 9 days at least - since work broke VPN access on my work issued MacBook - I’ll WFH and use my personal MacBook on the same VPN (works flawlessly - so it’s some of the bullshit my employer HOBBLES their builds with - honestly it’s a joke - I need to find a job with a smaller “shop”)…

All I really care about is WiFi and Brave Browser so I can have a tinnie or 2 and witness the sunset in reverse (i.e. looking east as the landscape changes hue [despite being colour blind - I love the colours] over an Aussie landscape - I reckon they should heighten the fences and release a few euros or wallabies and emu in that paddock [and some 1080 bates for the foxes and moggies - I have two cats - but I couldn’t give a rat’s arse about people’s pets if they let them roam near bushland])…

already tried that - tried a “Kali Compatible” WiFi dongle I bought specifically for Kali - that works with Kali - and it won’t connect either… The telling point being that it works flawlessly with my WiFi tethering hotspot on my smartphone… I’m 100% convinced it’s software - probably wpa_supplicant… I think last time I got it working was after deleting all my wpa_supplicant configs and starting with a clean slate…

Just tried to boot Ubuntu 23.04 off my Ventoy stick and no dice… just sits there forever and a day with the Ubuntu logo… If I can’t get Ventoy to boot Fedora SilverBlue - I’ll try a “native” Fedora SilverBlue USB stick…

There is an absolute minimal wpa_supplicant config that works anywhere.
Its buried in one of my Gentoo posts. Will search

It was in a message to Daniel Phillips

/etc/wpa_supplicant/wpa_supplicant.conf has

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel update_config=1 network={ 	ssid="my sid" 	psk="my password" } 

/etc/conf.d/wpa_supplicant has

wpa_supplicant_args="-B -Dwext -iwlp0s20u9 -c/etc/wpa_supplicant/wpa_supplicant.conf" 

I had to use the wext driver

Yes if it tethers the hardware is OK.

The trouble with wpa_supplicant.conf is that if you have something like NetworkManager running it will write on it if you attempt to make a WiFi connection other than the one it was set up for. Thats an issue for a laptop. My desktop that only ever talks to the modem never has an issue.

well - I wiped Pop! off there and installed Fedora SilverBlue via Ventoy boot stick - damn thing didn’t even create a UEFI boot loader or grub entries - and not only that - nowhere during the installer did it even try to do WiFi - so I’m guessing the realtek garbage wasn’t detectable / drivable… I suspect SilverBlue is too “edge” to do the heavy lifting on setting up UEFI and GRUB…

Booted Ubuntu 23.04 (refuses to ever boot using Ventoy - i.e. only shows the post grub splash screen) off a “dedicated” USB stick (used Balena) and same symptom as Pop! - i.e. it can see my two WiFi channels - I can type what I know 100% is the correct password for each - and it NEVER EVER EVER connects!

Going to try Fedora 38 (not SilverBlue) on a thumb drive (I no longer trust Ventoy - I will only use this for installing Windows in future) now - downloading from aarnet…

IF I can’t get WiFi to work on this piece of crap - then it’s a boat anchor - what use is a laptop without WiFi? Just a dumb brick is all it is!

Most Linux .iso’s are hybrid. If you just dd them to a usb stick, they will boot.
Why bother with Balena or Ventoy?

 realtek garbage wasn’t detectable / drivable

Why dont you check what the chips driver is, and look with lsmod to see if it is loaded?
Driver names for reaktek chips can be hard to find. Not necessarily chipname.ko
I dont know that it is possible to have the driver module loaded but not working?.. unless the WiFi config is messed up.