Firefox glitching out in Mint

I am running Mint 21.1, fresh installation. It runs GREAT and I am, mostly, loving it. It is a fresh, clean install on an Asus gen 4 i3 that had previously run several distros as I was hopping, testing and learning. Upgraded RAM to 12 GB, runs like a champ to be as old as it is. Never an issue. In fact, this computer has had fewer loading errors than any of my others when running new distros.

That said, I am having a BEAR of a time with Firefox. Periodically, the mouse cursor will freeze or go into glitchy slo-mo. It’s usually when a window is open and I do something… like scroll the wheel on the mouse or open a new tab. It SORT of feels like it might be having trouble rendering certain things in web pages. This causes everything to freeze. Can’t close windows, can’t open new ones. Just this long, jumpy pause. Eventually (after usually a few minutes of freezing or pseudo freezing), it will start working again as it should. Sometimes I reboot and it happens again eventually. Could this be some kind of extension issue? In FF, there are no add-ons installed and the only extensions are OpenH264 Video Codec provided by Cisco Systems, Inc., and Widevine Content Decryption Module provided by Google, Inc.

I have gotten accustomed to Mint and want to keep driving it on this particular laptop, but if I can’t fix this, I will need to go back to Chrome – and I don’t want to go back to Chrome. As of right now, I am running Firefox in Pop on another computer because I was tired of fighting that one.

I can pull info, but I am not as experienced as many of you folks are, so if you want me to pull hardware and software info from the system, tell me how and I’ll do so. Thanks in advance for your help!

Maybe it would be worth trying a browser based on Firefox and see how that goes. Some people swear by LibreWolf, Waterfox, or Pale Moon for example. I don’t know if they would sync with your Firefox account. That might be a deal breaker if it doesn’t.

Try turning off the hardware acceleration in firefox.
I dont know what type of graphics card your machine has, but it may be that its drivers (firmware) are not working perfectly and they get in a glitch when they try to accelerate something.
I had exactly the same symptoms when my old nvidia card became unsupported. I got a new card, but turning off the performance settings helped the old card.



Just a thought, but if you have a good fibre connection, and the sites that drag are from a slow connection then ff may be pushed into submission. What do others think?
Does that make sense?

I have a great connection and the sites that I visit have always worked on other distros using the same browser. I know something about this, and I can 100 percent confirm this is not the issue, as I am on another distro now using Firefox and there is no issue on many of the same sites. It is not a site related issue. It is either a Firefox issue, an extension issue or a hardware issue (graphics card, etc.) that is not playing nice with Mint.

I will give this a try later tonight. Good suggestion. Thanks for providing it, Neville!

1 Like

Hi @fishyaker,

This sounds very familiarity. The mouse not moving or move ever so slowly.
I was on vacation and got so frustrated, that I install Mint Xfce as a second (guest distro) to work around the problem.
I did a “top” command in the terminal and saw were a Mint program was taking up 90% of the CPU.

But damn, I don’t remember what caused it or how I got out of it. I am currently running Mint Cinnamon 21.1 with no problems. BTW, my problem was on a laptop.

I believe I posted a help request on this or another forum. I will try to giggle my memory as to what was the resolution.

Is your system up-to-date on updates?

1 Like

When it happens., can you Ctrl Alt F2 to another login screen?

There are 3 levels of mouse control

  • in the BIOS there are basic mouse and KB drivers
  • there are kernel modules that provide the firmware for particular types of mouse
  • when running x11 there are additional software blobs that deal with using the mouse cursor in windows. I suspect Wayland is the same.
    When there is a mouse issue, you need to determine which level is faulty.
    The BIOS is pretty easy to test… just go into BIOS screen and see if if works. Failure here is probably a faulty mouse
    To test firmware, run something without the desktop (no X11) that uses a mouse…
    If it is not either of those it is the X11 software.

Thats a sort of general guide for debugging mouse problems.

1 Like

I wondering why you would HAVE TO go back to chrome when you don’t want to,
considering how many Linux distros there are and there would have to be a good number of distros that would be similar to Mint.

All up to date. I am just now getting back to this and will do some troubleshooting tonight since I have a little time.

Also running Mint 21.1 and I have had a few similar experiences with Chrome – exactly as you described. I’ve found this has always and only happened when I’ve had a ton of tabs open already and then try to open up some memory-intensive website. Since keeping fewer tabs open I’ve not had this problem.

1 Like

I am running Mint on two separate computers. One experiences this issue; one does not. I am thinking it must be hardware related. The one that experiences the issue has done so with as few as two or three tabs open. I seldom have one open, so I can’t say for sure if that’s part of the issue or not. But it’s an easy problem to fix by changing distros if it continues to bother me. I like Mint and wanted it on that particular computer, but there are others that will work (and have worked) fine.