Fixing Freezing Caused New Problems

System was freezing when going to sleep, required hard shut down and files and folders were not opening. I checked driver manager and installed recomended update:
Device-2: NVIDIA GP107 [GeForce GTX 1050] vendor: Dell driver
That solved the freezing BUT
Ran: sudo dpkg --configure -a
`jennifer@jennifer-Inspiron-3668:~$ sudo dpkg --configure -a
[sudo] password for jennifer:
Setting up nvidia-dkms-450 (450.80.02-0ubuntu0.20.04.2) …
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
Removing old nvidia-450.80.02 DKMS files…

-------- Uninstall Beginning --------
Module: nvidia
Version: 450.80.02
Kernel: 5.4.0-53-generic (x86_64)

Status: This module version was INACTIVE for this kernel.

DKMS: uninstall completed.

Deleting module version: 450.80.02
completely from the DKMS tree.

Loading new nvidia-450.80.02 DKMS files…
Building for 5.4.0-53-generic
Building for architecture x86_64
Building initial module for 5.4.0-53-generic`

The rest of that message in the blue box was repairs would still be done but with no password the system would likely be unstable.

DANG!! When the system rebooted to the repair and asked for the new password, I could find no way to put it it. The cursor was not present and pressing enter just gave me a passwords don’t match. I could not put in the required new password. Now I am stumped! Clearly, changes are required but danged if I can see how to proceed when typing a new password fails. CRIPES!! This is only a little frustrating. :? :frowning:
I tried running the code sudo dpkg --configure -a again but it did not bring up a fresh attempt to run the process again, so not having been able to run the change with a new password suggests my system will be unstable. It’s reaction times are still a little sticky but at least I can power off and Screen saver no longer freezes.
Ran: journalctl -b -1
And see segments grayed out and the following yellow lines.

What should I do at this point?

P.S. Should I install any of these: