Gnome Annoyances - Gnome 3.36.8x

Here’s one thing that gets my goat, how Gnome 3.x lets you drag a window so that its title bar is UNDER the top “Panel” - i.e. the top “bar” with the notification area… IT lets you do that - BUT it will no longer let you grab it again OUT of that bar - because it’s UNDER it and the window controls and title bar of that application window are UNDER the top bar.

How f–king lame is that? Yeah! Lucky I still remember ALT+SPACEBAR to get window control again - but - HOW did Canonical (and Gnome’s) development team let this through? I guess if I could be arsed, I could log a bug report?

Any Gnome 4.x users here? Does this still happen?

I’m guessing the reason it happens to me, as I have a 2nd monitor on TOP of my main 32", and in the displays arrangement, I also have it “virtually”.

I just tried it here at work (popped into the office for a change) - and yeah :

How dumb is that - letting me do that… There’s just enough left there for me to grab the window title bar, but not always with apps that have shorter height titlebars (and then I have to break out the “ALT+Spacebar” trick).

BTW - that’s not MacOS, or elementary - it’s pretty “stock” Gnome 3.x desktop on Ubuntu 20.04…

While I’m there - that screenshot shows another annoyance, where my script (imgclipit.bash - it uses “xclip” to copy images into the clipboard) barfs on filenames with spaces in them - I’m constantly having to add this to my scripts :
I guess I should go ahead and add that to my profile… PITA

I have an unusually sized array of monitors attached to my computer, which leads to an “invisible” monitor appearing from time to time, which in reality does not exist. But the computer thinks, it exists. That leads to windows sometimes disappearing entirely into that limbo.
I learnt to deal with it by selecting the window in the taskbar and then pressing Win + Right Arrow Key, until it’s on my master monitor, again.

Since Linux has a very friendly attitude toward keyboard shortcuts, I would find it surprising, if that feature wouldn’t be available on that operating system, as well.

Contrary to your view, many fans thought the same about the Unity desktop back then. :laughing:

Of course, it let’s you do it!!! Linux is so powerful!!! You can do anything with it !!!
– Every Linux fan ever


Could you post the source? I’d like to see where it does not understand the literal string situation.

It’s got swearing in it - be forewarned :smiley:

#!/usr/bin/env	bash
# Plonkin a pitcha in da clipbud
if [ -z $ARG ] ; then
	echo " need to provide an image (PNG) file to work on..."
	exit 1
elif [ ! -f $ARG ] ; then
	echo "fuckin' eejit - there's no such file in $PWD ya fuckin' moron!!!"
	exit 1
case $ARG in
		export TYPE="png"
		export TYPE="jpg"
		echo "we can't do jpg as easy as png..."
		echo "first we gotta convert..."
		convert $ARG png:- | xclip -selection clipboard -t image/png 
		exit 0

		echo "not an image file???"
		exit 1
xclip -selection clipboard -t image/$TYPE -i $ARG

I fixed that error by adding that “IFS” bit… Another solution might have been to put double quotes around $ARG :
xclip -selection clipboard -t image/$TYPE -i "$ARG"

Indeed, I suspected that. I trained myself to always put quotes around every string, even the most generic and compatible ones. I also trained myself to always call variables the most proper way. Yes, I sometimes even do "${1}". I know, it’s a bit much, but this way, I am so used to putting quotes around everything and expanding variables properly, that I never get such issues with spaces or special characters. The quotes make life so much easier.

Sorry, cannot resist…


Or Alt and left click mouse. Used to have this problem in Gnome 2 days using Compiz. Especially with Desktop Wall on, or with wobbly windows. Ended up turning it all off in the end.

Note : that was a typo (more like a brainfart), to open the system / title bar menu from keyboard, it’s “ALT+Spacebar” - NOT - "CTRL+Spacebar - I have corrected this in my original post above…

I did not learn this in UNIX or Linux - I learned it in Windows 3.0 (not even 3.1 or 3.11). I don’t know if Microsoft “borrowed” that from X11 or Motif or whatever - who did it first? MacOS 6 (the first MacOS I ever used) or 7 didn’t have this feature.

Gnome 3.x is hardly “UNIX” - it SHOULD be Gnome’s job to STOP me doing that IMHO…

It still happens in Gnome 4.1 and 4.2!

And in another piece of Gnome shittiness, well maybe not Gnome, but - it happened to me in Gnome… I installed Lutris from a DEB file - but it wouldn’t display - so I purged it… and re-installed using the PPA method (I hate using PPAs)… and SAME symptom! I can see it running, e.g. “ps -ef |grep -i lutri”, it shows up with a dot under it in my dash, it shows up in “alt+tab” - but I can’t get it on my f—king screen! I’m just about to give-the-f–k-up on it - when I remembered “alt+spacebar” - in this case I had to run it completely BLIND!

  1. Alt+Spacebar
  2. down
  3. down
  4. enter

them flop the cursor about like a dying fish until I get a window on one of my monitors!

This comes of having this monitor arrangement :

Far left : QHD
Middle : QHD
Far right : QHD
TOP Middle : 1080p


The Lutris window was insisting (or Gnome was) on displaying in some “limbo” area to left of the top middle monitor, and above the far left monitor!


But - no - I’m not going to jump over to XFCE or KDE… And I DETEST (with great passion) LXDE, and I don’t think I could abide a tiling Window manager, and elementary’s pantheon looks lovely, but the whole elementary locked down paradigm feels like prison…

Guess what? While there are some minor (and major) annoyances in Gnome - I prefer it to EVERYTHING else :

    1. Gnome
    1. XFCE
    1. MacOS OS X Quartz
    1. elementary
    1. KDE
    1. LXDE
    1. MS Windows

So - these two particular annoyances (Lutris window in limbo, gnome letting me plonk an application window titlebar UNDER the top bar) - are no doubt due to my peculiar window arrangement… I have it like this 'cause I keep the top monitor running with VLC fullscreen on ABC TV News all day (and most evenings too)…


Happened to me again on the weekend - fresh install of Ubuntu 22.04 with Gnome 42…

Trying to find all the SHITE fonts that Canonical thinks EVERYONE in the whole anglosphere wants and needs for the 700 dialects spoken (and written) in South Asia :

Anwway - the “Font Manager” app was running, showing as an icon in my dash (dash to dock) - but not visible anywhere… I had to make sure it was “active”, hit “Alt + Spacebar” then remember down arrow (THREE TIIMES ONLY!), press enter, then wiggle the cursor about till the clingy piece of crap (very much like when a loose piece of shitter paper gets stuck to the bottom of your shoe!) is on an actual “real screen”… The fact that gnome does this, means is FAR from ready for primetime…

Ubuntu 22.04 adds even more SHITTY fonts on the shitpile they foisted on us in 20.04, I had to update my FUCK-off-fonts.bash (that’s the filename of the shellscript - sorry if you’re offended, Colourful English is my native language), the 2nd line in the for loop script :

for font in "${aFonts[@]}"; do
  sudo apt purge -y $font
  sudo apt purge -y fonts-teluguvijayam fonts-urw-base35

(note : it’s not really “my” shell script - I purloined vast swathes of its content from :

# Author: Rik -
# Licence: LGPL


And yeah - Gnome 42 still lets you plonk an application title bar, under the top panel / system tray - it SHOULD NOT DO THIS! This is NOT UNIX!

Just hit another major annoyance, how applications and desktop files aren’t consistent.

I VASTLY prefer the 1.4.x Sayonara that I can install on Ubuntu 20.04 as a DEB file, but it will NOT install on Ubuntu 22.04 - so I have to use the one that Ubuntu now includes by default (1.7) - which is considerably flakier, and more BLOATED than earlier versions - and - it has a *.desktop file in /usr/share/applications, and you can “add to favourites” in the dash, but when you launch it, you then get TWO INSTANCES of that icon in the dash! WTF? Also - you can keep clicking on the launcher, and gnome will continually happily launch new instance windows of the application! How clever!

So - I have to do this :
fire up sayonara, then in a terminal :
xprop WM_CLASS
and click the crosshair cursor on the Sayonara window… exit sayonara
The result from “xprop WM_CLASS” is a string :

WM_CLASS(STRING) = “sayonara”, “sayonara”

So I have to superuser edit the systemwide *.desktop file :

sudo vi /usr/share/applications/com.sayonara-player.Sayonara.desktop

and insert this line :


somewhere in the file (I plonked it over the “Exec=” line)… and subsequent launches will only show a single icon (launcher, and “running status” blah blah)…

While this SHITE carries on - Linux can NEVER be a replacement for Windows or MacOS (and yet, I will persevere with Linux :smiley: ). IMHO desktop linux is still like 10 years away from userland use-ability (this despite the apparent success of the SteamDeck - heck - most of the gaming consoles use some form of BSD).

In summary - Linux is till VERY MUCH a hobbiest operating system… Sometimes that bothers me, but mostly it doesn’t, and in many ways I’d rather it remain a niche “thing”…

1 Like


It just happened again! It’s more like stepping on a giant wet dog terd than having toilet paper stuck to the sole of your shoe…

Alt+Spacebar, down, down, down, enter :

And you can’t dis-engage the piece of crap - has a giant omni-pointing cursor in the middle… can’t screenshot the piece of crap either… Alt+TAB will get rid of it (it will let go of the window onto whatever monitor / desktop its hovering over…

Honestly - it’s a nightmare from a UX perspective…

Nightmare scenario :

Your boss calls you up, you have to do a sales pitch for Linux on the desktop to a bunch of corporate wankers and bean counters!

I think I’d rather seppoku :

At least it forced me into action of writing a shell script to migrate Lutris from one 'poota to anothery :

╭─x@titan ~/bin  ‹main*› 
╰─➤  cat lutris-clone.bash 
#!/usr/bin/env	bash
# clone Lutris library from one piece of shit machine to another
BOX=$(uname -n)
if [ $BOX == $FROM ] ; then
	echo "oi moron - wrong computer!!!"
	exit 1
FOLDERLIST="/home/x/.config/lutris /home/x/.local/share/lutris /home/x/Games"
	if [ ! -d $SHIT ] ; then
		echo "maybe create the folders first moron?"
		echo "$HOME/.config/lutris, $HOME/.local/share/lutris and $HOME/Games"
		exit 1
	echo "this is copying the shit over...." 
	echo "rsync -av $FROM:$SHIT/. $SHIT/."
	rsync -av $FROM:$SHIT/. $SHIT/.

Okay - rather than start a new topic - how about Gnome 42??? There’s things to love - but - there’s an almighty sewage truckload of stuff that really gets my goat!

The worst thing? Application open and save dialog boxes! ARRRRGGHHHH!

There’s NO WAY to switch to icon view when you’re opening or saving something… I REALLY REALLY want to see icons / thumbnails (LARGE 'cause I’m in my 60s and have REALLY crap eyesight) so I can see “what’s what” - but no! My only choice is a tiny bunch of rows for each object / folder in that folder… What’s the f–king point of thumbnails if they’re like 1/16th the size of a regular postage stamp???

It’s an almighty SHITSHOW! That’s what it is! PEZZO DI MERDA!

How did this get approved? How was it an improvement? And half the time, you’re saving something, and muscle memory has you start typing a new filename, but Gnome / Nautilus (where does one end, and the other start?) decides you really didn’t want to type a new name - you wanted to search for something with that string you just typed…

Not just that - there’s NO RHYME or REASON whatsoever to its arbitrary dialog box geometry - sometimes it presents a file operation dialog that’s BIGGER (heightwise) than my WHOLE QHD monitor (2560x1440)! WTF? How did this get passed? Who’s fault? Canonical’s? The Gnome Dev team?


I guess I can’t have everything - Gnome 42 is LESS usable and user friendly than f–king Gnome 3.36? Damn - I want Ubuntu 22.04, with the latest MESA and AMD GPU drivers and RADV, but NOT Gnome 42 (and how the flying f–k did they go from gnome 3, to f–king 40 anyway? That’s 37 versions they jumped! :rage:

And here’s me shouting and swearing (I’m even more “sweary” IRL, almost tourettes) - but ALL this shit is BETTER than MacOS, and like 10,000x better than Windows!

Maybe I need to go more bleeding edge? Because even with those much more recent OSS drivers on my AMD GPU - I still CANNOT have f–king Real Time RAYTRACING…

Hmmm - maybe time to go back to Ubuntu 20.04 and install AMD’s “Radeon Software” (I guess what used to be called “Catalyst” drivers - note : AMD have still NOT released “Radeon Software” to run on anything later than Ubuntu 20.04). So much for AMD opensource drivers being so much better than NVidia’s - I still don’t get “bleeding edge” features that are “run of the mill” on Microsoft Windows… I so so so really much wanted to try Quake II RTX (free to play on RayTracing GPU’s - which mine is - but the OSS driver is holding me back!).


Go F–K yourself! The AMD RX 6600 is capable of realtime raytracing! :rage: The “RX” in the product name is a HUGE clue…

Bleeding Edge, but still not sharp enough… What a gigantic shitshow… Even if I wanted to go back to 20.04 and run “Radeon Software” - I’d have to force-lock my kernel to 5.4! Maybe I should have stuck with my NVidia GTX1650 “Super” - which NVidia did “backport” real time raytracing support for…

Also - I am not going to try “scaling” to 125% or something - I LOATHE scaling (Linux / Gnome at least does it slightly better than Microsoft) - I don’t want to upscale EVERYTHING, just the thumbnails shown on file operation dialog boxes in the default “list view” (which is FIXED forced on the user).

That type of issue happens to me very often in a variety of programs. It’s never absolutely clear, when you are naming or searching for something, which means you will always lose a second or two for trying out. The worst thing about it is the frustration accompanying the situation. There’s always that damn!! moment you realise it’s not doing what you want it to do…

This is what, due to my personal experience, sounds like your average GNU/Linux GUI user experience. Shit like this is always the type of thing I think about, when people talk about how they use Linux GUI.
Back, when I was still using Linux GUI frequently, such quality of life issues constantly hit my face. It was extremely annoying to me, because in my mind this is part of absolute basic functionality. It’s not even quality of life stuff, to be strict. It’s absolutely basic stuff. I never could and wanted to wrap my head around such issues, because it was so extremely infuriating.
This is one of the many things I hate about Linux GUIs. They have customisability and other advanced features available, but when it comes to the absolute basics, they aren’t even able to size windows properly. What is the point of those advanced features if even proper window size is an issue!!!

I felt like that when I recently wanted to run an AppImage on NixOS. After a couple of hours, I gave up, booted up some random Ubuntu 18.04 someone else put on that laptop previously and got that AppImage running within two minutes and finished my operations with it within a further couple minutes. It was a breeze.
That’s when I again realised: “bloat” is usually not bloat! It makes things work!

In my experience, Linux GUI is at least a 1000 times worse than any Windows. Windows has so many issues and lack of customisability, but at least that damn thing works and knows how to size windows or how to properly fullscreen them. Still remember, the last time I used Debian GUI, I was NEVER able to fullscreen windows on other monitors than the primary one properly, because the window always spanned over multiple monitors. What the hell?
In Windows this just works, without me needing to set up anything. Just plug in those monitors and it works. Oh and using multiple GPUs didn’t work either. In Windows it’s a question of plug & play, while in Linux it didn’t work, even after I was trying to make it work for hours…
I could go on and on about the crap I ever experienced on Linux GUI and how all that shit just worked on Windows, without a single itch.

Sounds, again, to me like the average Linux GUI shitshow. I wouldn’t even blame AMD or NVIDIA for this. Linux just constantly does these graphics things wrong. At least, that’s my experience from years and years of Linux GUI usage.

That’s also what I hate about the Linux community mentality.

“Just turn off an entire feature your setup depends on, then it works. So, don’t complain that it doesn’t!”
Like, no. Why do I need to disable an entire feature for something else to work?
Or why do I need to install some weaker graphics driver for one program to work?
Why do I need to remove an entire program just to make something else work?

The issue with that is, that many people call these “solutions”. I call them “workarounds”. So, even if part of my setup works, after applying a workaround, I never consider it “solved”.

Such basic things shall just work. Without question. Without disabling anything. It shall just work, without an itch.

1 Like

All this is why I think we’re still at least decade away from any noteworthy share of the desktop market… even then, I think I’m being optimistic…

And something else? I don’t really care… I kinda prefer the idea of Linux being a niche thing… The real power of Linux is the shell anyway, and if the shell scares new users away, I really don’t give a rat’s arse :smiley: :heart:

At some stage I guess, the Steam Deck is going to make Linux (real Linux not that lame Java runtime running the kernel foisted on us by Google) more ubiquitous… But will it? I’m still pissed off I can’t get one in Australia - but - I’ve seen a lot of posts by new users, still sticking with Windows on their desktop machines - and using the “big screen” (i.e. steam fills the screen with a minimal interface with HUGE screen elements - like on a gaming console from Sony et al - note the defaul UX on Steam Deck is not the same thing as Steam Big Screen - but it’s similar) interface - and never venturing into the included KDE desktop…

Anyway - I don’t anticipate getting a SteamDeck anytime soon, but, I’ve stopped using my Thinkpad E495 (with Fedora 36) as I already have enough computers on my desk… When Valve eventually release SteamDeck OS 3 for everything else (it’s on their roadmap) I might install it on this Thinkpad… it’s similar specs to the SteamDeck, AMD Ryzen with Vega 8 graphics, mine’s got 16 GB DDR4 and 1 TB NVMe…

I think, we are a big change in mentality away. If the mentality of the majority of people responsible for major Linux distributions don’t make things more approachable, Linux will never be competitive as an end-user’s operating system.

On one hand, I agree, because I almost exclusively use the shell, however on the other hand, I wish there were a competitive open source alternative. I wish, there were a Linux distribution that is as comfortable, usable and PITA-less as Windows for normal use-cases.

My situation is like this: I prefer the lack of customisation options but have basics work flawlessly, rather than having advanced customisation options available, while having the simplest basics not work properly.
That’s one of the main reasons I barely can handle Linux GUI installations for my life.
If I’m just looking at how many hours you have spent already on issues, I have never or at most very rarely had on Windows, it just scares me away even further from using Linux GUI in my real life.
Now, I am not as patient and persistent with such issues, as you seem to be, because it just always annoys the crap out of me, pretty quickly. I want my main system to just work. I pay the price by selling my soul to Microshit, but Windows is a hell of a drug, when it comes to convenience, compatibility and having things just work.

Ironically, the last time I had a disaster with Windows was a couple of years ago. Only about a year ago, I found out that it was caused by Linux being installed on the same computer, through a multi-boot setup. If I had not installed Linux, I would’ve never had that disaster and wouldn’t have permanently lost precious data.

With Windows, I turn it on and everything works. The only things that “break” are some reset audio settings after a Windows or sound driver update.
With Linux GUI, every boot up was a play with the devil. I never knew if it was broken now, or not. It was always an unpleasant mystery to wait and find out. Then, instead of going about my life, I had to fix this, that and additional things, to even get into the damn Linux GUI.

Therefore, after all this Linux GUI crap in my life, I had given up and used Windows for 90% of everything I do. The other 10% is WSL/2, GUI-less servers & Linux GUIs on laptops, which are not my main systems, but something on the side to supplement my main system.

Now, I try to go back to Linux GUI, because my friend showed me that it’s possible to have advanced Linux GUI setups work, without hiccups, once you set it up for a couple of weeks. Linux GUI also became much better in the past few years. Especially KDE is a monster of improvement. They work so much on this desktop environment, it’s very motivating and inspiring. There’s a great team behind KDE.

This time however, I won’t dive into the deep cold water upfront. I will dip my toe, then the foot and so on. I will switch to Linux GUI, once I can confirm everything will work perfectly fine on it, just as needed. This process will most likely take years…

Every Linux wannabe fanatic craps on Ubuntu for making Unity, doing this, streamlining that, making other things restricted or even partnering with unpopular brands & companies.
I just want to laugh at that, because Ubuntu is the only one doing at least something right. They make things work. I don’t know any other distribution that has such a huge amount of compatibility & usability with things.

I don’t care if Ubuntu uses Unity or whatever. If it works, I’m on board.

I never used Ubuntu as my main Linux GUI system. I admit, I was one of the people complaining about Ubuntu and its derivatives. Then, I changed my mind. Making things work is the most important thing about operating systems. Everything else is secondary.

Perhaps, it’s time for me to go Ubuntu.

Not remembering which YouTube video it was, but there was some guy talking about a broken game. He told the audience about a significant truth, everyone should know about, because you can apply it to so many software use-cases.

What is the most important thing about a video game?

It does not matter how great your game is, if nobody is able to play it.
It does not matter how customisable, beautiful, accessible & private your operating system is, if it is not usable (enough) for a variety of reasons.

Steam is doing a great job. Already did with Proton alone. Now, it went up to the next level. Now, it all makes sense. Linux has a chance with Steam and its Steam Deck. The Steam Deck absolutely obliterates any Nintendo Switch styled consoles. Since the Steam Deck launched, the Nintendo Switch console and its competitors pretty much died a horrible, but quick death.
The Steam Deck introduces console play with PC Masterrace DNA in it, for the first time in history.
The Steam Deck literally wrote history and opened a gate, so many people had given up on trying to open.
It is compassed.

The Steam Deck is the messiah of the console world. He has come.

Without the touch screen, compactness, coolness, online assistance, etc… :wink: :laughing:


Yes, but I lament the tendency for ‘making things work’ to lead to ‘making things more complex’
My vote would go to the simplest GUI that works, always and in all environments, including your multiscreen stress test. sophisticated graphics cards, and inexperienced users.

Bloat is something else… adding unnecessary things.
Are we sure the basic GUI design is not the problem?
I must admit KDE is more progressive than I once thought
I imagine most Linux users would be disappointed you had to to to Windows to get something to work

I wasn’t considering it a replacement for the SteamDeck… merely an interim stopgap - once they release SteamOS 3 to “everyone” (perhaps they mayn’t - there’s already SteamDeck clones on the looming horizon - I don’t think there’s anything in GPL or even the BSD licenses that say Valve HAVE TO make it easy to run their distro on anything) - by SteamOS 3 I mean the arch based distro they build upon, not the old Debian based SteamOS… If I’m lucky I might be able to get one on next year’s tax return cheque… And no I’m not going to run Manjaro on the Thinkpad…

More Gnome annoyances?

My preferred simple image manager is shotwell - I use it to crop images all the time… But it kept happening to me today - the mini crop toolbar would stay hidden :


Doh! So I had to write a shell script to reset Shotwell to defaults :

╭─x@titan ~/bin  ‹main*› 
╰─➤  cat fix-shitwell.bash 
#!/usr/bin/env	bash
# Gnome 42 is a piece of crap...  disappears the crop control in shotwell :
/usr/bin/gsettings reset-recursively org.yorba.shotwell.crop-settings

It’s probably 10 years or more since I had to do anything like that (I think in the 2nd iteration of Unity - and bear in mind - I actually quite liked Unity and kinda miss it - but not enough to saddle my system with legacy rubbish just to run Unity) - I remember Ubuntu did something hideous with scroll bars in 11.x or something, Unity was okay - but the scrollbars pissed me off and I wrote a gsettings shell script to fix them…

Now I’m thinking about writing a shell script to run xrandr to alternate primary monitors… When I’m gaming - I want my middle monitor the primary for full screen gaming, as most (all?) games default to my desktop’s primary monitor… I can run the game in windowed mode I guess, but that’s less than satisfactory…

I reckon 2011 was around the last time I had to resort to running botched together shell scripts to make things work how I wanted them in Ubuntu - here we are in 2021 and I’m having to resort to this again! WE’VE MADE NO PROGRESS!

I dont get this.
It is worse than no progress, it is new problems in previously satisfactory software.

Those issues with shotwell haven’t re-occurred for a fortnight at least (haven’t even needed to break out my shell script solution)…

Anyway - SIX weeks in with Gnome 42… there’s still more to hate than to love, and to think it probably won’t be "mature’ for another 5-7 years! Sounds like they’re (Gnome dev team) throwing the baby out with the bathwater sometimes…

The lack of consistency between files / nautilus, and application file operation dialog boxes is enfuriating in the extreme - to the point where I try to avoid them altogether… Why can’t we just get a nautilus window? I’d be happy with nautilus on it’s own…

Here’s one thing I REALLY like in Gnome 4.x - the new Gnome terminal application “console” (installs at /usr/bin/kgx). It’s not very configurable, and forgets some stuff you did (like window geometry) but remembers other important things like font size (you can’t specify the font, or size, but zoom in, or out changes it, and saves it on exit - I run mine at 130% zoomed)… It has a tiny amount of transparency, it needs more, as the default is not readily adjustable - but - it’s VERY responsive, I prefer using Gnome Console to Gnome Terminal… One of the neatest things, sure it’s a toy, but, when you’re remoting, the title bar changes to purple, where you’re “su -” or “sudo -i” it changes to red! That’s awesome… I’m sure other terminal apps probably have this feature, and the Gnome dev team are just playing catchup…

I’m yet to try the replacement for gedit, Abishek recently published two articles about Gnome 42, one was about the new text editor, the other was about the new terminal application… Sorry - I read them earlier today after seeing them on social media, but can’t find the links anymore (and they’re not on the front page at It’s Foss, not that I can see anyway).

I can’t put my finger on it - but it seems more responsive, and it looks more dynamic, e.g. the readout from an instance of bashtop (much better replacement for top) is so much more “dynamic” in Gnome Console, than it looks in Gnome Terminal … more “vibrant” maybe?

Default - logged in as me :

After “sudo -i” :

Remoted to a Red Hat instance I have running on a NUC :

Note - “fuglpige” is allegedly “bird girl” poorly translated, from the Greg Bear novels about fighting an alien race of sapients which have feathers, and I named my main “race” in the game Stellaris (available natively on Linux!) “Fuglpige”… It’s probably wrong, and I can’t even remember which North East Germanic language I chose for that shonky (mis-)translation in “Google Translate”.

I’d like have a few more things to configure :

  • specify font
  • specify font size
  • specify opacity
  • specify lines of scrollback (default is 10K - sounds like a lot - but sometimes it’s not)
    thankfully it doesn’t have that annoying as F–K bell when you backspace too many times!

I can say one thing - it’s MUCH more usable out of the box, than elementary’s “Vala” terminal, which is neat, but it’s so locked down (e.g. fully opaque out of the box, i.e. no transparency!) as to be almost unusable, and whenever I’ve used elementary for more than a day, I’ve eschewd Vala, in favour of XFCE Terminal, or Gnome Terminal…

I quite like it anyway… Might keep using it…

All these annoyances and first world issues, but I’d still 1000 x rather use Gnome 42 than MacOS, or 10,000 x rather than use MS Windows of ANY flavour or version…

Damn - won’t I give this a rest - the whole thing is now “how I learned to stop worrying and love Gnome forty-something” - but here’s two cases in point :

“Average” gnome file save operation dialog box :

There are NO options anywhere to change how it displays my information… I’m sure it breaks a bunch of UI interface design rules anyway… it’s uglier than a fedora chockfull of sphincters anyway - looks like something from 1992…

Here’s Gnome 42 files/nautilus view of the same folder (icons because I chose so - but I could change it to a tabulated list if I was so inclined) :

If things get worse in Gnome 43 (and hopefully Canonical will let me have it in 22.04 LTS and not wait for 23.x or 24.04/24.10) - I may just jump back to XFCE and or elementary (but I think after booting out their founder - elementary are doomed).

OK - I’m fed up of the inconsistencies in Gnome 42 on Ubuntu 22.04 (they were there in Fedora 35 and 36 too), going to try Pop! OS on my Thinkpad E495 - which was running Fedora, but I haven’t powered it up or used it in over a month…

Let’s see how we go there… If that proves satisfactory - I may be wiping my desktop machine and running Pop! OS…