Grub2 fails to list all operating systems after Ubuntu up-date

Machine has several Linux and 1-windows7 operating systems installed. Ubuntu updated and then reconfigured its grub menu. When grub completed its configuration, grub menu listed the Ubuntu operating system which updated. I observed the updating process and noted that all of the (sda) installed operating systems were recognized, however, these were not added to the grub menu. grub update was once-again run manually with no success in setting grub menu right. Is there a possibility that an re-installed grub could fix this?

Ubuntu: 18.04 bionic (i686) 32-bit
Gnome: 3.28.2(Ubuntu)

When OpenSuse upgrades Grub2, I lose the other OSes and can only boot OpenSuse until I do the following:

  1. open a terminal
  2. type su and hit enter (for Ubuntu skip this step)
  3. type root password and hit enter (for Ubuntu skip this step)
  4. type os-prober and hit enter (for Ubuntu type sudo os-prober)
  5. verify that all the other OSes are found (for Ubuntu type sudo password and hit enter, then verify)
  6. type grub2-mkconfig and hit enter (for Ubuntu type sudo grub2-mkconfig)
  7. type update-bootloader and hit enter (for Ubuntu type sudo update-bootloader)
  8. reboot and verify the other OSes are now in the menu list

Sorry, the command is update-grub instead of update-bootloader

Trust me, Grub Customizer is an acceptable solution. The reason it did not get updated is because you used the wrong GRUB. You need to select the one that is actually responsible for the menu you see at the startup. (Yes, this means you have 2 or more GRUBs installed at the same time…)

Repeat the process you did with Grub Customizer, but this time select the correct GRUB location, in the top left corner of the GUI Window.

Sorry I couldn’t help. My steps worked for me many times over the years. Did you skip the os-prober command?

Akito this screenshot indicates an problem with /boot/grub/device-map. Any ideas’

More info later.

1 Like

Did you change the selected partition? Try changing and see if theres a second GRUB, when loading the menu configuration.

This problem is not solved, and needs additional input.


1 Like
  1. Remove all instances of Grub (Important!).
  2. Reinstall GRUB:
    FAQ - Read before you post a request for help
1 Like

Hey Waldo, sorry to change the subject. I do know you must be getting frustrated. But I very much like your DE - Desktop Environment. Which DE is it?