Hard drive is always looked at as file. Need to unmount each time

I am using linux mint 19.2
I have a hard drive that is looked at as a file. I always have to unmount it for me to access it.
My other hard drive works fine.
How can I fix it.

Care to elaborate?
…
…
…
…

1 Like

As @Akito says please supply more information about the problem so the community can help you with a solution

1 Like

We have a 1 Ter. hard drive that is plugged into the mother board. Just like the other hard drives, but this one is always looked at as a file, not a hard drive. Have used disks utility and tried changing it to a bootable and also unmounted it there. But to no avail.
Would like to have it seen as a hard drive, but if not will unmount it each time.
Using Linux Mint 19.2 but it was the same on 19.1
Have formatted it for linux but still not seen.
Dont worry if there is no fix, we can get around it.
Ross

“Plugged into the motherboard” means, via SATA?
How many other HDDs are there?
Have you tried with e.g. gparted to re-partition it?

It is very unprecise what you are saying. Please explain exactly what you are doing and what commands you are using.

(All drives are seen as files on Linux and that is the default behaviour…)

1 Like

Yes via sata.
Yes tried gparted

Then why is my second drive looked at as a hard drive.
We have 3 hard drives on board

???

Please explain exactly what is happening, what commands are issued and what is shown, how and where. Please be specific or nobody here will be able to help you appropriately.

Maybe take some screenshots.
A picture sometimes clears things up better than long descriptions.

2 Likes

@emit as @Akito has said to you please be more specific as I for one am struggling to understand exactly what your problem is just looking at this thread. The more information you can give the sooner our community will be able to help you with it. Also @Fast.Edi has suggested a screen shot would also be helpful.
When we have a problem, we all think we know what we mean, it is just when we try to explain it to others it doesn’t quite come across to them. We’ve all done this, so this is not a criticism of you, just saying please try and give more information so we can help okay :grinning:

3 Likes

OK here we go.

If we unmount the drive it works fine.

What does disk management show?

How does it mount automatically all the time ? Is that something you have set ? Or, simply because it is ext4 ? If you can handle the data in it, I might suggest trying the file system as NTFS or similar. Simply to see how it responds.

This is how it comes up each time I boot the computer, once I unmount it , it works fine.
I just have to do it every day

Describe the process step by step, what exactly you are doing after boot up and what is exactly happening when.

1 Like

After boot up I get busy, but when I want to access my Ross 4 drive I go to files. There I can access my root and also Ross 1 drive. But when I try to access Ross 4 I get the message I sent to you.
I just dont understand why Mint will look at Ross 1 with no problems, but not Ross 4.

What is the file system in Ross 1 ?

Can you please post the contents of the /etc/fstab.

The fstab is the control file that shows devices, mount information, etc.
Also indicate which line of the fstab is the drive in question as your fstab typically shows
UUID=xxxxx for all entries.