How to enable read-write permissions on a USB flash drive

Tried a number of suggestions w/o success.
Here’s my situation. Using Linux Mint 19 I installed a app called Multibootusb. It allows you to have multiple bootable ISO on a single flash drive. This app makes the usb flash drive read only and nothing seem to change the permissions. I have scoured the Internet for solutions and everything suggested so far has failed. Hoping someone knows a way to overcome the Read Only permissions on my USB Flash Drive.

Like what?

On Linux:
hdparm -r0

On WIN10:

What exactly did you do?

I attempted to reformat, create a new partition, delete files, remove the “read only permissions”. I tried everything I could do so that I could re-purpose the flash drive, since the full 128 gig was read only it is now useless to me if I cannot find a way to remove the read only file permission.

How did you attempt the reformat and what was the error code? If you don’t remember, attempt it again and post the output here. Ideally prepending the formatting operation, itself.

First use the command “lsblk” for see your usb device.
sudo mkdir -p /media/USBdrive
sudo mount -t ext4 -o rw /dev/sdb1 /media/USBdrive
sudo chown -R USER:USER /media/USBdrive :male_detective:

@76ron First we should find out, what they tried in the first place, to not make useless suggestions.

I am wondering if the reason I cannot delete files/directories or reformat or create new partions, etc. is because my OS see the flash drive as a Compact Disk. I entered cat /proc/mounts and this was returned:
/dev/sdf /media/guy/KNOPPIX_8 iso9660 ro,nosuid,nodev,relatime,nojoliet,check=s,map=n,blocksize=2048,uid=1000,gid=1000,dmode=500,fmode=400 0 0

I have never known Mint to do that. So I don’t think it is a Mint problem. Where did you get Multibootusb from? It’s not in repository, I’ve checked that. Perhaps the problem is with that rather than Mint? Okay just did a search for it online and see what it is.
I have found this if it helps at all, apart from that I can’t offer any advice

Try to remount as drive.

I don’t know how to mount the flash drive in that manner, time to research the mount command.

Tried remounting, if I did it correctly it didn’t work.
Here’s my steps:
guy@guy-HPElite ~ $ sudo cat /proc/mounts | grep KNOPPIX_8
/dev/sdf /media/guy/KNOPPIX_8 iso9660 ro,nosuid,nodev,relatime,nojoliet,check=s,map=n,blocksize=2048,uid=1000,gid=1000,dmode=500,fmode=400 0 0
guy@guy-HPElite ~ $ sudo mount -o remount,rw /media/guy/KNOPPIX_8
mount: /media/guy/KNOPPIX_8: cannot remount /dev/sdf read-write, is write-protected.

It does not work because you are trying to remount it as /dev/sdf, again. You have to remount it as the drive it is, so it mounts as /dev/sda2 e.g., but not as /dev/sdf.

Sorry I really don’t understand your post. The flash drive is currently unmounted, here’s the output of lsblk: guy@guy-HPElite ~ $ lsblk
loop0 7:0 0 88.7M 1 loop /snap/core/7396
loop2 7:2 0 54.4M 1 loop /snap/core18/1074
loop3 7:3 0 78.5M 1 loop /snap/scrcpy/136
loop4 7:4 0 202.3M 1 loop /snap/vlc/770
loop5 7:5 0 202.9M 1 loop /snap/vlc/1049
loop6 7:6 0 183.6M 1 loop /snap/vidcutter/14
loop7 7:7 0 54.4M 1 loop /snap/core18/1066
loop8 7:8 0 54.5M 1 loop /snap/lxd/11643
loop9 7:9 0 78.5M 1 loop /snap/scrcpy/145
loop10 7:10 0 88.5M 1 loop /snap/core/7270
loop11 7:11 0 54.5M 1 loop /snap/lxd/11633
sda 8:0 0 119.2G 0 disk
├─sda1 8:1 0 512M 0 part /boot/efi
├─sda2 8:2 0 102.8G 0 part /
└─sda3 8:3 0 5.2G 0 part [SWAP]
sdb 8:16 1 372.6G 0 disk
└─sdb1 8:17 1 372.6G 0 part /home
sdc 8:32 0 3.7T 0 disk
├─sdc1 8:33 0 128M 0 part
└─sdc2 8:34 0 3.7T 0 part /media/guy/Seagate Backup Plus Drive
sdd 8:48 0 1.8T 0 disk
├─sdd4 8:52 0 1.3T 0 part /media/guy/sda4_1tb
├─sdd5 8:53 0 494.5G 0 part /media/guy/Data_sda5
└─sdd6 8:54 0 4.9G 0 part
sde 8:64 0 931.5G 0 disk
└─sde1 8:65 0 931.5G 0 part /media/guy/Backup
sdf 8:80 1 114.6G 0 disk
sr0 11:0 1 1024M 0 rom

How do I tell my OS to mount the flash drive differently than what the OS sees it as?

Try this after unmounting /dev/sdf.

I already had a /dev/sdb1, I use it for my home directory. To try to keep things simple I am now using a laptop without any initial flash drives attached. The flash drive was inserted but unmounted, after creating the USBdrive directory I entered the mount command and got this error back:
root@maureen-Satellite-C655D:/home/maureen# mount -t ext4 -o rw /dev/sdb1 /media/USBdrive
mount: /media/USBdrive: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error.

The ID depends on your system. You have to adjust it according to your set up. You should read about how to mount devices on Linux and how to manage them.

I will read up on mounting and managing devices as you suggest.

This command failed: sudo mount -t ext4 -o rw /dev/sdb1 /media/USBdrive
cat /proc/mounts reports that the flash drive as vfat.
I modified mount for vfat: sudo mount -t vfat -o rw /dev/sdb1 /media/USBdrive
After executing it, the message returned was that "WARNING: device is write protected, mounted read-only.

Are you sure there is no hardware switch for turning on write protection? Because this sounds seriously like the device is trying by all means to disable write permissions. So this definitely seems like your device is either marked read-only by a hardware switch or it is broken.

Some flash storage devices turn the device read-only once it gained enough bad blocks, so you can still retrieve the data from it before it will break entirely, rendering all data on it unretrievable.