HP printer on the bum (no driver) - viable options? [Solved]

For whatever reason, my good old reliable HP LaserJet no longer has drivers to make it work on Linux.
Tried three times with LinuxMint and again yesterday and today with KDE Neon.
Have installed it many a times before without issues.
Think HP is “driving” this broken issue…

Someone recommended an Epson:

What is your take?

What are you trying to say?

Have you tried installing HPLIP? If it is already installed then delete it and re-install. Also,be sure to delete the config file, which is ~/.hplip/hplip.conf before you re-install. This will let you start with a clean slate.

This worked when my LaserJet decided to stop working.

@don.karon - appreciate that! :slightly_smiling_face:

Had removed it and rebooted, but never deleted that file.
We shall see…

@Akito - the HP LaserJet 1018 is an antique.

Works well on Windows (found a driver for it - HP did not have it).
But with this issue on Linux, it just gets to me, you know?

I wasn’t sure if you were proposing getting a new device, simply because it does not work on Linux.

Simply fed up with getting drivers for this HP Laserjet.

Delete that config file, removed HPLIP from the apps, rebooted, re-installed.
Still a no go.
Decided to try Titan Linux and same issue (error message).
Except for Solus, most other distros i’ve tried thus far have worked just fine at installing the driver.
If only a downloaded version of it could be found (like the one i found for Windows).

It’s an old printer… that’s why i’m shopping around for something usb connected that can work for Linux and Windows.

1 Like

You could try Turboprint. A German company, not free, but not too much either. You get a license for life, for one computer, two printers, I believe. They have tons of drivers, you can contact them before you buy, to find out if they have the right driver. I’ve been using them for years with an old Canon MX 310. Print quality way much better then default Linux, using up less ink.

1 Like

@shamu - interesting!

Will keep in mind if ever get another printer.
Unfortunately, the one i have now is not on their supported list.

Disappointing. However, I used to have a second printer, an HP, it didn’t have the exact right driver, but an alternative worked just as fine, until the printer completely died.

I use CUPS without a driver. A printer’s ability to interpret CUPS is part of the printer hardware - in existence since 2000’s. This was necessary if they wanted printers to function with Apple products. I don’t think it matters how old the printer is. But, you must be ready to do a lot of reading on the web.

P.S: Windows 10 is also using CUPS to connect to our Brother server. The problem is that I cannot find where their setup is. No one wants to answer this question on Windows 10 Forum. . . . More reading.

1 Like

@ineuw - tried CUPS too!

Have done it in the past with much success.
Not anymore…
The printer is listed as expected and all.
Still won’t work.

Can’t you just use it in emulated mode - or PCL generic driver?

I once had a HP colour laserjet, got it when XP was all the go… HP NEVER released 64 bit drivers for Windows 7… There was a 64 bit driver for Vista, that you could install, but when you printed, it would make the whole page black - this was obviously a conspiracy to drive customers to buy a new printer - HP are EXTREMELY guilty of this hideous planned obsolescence, which breaches lots of laws in civilized regions like the EU, but not barbaric backwaters like the USA or Australia…

Note - I can’t remember how we got around this limitation… Never was an issue in Linux though… I think I just used a generic “Laserjet” driver with it…


Think my days of distro hopping on Linux are over.
A.I. has finally put the hatch to my tryouts.
Took me a long while to find a driver (in Windows).
Tried everything and anything.
What i like so much about this 12+ year old printer?

  1. doesn’t call homebase;
  2. is reliable.
  3. is a lot faster than the few most recent “smart” ones i’ve seen!
1 Like

I am really a newbie but I got my old printer working on the second day using .cups.

1 Like

This tip finally did it for me:

sudo apt-get update

sudo apt-get remove hplip cups-filters cups hplip-data system-config-printer-udev

sudo rm -v -rf /usr/share/hplip

sudo apt-get install printer-driver-foo2zjs printer-driver-foo2zjs-common

sudo apt-get install tix groff dc cups cups-filters

sudo getweb 1018

d. Disconnect the USB cable of the printer, count to five and reconnect it.

e. Launch the application Printers again from the menu and add your printer; you may have to click on the “refresh” button (the round arrow) first. Then print a test page.

f. Reboot your computer and turn the printer off and on.

–HP Laserjet 1018 - Linux Mint Forums
HP Laserjet 1018 - Linux Mint Forums

The only difference is that i had the printer unplugged beforehand.
It printed test page after and even after reboot!

-tested on latest Mint Cinnamon.


@danielson I had the same problem with a monochrome HP printer a couple of years ago when I first installed Mint Mate. I could not get the printer to work. I also tried Ubuntu Mate and the same thing happened so I changed to Mint Cinnamon and it worked fine. A friend of mine suggested that the Mate may not have the drivers necessary for Brother. I have no issues at all with Cinnamon.

HP LaserJet 1018 works fine for me on Mint Cinnamon and XFCE, but not KDE Neon.

Wonder why?
They’re all based on 'buntu…

Several experiences have shown, that just because a derivative is based on a popular and comparatively stable distribution, it does not imply that the derivative is just as stable. This is the reason why I wouldn’t blindly recommend Linux Mint over Ubuntu for beginners. Same for Artix. It’s just Arch Linux without systemd, right? Wrong. It’s much more unstable, has a lot more negative quirks, a lot more bugs & glitches, etc. If you switch from Artix to Arch, then suddenly so many things start working.

Therefore, if one wants maximum compatibility, one ought to use the popular base distributions, i.e. Ubuntu, Arch, etc.

But Ubuntu itself is a derivative.