I created a desktop launcher for It's FOSS on my older laptop PC

After creating two tutorials for installing LMDE 6, I decided to put it on my older laptop PC. After finishing up the installation, as part of my ‘customizations’, I created a desktop launcher for It’s FOSS. I don’t like the default icon image (the one that looks like a rocket ready to take off) so I creates one specifically for It’s FOSS. If anyone’s interested, I’ll share it with you all:


You should be able to copy it into kolourpaint or some other graphics editor then save it in whichever format you prefer (the original is a .png file).



Several years ago I used Opera for quite a while. I liked their speed dial style of launcher. So I created a speed dial type of home page for my most used links.


Here is the image for It’s FOSS.


1 Like

If you were really “inclined” - you could even use Nativefier (GitHub - nativefier/nativefier: Make any web page a desktop application) to create an executable that launches Its Foss as an application :smiley: - me - I’m not so inclined - but interesting nevertheless… :smiley:

I make mine the manual way, more fun and know what it is, not worried about some funky lines of code going into my script. A lot of these online launcher scripts set the script up backwards. Yes they still work, but I’m fussy about uniform in my scriptures.

All of my Web launchers

Have now moved everything to brave-browser. Though Thorium browser is a good browser, thinking about moving to that

1 Like

So this is like “Electron” I gather. Did not know we could do that. I would very much be interested in the ItsFOSS script, but how do you deal with login? What I mean is, I have issues leaving the Community tab pinned, because each time I restart Firefox requires logging in and that is only done via email link; which then opens a new tab for logging in, then choosing Community, etc. So I have to keep unpinning original tab and then repinning the one where I am logged in. This could work if we could login with an authenticator app or a code, but not sure with email links.

Not having written scripts before, is there a specific app you are using or just any text editor @clatterfordslim Where does this script reside?

Sheila Flanagan

A script hadn’t occurred to me. Huh, an interesting idea, but I don’t have any issue with logging into It’s FOSS after a reboot, even a day or so after my last session, so I don’t have any need for a script just now. I use Firefox here (currently version 118.0.2, but I’ll update after this post because I know version 119 has been released recently), if that makes any difference, I’ll edit this with an update.

FYI, I use the KDE Plasma desktop environment in Solus Linux here. If you use a different DE, how you create a desktop Launcher (AKA: desktop icon) may differ.

I created the launcher by ALT+Clicking an empty space on my desktop and choosing “Create New . . . → Link to Location (URL) . . .”, which opens this dialog:

I simply give the link a name, and enter the destination’s URL (For it’s FOSS, I named the link “It’s FOSS”, and entered the URL “https://itsfoss.com”, then I clicked the “OK” button to save the launcher/desktop icon to my desktop.

I do have to click to switch to the community page, but after trying a few options, I decided linking to the base page works best for me. How you use this information (if at all) is up to you,

Solus does not yet have the current version of Firefox, so I installed it from flathub and removed the Solus version. After doing all this, I did have to log in again by getting the email link, but that only happens every few days or so.

I agree, it would be nice if members could use a pass key or something similar to avoid the need for the email link, but I guess it works well enough, at least for me. I have a passkey for my Google account on Windows, and I will set one up for my Solus environment when I’ve finished this update.


Any text editor Gedit, Xed, Pluma. If you copy the script above? Make sure you put the path for your own icon in, that you can either make in GIMP or download yourself. The script can be put into your hidden home folder in .local/share/applications. To activate it call it Its Foss.desktop Then right click it left click properties, left click the permissions tab across the top, then tick the box saying Allow Executing File As Program. Open your menu, it’ll be under Internet.

@ernie I wonder if my Firefox on LM 21.2 (still kernel 5) has settings that cause this. I was having trouble logging into some sites due to cache, so I think I set FF to clear cache at each restart. Yes I still have to login to the pinned tabs, but that doesn’t generate a new tab of the same site the way ItsFOSS does.

But clicking the email link for sign in uses the default browser (FF) to open a new tab for sign in. So how does that work in a script? Wouldn’t clicking the email link open it in FF and not the saved window from the script? Just trying to understand how it gets around that. If the same settings in my main FF window applies to the scripted instance seems the same thing would happen.


I’m not sure how all that works, but the first thing I’d recommend would be to turn off the setting to clear the Firefox cache at every start-up. That’d probably resolve your issue with having to get the email every time you want to be signed into It’s FOSS. As for the issue with signing into the other site(s), I’d simply clear the cache for the affected sites (I think Firefox has that level of granularity) when the issue arises.



In LMDE, right-clicking desktop and Create New Link brings this up:

But as you can see, the red dot indicates an error. I am guessing “Browse” indicates needing the exact command for opening FF app. But then I don’t get the specific website:


So I will try again with the script, which offers more detail to allow for a specific webpage.


@ernie & @clatterfordslim I wrote my script as follows:

[Desktop Entry]
Name=ItsFOSS Community
Exec=firefox %U https://itsfoss.comunity/
StartupWMClass=ItsFOSS Community

I gave it the permissions to execute, but executing it I get (as I suspected) a new tab in the current FF window:

So I will try again with executing it in Brave (as I have no open windows in that browser).

I saw in my above script the typo “comunity” and fixed that. Then I edited the script to use Epiphany browser which was already installed. And it worked…except it asked for login and displayed the “check email” message. I had to copy “link location” and paste into Epiphany and that worked. Closing the browser and reopening via script showed me logged in.

After system reboot, will see if it requires login again. However, the logo does not show on my desktop script. Clicking the logo file it opens and displays, but it uses the standard Text icon. In file properties, there is a tab for emblems, but that only adds an emblem like “heart” to the text icon.

If I can get the logo display fixed, and providing it does not take 3 steps to use Epiphany just for ItsFOSS community, this is great.


UPDATE: The only thing I need help with now is getting that icon that I downloaded from @pdecker comment to work with my script that is currently defaulting to the text icon for LM.

Where it says icon= in the script, change it to where you downloaded it to, plus change the name of its foss.png to whatever the downloaded icon is called. Your user name needs to be after home too. /home/username/Pictures/its foss.png

Sorry, @clatterfordslim I did fix the usr name before Pictures, but that did not resolve it. It was downloaded from this thread, above, and saved in Pictures (as the system auto saves image files into pictures). I did change the name but didn’t think that mattered as the script points exactly to that filename. So I “Saved As” again and left the numerical name, then changed the script. Yep…it now displays. Wonder why?

So we are good! Thanks so much.

One more thing: after everything was working with the downloaded .png image, I decided to do as @ernie showed and create a launcher as I thought maybe that would let me pin to panel. As soon as I did that, the image for launcher changed to this:

LOL. I will need to re-route getting this pinned to panel as right clicking the desktop script has no options for that.

Now the script changed to this:


In the Launcher Properties dialog, enter firefox, a space character, then the URL for the it’sFOSS community. That should resolve the error.


I understand that you’ve solved your issue. I post this reply in the hope it may help others who read it:

That icon is the one I don’t like. ALT+Click the launcher and choose properties. In the resulting dialog, click the square image icon (IIRC, upper left) then click the ‘Browse’ button. In that dialog, navigate to the image you want for the icon and double-click it to select it and close the dialog, then, double-click the icon image in the selection dialog to select it and close that dialog. Now you can close the properties dialog and your launcher should have the icon you want.

I think this is all correct,


Yeah we’re good, forgot you’re using Cinnamon I use Xfce Linux Mint 21.2, which is a whole different kettle of parsnip eating fish. Commands in Xfce and Cinnamon differ between each other Script Wise. Still glad you got it sorted.

1 Like

Thanks, @ernie was able to get my icon back.