Installing MatterControl 3D Printing Software

Hello Man,
As you knowingly said, FreeCAD is a little harder to learn. I could make two very simple parts and printed them. However, I’m going to download Tinkercad, following up on your advice. On the other hand, I downloaded and opened MatterControl. It looks great , though, but can’t get to connect it with one of my 3D printers. My printers are both RepRap made with cheap Chinese parts five years ago and both have worked with Repetier very well. One of them is a Prusa Mendel and the other is a Prusa i3. I found this last in the Mattercontrol menu but it can’t connect. Maybe my printer match with another model of those in this Host menu but it is hard to find out. The hardware of my printer is Arduino/ Ramps 10 with Marlin firmware. Do you know something about which one could be a match? Any suggestion will be greatly appreciated.

Hi @Bioethical,
I also built my 3D printer 5 years ago in the same way as yours.
I have never tested the 3D printer with Linux and although the printer has a malfunction at the moment, I need to replace the hotend, I can do all the necessary tests to configure MatterControl.
If I want I can do these tests next Wednesday.

From what I remember, I set up the printer manually in MatterControl, I didn’t use any default settings

BWT, you followed these instructions, correct?

1 Like

Hi @Bioethical,
I’ve just tested my 3D printer in Linux and it’s very to configure, you just need to follow the steps on the MatterControl support page.

I did the following steps (I have Linux Mint 20):

I installed mono’s latest version:

sudo apt install gnupg ca-certificates
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/ubuntu stable-focal main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update && sudo apt upgrade

With the 3d printer disconnected from USB, I ran ls /dev/tty* to get a list of all tty but the printer

I connected the usb to the 3D printer and listed again all tty to find which one is the printer

In my case, the printer port is /dev/ttyACM0

I ran the command below to know the serial number of the USB device:

udevadm info --attribute-walk -n /dev/ttyACM0 | grep "serial"

image

Found what was the serial port’s group:

ls -l /dev/ttyACM*

image

In my case, the printer’s group is dialout

I added my username to the printer’s group:

sudo gpasswd -a $USER dialout

Next, I created the file 97-3dprinters.rules in /etc/udev/rules.d/:

sudo touch /etc/udev/rules.d/97-3dprinters.rules

and I added the following code to the file, in my case using nano (sudo nano /etc/udev/rules.d/97-3dprinters.rules):

SUBSYSTEM=="tty", ATTRS{serial}=="YOUR_NUMBER", GROUP="YOUR_GROUP", MODE="0660", SYMLINK+="tty-YOUR_PRINTER_NAME"

NOTE:

  • replace the ATTRS{serial} number with your USB device serial number
  • replace the GROUP name with your serial port group name
  • replace SYMLINK name with the name you’d like your printer to have. Keep in mind it has to start with tty, for example “tty-3DPrinter”

I saved the file, remove the USB form printer and reconnect USB to printer.

Add printer to MatterControl:

Open Mater Control and click on Hardware tab

click on + icon to create (add) a new printer
image

choose Other category, Other print model, enter a name to your printer, for example, my_3d_printer and click on next button
image

click on Manually Configure Connection

select your printer ( don’t choose dev/ttyACMXX) and click on connect button
image

Now you have your printer added in MatterControl. You can disconnect printer by clicking on Disconnect button

click on your printer’s menu tab and select Show Controls
image

Close menu and click on Controls button
image

I think you already know this menu/functions

To print:

you can click on Print button to print. In this case, you can see an error: “Printer Setup Required”. Click on Setup button

Select Add New Setting

I think you already know this menu. Don’t forget tho check all tabs!

After change settings and name, save and close window

Choose your material and load it

Follow the steps of printer Calibration and click on Next Button

the filament is loaded

Now, if you try to print again,you have a different error " Empty Bed":
image

select Library tab and choose a file to print
image

you can click on Slice Settings to adujst settings, next pressing Slice button and Print button


Tell me if you were able to print with MatterControl

Hello J.A.,
I followed up everything accordingly and all seemed fine but when trying to connect there is no port to select from, only numbers of one or two digits. Not my printer’s port.
I believe that the document that I made with NANO may be missing something. Could you please check it out?
Thank you,

SUBSYSTEM==“tty”
ATTRS{SERIAL}==754393237353519142
GROUP=/dev/ttyACM0
MODE=0660
SYMLINK+=tty-PRUSAI3VHR

Could you try to copy and paste the line below to your /etc/udev/rules.d/97-3dprinters.rules file?

SUBSYSTEM=="tty", ATTRS{serial}=="754393237353519142", GROUP="dialout", MODE="0660", SYMLINK+="tty-PRUSAI3VHR"

Or, if you want to break the rule in multiple lines it’s like this:

SUBSYSTEM=="tty",\
ATTRS{serial}=="754393237353519142",\
GROUP="dialout",\
MODE="0660",\
SYMLINK+="tty-PRUSAI3VHR"

Try again please.


P.S.:I forgot to mention this step: if you receive this message:

Click on the enter key and on the connect key again and the MatterControl should connect to the printer.
I think it could be a bug…

Hello Man,
Nothing happened so I went to their page looking for the port permissions and found these commands but access was denied. Am I missing something here:
$ gpasswd -a $USER uucp
$ gpasswd -a $USER lock

I repeated the whole process and after entered this command and the cursor kept blinking with no end. I tried several times and same thing happened.
victor@victor-ThinkCentre-M58p:~$ sudo tee /etc/apt/sources.list.d/mono-official-stable.list
[sudo] password for victor:

If you work with Mint 20, the group is dialout, not uucp.

Please confirm the correct group with this command:

Could you please add your user to the correct group?

Did you follow my instructions step by step?

Yes, I did follow your instructions step by step. I’ve been very careful but the printer wasn’t detected by the host.
I was about to do it all over again but now I can not open the MatterControl Host desktop anymore: /home/victor/Downloads/MatterControlSetup-2.19.10.10370/usr/lib/mattercontrol .
Mattercontrol.ex no longer opens the desktop no matter what I do with the files.
Now I have nothing. I am very sorry.
By the way, the Mattercontrol.exe icon inside the lib, used to open the host with difficulties. Now it doesn’t.

1 Like

Ok Victor,
right now I don’t have access to the printer or linux but I think I can help you anyway
Want to try now istall MatterControl?

If you want, I can try to help you install your printer with matterControl.
My time zone is GMT + 1.
I am available to arrange a time / day with you, so I can be online and do the installation with you step by step

JA,
I really appreciate what you’ve have done so far. Honestly, I wouldn’t like you to do that for me. However, let me try to redo everything from the very beggining and if I can’t make it, then I’m going to require such additional help from you.
For starting over I need to uninstall the MatterControl program and install it again, so I’d like you to tell me what SUDO I would need to uninstall it completely. Or maybe I just need to delete the file off my downloads?
When I’m done with that, I’ll try to reconnect since the rest of the certificates and packages are already in the Linux Mint 20. Maybe I’ll need to run them again. we’ll see.
Thank you very much,
Victor

1 Like

Hi Victor,
run the following command to uninstall MatterControl:

sudo apt-get –-purge remove mattercontrol

You can check if you are running the latest mono version with this command (this means you successful latest version correctly):

mono --version

The latest version is 6.12.0.90

victor@victor-ThinkCentre-M58p:~$ mono --version
Mono JIT compiler version 6.8.0.105 (Debian 6.8.0.105+dfsg-2 Wed Feb 26 23:23:50 UTC 2020)
Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
Interpreter: yes
LLVM: supported, not enabled.
Suspend: hybrid
GC: sgen (concurrent by defaul

victor@victor-ThinkCentre-M58p:~$ sudo apt-get purge remove mattercontrol
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package remove

It will evidently help a lot, if you copy & paste commands, instead of typing them manually.

1 Like

yes, I noticed the double slashes and did it that way.

Hi Victor,
I believe you are using a 64bit computer, correct?
Try these commands instead of the commands mentioned above for mono installation:

echo "deb [arch=amd64] https://download.mono-project.com/repo/ubuntu stable-focal main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update && sudo apt upgrade

After entering my password the cursor continues blinking with no further changes on screen.

victor@victor-ThinkCentre-M58p:~$ sudo tee /etc/apt/sources.list.d/mono-official-stable.list
[sudo] password for victor: