Linux Mint 19.1 kernel problem

Just finish installing Mint 19.1 Mate on my laptop to give it a try on a spare SSD. Ran into a problem and narrowed it down to one update. Up to this point all seem to be fine. The update I’m having a problem with is ‘Linux Kernel’ level 4 update.
The problem: After the update when I boot the PC, it starts out with 7 to 11 lines of white static at the top of the screen and locks up for about 30 seconds. Then the PC seems to re-boot and I get the normal Grub menu. Before the update I did not get a grub menu.
Here is some info from the inxi command.

easyt50@X220:~$ inxi -Fz 
  Host: X220 Kernel: 4.15.0-58-generic i686 bits: 32 Desktop: MATE 1.20.1 
  Distro: Linux Mint 19.1 Tessa 
  Type: Laptop System: LENOVO product: 42983RU v: ThinkPad X220 Tablet 
  serial: <filter> 
  Mobo: LENOVO model: 42983RU serial: <filter> UEFI [Legacy]: LENOVO 
  v: 8DET73WW (1.43 ) date: 10/12/2016 
  Topology: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 797 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 797 2: 797 
  3: 797 4: 799 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile x86/MMX/SSE2 
  v: 3.3 Mesa 19.0.8
1 Like

It’d be great if you could capture this process, ideally through a video recording, for example.

I suppose I could take a pic of it with my camera and then paste it here, if you really think it would help or just curious what it looks like.
I beginning to think it has something to do with grub since before the patch I did not have grub menu.
What gets me is after the 30 second stall, the PC re-boots and acts normally. I would think if it is re-booting, then I should get the white lines again. I have not try anything yet, but I might run a update-grub to see if that changes anything.

OK @Akito, this about the best I can do. PC boot, white lines, PC boot, Grud menu, Logon page.

It seems more like it has something to do with your PC and less with GRUB2. On the other hand, I experienced some werid reboot behaviour regarding to Linux, as well. I’m not sure what the shown means.

As one of the more naive members of the forum, allow me the unwarranted impudence to suggest that this looks like a video card issue. When you get the grub menu, try just entering the three-finger salute and get it to reboot. If that isn’t enough, see what GPU is on the machine and check the support for that.

Also, if this is incorrect, don’t worry about correcting me. I can take it.

1 Like

Howard I seemed to remember there was a problem with the Mate version, have you looked here ? You could also try and install without the internet connection and then if it installs correctly look in drive management and install drivers through there.
I am not sure that is as Cliff suggests a video card problem, but that is also worth considering as a possibility.


Hi Howard!

I’m eventually going to post a topic about how in the last several years it’s become harder and harder to design “one-size fits all” kernels. The reason I’ve become interested it this is that my sacrificial laptop–the machine I use to experiment with–has wildly different boot times depending on which kernel version I use. For example, any kernel in the 4.4 series will boot up in 23 seconds; any kernel in the 4.15 series boots up in over 7 minutes. (For this reason I can’t use Mint 19 on this machine–it takes 20 minutes to boot and is unstable when it does.)

The reason I bring up this seemingly unrelated topic is that your boot-up weirdness started after installing a new kernel. And while major kernel regressions have become much rarer lately, small issues seem to be common–especially on older machines such as mine. (Though your machine is newer, I think?)

The problem here is almost certainly within the latest kernel. And while it is always possible to repair it, for all practical purposes it really isn’t. The bottom line here is that the easiest way to be rid of this graphic weirdness is to stop using this kernel and use the previous version instead. Here a couple of ways to do this:

1-Since a Grub screen now appears, hit the down arrow to “advanced settings” and select the previous kernel (4.15.0-55). The machine should be back to normal on the next boot. If it is, the next step is to make Grub run invisibly. (While there are doubtless ways to do this in the terminal there is an excellent graphical app called “Grub Customizer” which allows you adjust everything Grub, including whether or not it appears. Check out this article by Abhishek: to learn a little more and for instructions on installation.) Basically the offending kernel is still installed, but it’s not active.

2-If the problem persists, it seems likely then that Cliff is partly right–the problem is with the graphics card but it’s a software problem. As I understand it–and please anyone correct me if I’m wrong–what we like to think of as “proprietary drivers” are now elements of “dynamic modules” as Linux moves down the road towards being a truly modular OS. These are rebuilt each time you upgrade the kernel using the previous version as a template. So if the latest kernel trashed your graphics all future versions should inherit the same bug. So the only easy way to fix this is remove all traces of the new kernel. If you’re using your Timeshift simply restore your system to a point just prior to installing this kernel. Kernel will, of course, immediately come up again among your updates. Don’t install it. Wait for the next kernel and install it instead.

Hoping this might help,


I run an older ThinkPad T410 with Mint 19.2 (Cinnamon) and on boot, I see a few faint garbled lines near the top. It doesn’t hang there though, it’s just for a few seconds, then loads the DE.

What are the specs of your machine? I’m wondering if it’s hardware/graphics driver related…

1 Like

Actually @cliffsloane, I believe you are right. This laptop is a ThinkPad X220 which is an early laptop / tablet. Meaning the screen is a touch screen and the PC came with a light pen. When I first installed Windows and the first time with Linux too, I had the jumping cursor problem which had to be disabled. If you never seem it, the jumping cursor (mouse) is like a ghost taking over your mouse. The cursor jumps (moves) on the screen, open new windows, and moves around even if you are moving it in another direction.

Hi Dave,

Yes, I can get rid of the problem by removing the kernel update. Actually, I was able to back out the patch using Timeshift.
This PC is actually a PC / Tablet ThinkPad X220 and it’s about 8 or 9 years old. So, it has this touchscreen (a real pain in the a**) build into it. I had to disable it both on Windows and Linux.

When researching a question on the forum about an old Dell PC tablet, I ran across the same info. That Linux is not compatible with all PC and tablets. But hey, it seems to work on most of them. :smiley:

@ElectricDandySlider and @MikeREM thanks for your input. I was taking a look at Linux 19.1 Mate and was applying all of the updates. I’m able to remove the problem if I back out the kernel patch with Timeshift. Maybe I’m a bit bias, but I started with Cinnamon Mint and I like it better them Mate or Xfce. So, I going install Mint 19.1 Cinnamon instead of using Mint Mate.

1 Like

Just curious, why 19.1 instead of 19.2?

1 Like

Back in the (Windows 3.1) day, jumping cursors were an indication of a hardware conflict (does anyone remember COM ports?), two devices hungry for the same hardware interrupt.

1 Like

I tried with Mate, Howard and didn’t really get on with it. It is good to try these things out to see how they are. I understand you using 19.1 at the moment, although 19.2 is stable and solves many of the bugs from 19.1.
Personally on my spare I like to experiment as well

I too am curious-why 19.1 and not 19.2?


Yeah, the problem is that with every new twist in hardware the number of possible machines Linux OS’s must accommodate explodes. It would be a miracle if some older machines did not get left behind.

For example, my sacrificial laptop runs Mint Cinnamon 18.3 beautifully. However 19 barely boots.

The great thing with Linux is that someone has probably already created a distro which will keep it running years after Mint 18.3 hits its end date. :wink:


And @tosim91. I was thinking that 19.1 might be more stable then 19.2. But also did not like that Mint 19.2 had removed the ‘Level’ flag on the software patches. Before 19.2, System patches had level 1 thru 4. I would take a backup / Timeshitf and apply all level 1 & 2’s. Then I would look at the level 3 & 4’s and apply them one at a time after a backup since these levels had a far greater impact on the system. Now I feel blind applying the updates.
I just read about the improvemets that came with 19.2 and now having second thoughts. I’m d/l’ing 19.2 now as I type and may install it instead. Thanks to both of you for the little nudge. :grin:

1 Like

davemerritt-They have-While Mint-MATE has been my main distro on all my machines for many years, I like to distro hop (using MultiBoot USB), and also have been using many different versions of Puppy Linux for the past 2 years. Although still checking them, I’ve more or less settled on Bionic Pup32(270MB) for my older machines, and Bionic Pup64(354MB)(I prefer the 32bv). However, nothing will take me away from Mint-MATE!

1 Like

My apologies for not responding sooner.

I’m not sure I’ll have to go that bare bones. If, when 18.3 Cinnamon is put to bed, I still can’t make 19 Cinnamon to run I’ll switch to Mate.

But I would like to thank you for directing to Puppy. I’m most intrigued by the degree to which the bootable media can be customized. Could I, for example, make an installation medium that has a bundle of utility applications?

The reason I wonder is that for years I’ve used Redo Backup from a bootable CD. It works well enough, but since it’s running off optical media it’s very slow to boot and use. And though I’ve read many articles that claim you can use a thumb drive instead, I’ve never been able to make it actually work.

Something I’ve noticed about Mint installation media is that they are incredibly responsive, which makes them great to work with. If only it came with clonezilla, g-parted etc…

Thanks again t for the idea & Cheers