Linux Mint 19.3 audio issue

Hello everyone,

So, I am new to Linux in general.
I have an HP Pavilion x360 notebook and I wanted to make the step from Windows to Linux.
Because I still sometimes need Windows for work related stuff, I made a dual boot on my notebook with Windows 10 and Linux Mint 19.3 Cinnamon.

Everything works great, except for 1 thing: sound.
Audio works fine through headphones, just not through the speakers.

I followed the steps I found on the webpage https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/ and it did solve the issue finally.
I powered the notebook off and powered it back on the next day, and booted to Windows 10 for work.
I had audio through the speakers in Windows all day without problems.
After work was done, I rebooted to Linux Mint, and no audio is coming out of the speakers.
I connected headphones to test, and that is working fine.
I disconnected the headphones, but still no audio from the speakers.

So it has been working for just one evening.
I performed the steps from the website again, but this time it did not fix my audio issues.

Does anyone have some additional steps I could do to get it working again?
Thanks!

edit:

After reading the “Read before you post” here is some additional information :stuck_out_tongue:

Output of inxi -Fxz:

System:
  Host: HP-Pavilion-x360 Kernel: 5.3.0-42-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Convertible System: HP 
  product: HP Pavilion x360 Convertible 15-cr0xxx v: Type1ProductConfigId 
  serial: <filter> 
  Mobo: HP model: 8488 v: 73.22 serial: <filter> UEFI: Insyde v: F.24 
  date: 11/18/2019 
Battery:
  ID-1: BAT0 charge: 42.7 Wh condition: 42.7/42.7 Wh (100%) 
  model: 333-42-42-A LK03048XL status: Full 
  Device-1: hid-0018:04F3:2731.000A-battery model: ELAN2514:00 04F3:2731 
  charge: N/A status: N/A 
CPU:
  Topology: Dual Core model: Intel Core i3-8130U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17599 
  Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 802 4: 800 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 19.2.8 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.3.0-42-generic 
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3040 
  bus ID: 01:00.0 
  IF: wlo1 state: up mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 1.03 TiB used: 91.92 GiB (8.7%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  ID-2: /dev/sdb vendor: SanDisk model: SD9SN8W-128G-1006 size: 119.24 GiB 
Partition:
  ID-1: / size: 116.87 GiB used: 23.40 GiB (20.0%) fs: ext4 dev: /dev/sdb1 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 215 Uptime: 1h 07m Memory: 7.52 GiB used: 1.14 GiB (15.2%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32
1 Like

Thank you for reading the posting guidelines and improving your post. You are the first one doing that on their own. :partying_face:

Did you change the default output device after plugging off the headphones?

Hello Akito!

Where do I configure the default output device?
When I go to Preferences > Sound, and I unplug my headphones, I see only 1 device: Speakers Built-in Audio.

When I go to Terminal > Alsamixer, and I press F6 to select the sound card, I see that it is set to “- (Default)”
I to change it to “0 HDA Intel PCH” and press the Enter key.
But there is still no sound then.
The speaker volume in Alsamixer is 100 and in the bottom it shows “OO” and not “MM” so it is not muted.

Have you been in Control Center and under the sound button, to check if the right audio device has been selected.

Hello 4dandl4,

The strangest thing happened. I didn’t change anything, but when I powered on my notebook this morning, the audio was working again through the speakers.

What I am not happy with though, is that I don’t understand WHY is started working again.
I’m afraid to power my notebook off now!
It feels a little bit random, do you know what I mean?

Is there anything I can do to check what is different?
Are there any settings windows I should take screenshots of, to compare with when the audio decides to stop working again?

Screenshots are always super helpful. I would advise making some screenshots of the audio settings, when you click on the speaker icon on the bottom right, when being on the desktop. Then it will be clear what devices are available and selected.

You might want to open Control Center and click on Driver Manager and do a driver scan.

Hello rvh.
Well, that’s an old story… there’s no such thing as “perfect software/OSs”.
I can tell you the same thing: I use Dropbox on my Ububtu-Mint.
Now, here comes the question:
Why sometimes Linux boots up without the Dropbox running 'though it’s set up to auto-start?
It’s a rare thing but it happens!
You may as well be a victim of the same imperfections.

I had same problem on my gaming Laptop running Linux Mint 20. Click the sound icon in your taskbar or panel. Left click Audio Mixer. Click the tab that says output sounds and make sure the speaker Icon’s bar is on if it isn’t it’ll have a line going through it to say it is muted. If this occurs again just follow the same procedure as above. When Mint gets switched off with headphones on and then booted back up with speakers, it seems to get confused for some reason. Just go back into Audio Mixer or pulse audio volume control in menu/sound and video and make sure the speaker in output settings is not muted. Play a music track or video track before hand to test if you have sound or not.