Linux Mint 19.3 does not boot

Hi,
I realize this is a slightly different issue than your problem, but have no idea how to solve my issue. I’m new to the Linux world. I have an older PC that had Win 7 installed that I created a dual boot with Linux 18.3 then after several weeks of use I wiped out the Win 7 OS. Have been using Linux 18.3 ever since. Purchased a new PC with Win 10 installed with the intention of getting rid of Win 10 OS after a successful loading of Linux 19.3

I did everything to set up Linux 19.3 in the “How to Dual Boot Linux Mint and Win 10”. I created a thumb drive with what looked like the appropriate files. I changed the Boot BIOS of my new Win 10 PC to USB and shut it down. Then plugged in my thumb drive, turned on my PC and received the following:

“Failed to open \EFI\BOOT\mmx64.efi – Not Found
Failed to load image \EFI\BOOT\mmx64.efi: Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed
: Not Found”

The system then shut down. Checked my thumb drive and found the file: /media/chuck/UUI/EFI/BOOT/BOOTx64.EFI

I redid the install of Linux 19.3 on the thumb drive ad got the same results. Any help?

chuck

Hi Chuck (@DaMoose),
Found this on the internet.
https://forums.linuxmint.com/viewtopic.php?t=284124
Short answer as the post before your is;
Did you disable ‘secure boot’ in your BIOS?

Yes. Also, enabled ‘usb boot’ and reordered ‘usb flash drive/usb hard disk’ to the first place.

Failed to mention in my reply that after getting the note:…‘failed to load image \EFI\Boot\mmx64.efi: Not Found’ I checked my thumb drive and found: ‘… EFI/Boot/Bootx64.efi’ Any signifigance?

Hi Chuck, I did some reading on this subject and I still don’t understand it. (A little help from my friends would be welcome.)
But I did see a youtube of how one guysolved his same problem. Maybe it worth a shot and it is easy to do. Under EFI/Boot/ it showed 2 entries. BOOTx64.EFI and grub64.EFI – The guy on youtube rename grub64.EFI to mmx64.efi and it fixed his problem. Here is the link. It worth a try.
www.youtube.com/watch?v=ranBNkMV8k4
Of course, this does not explain why your is looking for mmx64. My Linux 19.3 USB boots fine and it does not have mmx64 on it.

Hi Howard, I changed my grub64.efi to mmx64.efi and It loaded all except when I got to the ‘installation type’ the window shows ‘device for boot loader installation’ ‘/dev/sda’ and I clicked ‘install now’ a warning window appeared saying ‘no root file system is defined. Please correct this from the partitioning menu’. I have Gparted on a USB stick. Do you think it wise to plug it in and try loading Gparte? I’m so close to getting Linux 19.3 up and running I can taste it. Can’t find Windows partition app or I’d use it. Suggestions?
chuck

Hi Chuck, yes, it sounds like you are getting pretty close to installing Linux.
When I install Linux Mint 19 or Linux 20 there was a screen that came up on with the install options. After many tries & errors, I found what works best for me was the last option called
“Something Else”. By selecting this option, the next screen is a Gparted like screen. This is how my desktop /dev/sda is laid out.


CAUTION!!
Gparted is powerful and not very forgiving for mistakes. If there is anything on the install disk that you want to keep, be sure you have a backup that you can restore.
Your disk will be different from mine of course.
CAUTION!
If Win 10 owns the whole disk, you will need to boot Win 10 first and shrink the C: or D: disk to give room for Linux.


In a free area of the disk, you need to define a partition as ‘/’ like /dev/sda6 shown above. Define a swap partition like /dev/sda7 and I like to define a separate home partition (/dev/sda8)
In my system 25 GB was plenty for root (’/’), define swap maybe for you 4 GB, and my home partition is 30 GB, but make this as big as you want it to be.
All these areas need to be formatted. Root & home to file system ext4. On this disk I also have Win 10 installed at /dev/sda4


To be completely honest, I re-installed Linux Mint several times before I got it the way I wanted it and I also wipe out Win 10 a couple times and had to restore it. But that all part of my learning process.

Hi Howard, I went into Win 10, shrunk ‘C’, made a simple partition and formatted it as NTSF then named it ‘sda1’. Looks like I’ll need to call it ‘/dev/sda1’ then create a swap partition after shrinking ‘/dev/sda1’. Thanks for the help! Will keep in touch.

Hi Chuck,
Shrinking the Win partition was correct. The formatting has to be done under Linux for Linux partitions. Formatting under Win was not needed, but no harm. Second point, /dev/sda1 thru /dev/sda? are logical names. The Win disk label “/dev/sda1” is not the same as /dev/sda1 under gparted.


Under gparted /dev/sda1 will always be the first partition, /dev/sda2 always the second partition and so forth. So under Linux, if you format /dev/sda1 you might be writing over your Win partition.
Be Careful.

That’s why the options for a partition can’t be seen after I made partitions in Win 10. Dang! I can’t seem to get past the 4th install page 'Installation type". Have used gparted previously, but have no way to get Linux installed to use gparted. Soooooo frustrating.

Howard, have extended my Win 10 C: drive back to its original 930.77 GB status. I’m half afraid to plug in my gparted thumb drive while running Win 10 because I don’t think it will work without Linux. As I said in previous response, I cannot get past the ‘installation type’ screen while trying to load Linux. Seem to be caught in a catch 22 situation.

Has anyone else
run into this situation previously?

Sorry I have not been much help, but shrinking your C drive using Windows was the first correct step. If you want to install Linux, it has to have a place to install it at. I don’t believe you want Linux to over write your Windows partition.
Also Chuck, to have someone help you, you need to give more detail info. Saying “cannot get past installation type” does not tell us much. What option did you select, what happen next, what screen came up next, and so on.
If you had selected “something else” as I had mention, you would have gotten a gparted like screen.
If you selected “Install Linux Mint alongside them” what was the next screen?
Good Luck, but I give up.

1 Like

Howard, here’s a complete pix story of the process I used to try loading Linux 19.3 as a dual boot system. It looks nothing like the process described in https://itsfoss.com/guide-install-linux-mint-16-dual-boot-windows/ starting here: image Never got that image or images from Step 5 and beyond.

Here’s a series of pix of the process taken to load Linux 19.3 on my new HP Pavilion x360 Convertible PC loaded with Win 10 Home 64. USB stick has dual boot Linux 19.3 loaded per instructions on https://itsfoss.com/guide-install-linux-mint-16-dual-boot-windows/. Had to change the file ‘EFI/Boot/grubx.64.efi’ to ‘EFI/Boot/mmx64.efi’ to get the USB stick to start loading Linux on the PC.

Inserted USB stick w/Linux 19.3 loaded the turned on PC pressing ‘esc’ key.
Pic 1:

Selected F9
Pic 2:
Selected USB Hard Drive.
Pic 3:
Selected Start Linux Mint 19.3 Cinnamon 64 bit.
Pic 4:
Selected Install Linux Mint
Pic 5:
Selected English and continue
Pic 6:
Selected English and continue
Pic 7:
Selected Install 3rd party and continue
Pic 8:
I selected drop down arrow and only ‘/dev/sda’ was shown. Selected ‘install now’ got the next screen. Also, at this point is where I had problems. Selecting ‘+’, ‘-’ or ‘Change’ got Pic 10.
Pic 9:
Selected ‘OK’ and got this message…
Pic 10:
…which dumped me out of the install.

Tried selecting ‘Back’ which took me back to Pic 7.

Prior to all this, I started Win 10 and shrunk the ‘C’ partition and added a simple partition that was formatted in NTFS and named ‘/dev/sda1’ to give Linux someplace to install. That hasn’t worked either. No idea where to go from here.

Hello Chuck,
I will say, you did a wonderful job documenting the problem you are having with your PC. I truly want to help, but I have not seen this problem before and it is pass my level of experience.


I have 2 other cards up my sleeve and maybe one of them will provide a solution. If you get this problem corrected, I would appreciate it if you would post the answer so that I and others might learn from it.
Card One – I found 2 other people who had the same problem and got the problem resolved. One answer was a bad HDD. Anyway the posts are a little long and I will not try to re-type all the things that was tried. Here are the links to the same problem as with your PC. The first link is the bad HDD.


The next link has to do with setting in the BIOS.

You can try some of the suggestions and post what you try and results.
Card Two — I am going to call out to a few of my friends here on the forum that are way more knowledgeable then me on Linux. Will you please provide some help with Chuck’s PC problem? @Akito, @01101111, @abhishek, @Mina, @daniel.m.tripp, @4dandl4, and @kc1di. Thank you.

When installing Linux on the same drive as Windows is on, and you shrink the partition, then this is left unallocated, to create the partitions that are needed for Linux, during the Linux install.
Is this a laptop or a desktop?

Hello 4dandl4, My PC is a laptop. HP Pavilion x360 Convertible w/16GB SDRAM… brand new out of the box. Win 10 Home 64. Win 10 works perfect so am assuming the 1TB SATA HDD is working fine. Prior to all this, I started Win 10 and shrunk the ‘C’ partition and added a simple partition that was formatted in NTFS and named ‘/dev/sda1’ to give Linux someplace to install. That hasn’t worked either.

Howard… thanks for asking 4dandl4 and others for help. Sometimes one just can’t solve a problem because one runs out of ideas. It’s understandable and I appreciate your help and suggestions. Will look into the second link you sent. The first link isn’t my problem because Win 10 works on my HDD.

1 Like

@DaMoose…I will see if I can walk you through the tutorial. But first
things first.


This a screenshot of my HDD in my Dell laptop, it has GUID(GPT)
partition table.
The first step is to prepare OS (:C) for your Mint install.

Hi 4dandl4, you’ll have to excuse this pic because I don’t have my Thunderbird app loaded to my new PC as yet so this is a smartphone screenshot of my Disk mgmt. Am conversing with you from my Linux 18.3 PC so can’t take a screenshot.

@DaMoose…Why do you need thunderbird to post to Foss? Just use your W10
snipping tool and upload the .png file with your post when logged into Foss.
What is the UUI (D:) partition and what and how much data is on it?
Boot your laptop and type this in your run box " msinfo32 " I need to know the
bios mode, it is probably UEFI but please confirm
.


Partition Table
Do you know how to find the partition table info?
Before we start, have you made a system image of Windows?

1 Like

I have been very ill and haven’t signed on in a long time. Sorry!
The BIOS mode is UEFI. Yes, I know how to find the partition table and disk properties. Have not made a system image of Win 10.
I need to sign off for now and will probably get back on-line on Monday or Tuesday of next week.