Make sure you have all the printer drivers installed

Having seen that Tara installed the printer and done a test to make sure it had done so I thought nothing else of it. Then my wife tried to scan a document to her lap top and couldn’t. I thought it was something she was doing wrong either within Libre Office or with the print options. So I looked at these and she wasn’t.
I then thought I’d just re-install the printer HP ENVY 5530 so added the printer and also added the duplex which I had done in previous versions of Mint and then tried again. The scanner has worked perfectly since doing.

To be honest I wouldn’t have thought about doing any further checking if my wife had not had this problem. This is why I am mentioning this, because many of us are fairly new to Linux and wont think to check if our printer shows up as working.

Usually mint needs to restart for the scanner to work I had the same issue with other models of printers
But yes you do need to make sure you get all the bits to make it function correctly even after the auto installation not always clear
It’s usually safer to blame the dog than my wife as the dog does not answer back…


:rofl::rofl: nice reply

I use a Canon 88oof scanner and after I installed Linux Mint 19 Mate (first time user of Mint as I usually use Ubuntu but prefer the Unity desktop so I changed). I turned the computer off after the installation and plugged in the scanner and it worked no problem after I booted it again. I have used this scanner for several years and it has never let me down.

Well, on my desktop I use a Canon MG5330.
I only had to install XSane to be able to use the scanner.
If one needs to print to A4 pages only, that works with CUPS/Gutenprint quite well.
It’s just my decesion that I purchased Turboprint for Linux, so I can also print to discs correctly, or
clean the print heads for example - those functions are defect, or missing in Gutenprint for this device.
BTW, anyone having a Canon inkjet should seriously consider Turboprint, I think. :slight_smile:

We have a Cannon MX470 scanner/copier/printer on our wifi network. It has been hit and miss with getting it to work with various Linux distros. Mint is one distro, however, that it has always worked with. For scanning, I just scan using my Windows PC as it’s in the same room as the scanner anyways and has the full drivers & software suite installed.

Printer software & drivers is one area where Linux needs to vastly improve. Especially with LAN printer devices. It’s always been somewhat of a struggle in my experience, to get them working properly with Linux.

i had trouble with my epson mfc a while back and found a couple of interesting ways to try and troubleshoot printing in distros that don’t work as well as others. http://localhost:631/ in a browser will take you to a CUPS interface that may help. if you can get your ip address from the printer, it may also have an online portal you can use to look at configuration options.

the standard linux printer utility usually has a way to change the uri if the protocol isn’t working. i found antiX used different protocols (lpd and dns) depending on the cpu architecture so there may be some use to trying the different protocols if the one a distro picks doesn’t work as well as you would want.