Mount external HDD

I have a 1 TB Toshiba external hdd mounted at /run/timeshift/backup. I found out the hard way that timeshift isn’t for backing up data.
Can I set up a different mount point for the Toshiba hdd so I can back up my Documents? I’m not wanting to back up Pictures, I have them in multiple locations.
I’m thinking of using LuckyBackup if I can figure out how to set it up. I’ve been using Linux for quite a while, I’m still totally lost when it comes to specifying paths when configuring things. Thanks for any help.

As far as I have read, you can configure Timeshift to backup anything you want to.

Otherwise, have a look at the backup section in our FAQ.

Hi Jim good to see you are back :slightly_smiling_face:
I too am still not 100% sure of what I doing with backup. :confused:
Using same external as you I use the my standard distro OS’s backup app which gives me the choice of excluding pictures.
I copy a years worth of pictures separately to other computers and ext drive - hey which reminds me…
We all need reminding from time to time to use it’sFOSS resources as we forget where to look first - thanks Akito :shushing_face:
Edit: Wow - just had notice that I have been with it’sFOSS for one year - Happy Anniversary! Surprised I have not been banned yet :thinking::astonished::joy:

Hi @JHarp, I use a 3 prone attack on the backup of my desktop. I too use LM. As an example let say on partition 1 is IEF, part 2 is Mint, part 3 swap, part 4 home, and large part 5 data.
I use Clonezilla to backup part 1 & 2. System or OS backup.
I use Mint’s backup tool under Admin to backup part 4 (home).
I use FreeFileSync to backup the large data area b/c this program can just backup the changes and has a nice GUI.
Just to be safe, I have more then one backup of each area.

You can always mount your devices where ever you want. Check this out:

However, you should do what @Akito proposed: Reading the backup section in the FAQ.

Thanks to all who have replied. I had to do some errands and chores this AM, so I’ll take some time to do the suggested reading.

What happened was I did a TimeShift snapshot of 19.3, then tried to upgrade to Mint 20, that didn’t work, I don’t recall the error given for the failure. I did a fresh install of mint 20. When I tried to recover my Documents which I had included in the backup, they were not restored to the new install.
I can see all the documeents on the ext hdd, but haven’t found a way to get them into the ssd of the laptop. I’ll do some reading and try some fixes before responding further. I’m slow but I’ll let you know if I make any progress.


Hmmm. I just open Thunar or Nemo or whatever I’m using at the time, highlight the files I want to back up and then drag them to the external drive folder where I keep my backed up files. It might be an external drive or it could be MEGA. Good old copy/paste and intentional backing up usually works, right?

1 Like

Progress!! I got most of my documents restored by compressing the documents in the timeshift snapshot, and extracting them to /home. There are still a few folders containing icons and such which I’ll try to do later.
Sorry I haven’t got to much of the reading yet, but that is on the list. Must do some work now, but will get back to studying asap. Thanks much to each of you for your advice.

1 Like

Thanks Akito, I’ll see if I can attach the template here. Sorry for the delay responding, it’s been a busy day.


-> Output of inxi -Fxz here!

jim@jim-HP-Laptop-15-db0xxx:~$ inxi -Fxz
  Kernel: 5.4.0-58-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
  Type: Laptop System: HP product: HP Laptop 15-db0xxx 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: HP model: 84AE v: 86.20 serial: <filter> UEFI: Insyde v: F.11 
  date: 08/20/2018 
  ID-1: BAT1 charge: 37.5 Wh condition: 37.5/41.0 Wh (91%) 
  model: Hewlett-Packard PABAS0241231 status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510 
  charge: 55% (should be ignored) status: Discharging 
  Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 19964 
  Speed: 1360 MHz min/max: 1600/2500 MHz Core speeds (MHz): 1: 1408 2: 1474 
  3: 1369 4: 1386 
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.0-58-generic LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.8 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.1 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: N/A bus ID: 04:00.5 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.6 
  Sound Server: ALSA v: k5.4.0-58-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 02:00.0 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter 
  vendor: Hewlett-Packard driver: rtw_pci v: N/A port: 2000 bus ID: 03:00.0 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 931.51 GiB used: 109.50 GiB (11.8%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-60Z10T0 
  size: 931.51 GiB 
  ID-1: / size: 915.40 GiB used: 109.49 GiB (12.0%) fs: ext4 dev: /dev/sda2 
  System Temperatures: cpu: 44.6 C mobo: N/A gpu: amdgpu temp: 20 C 
  Fan Speeds (RPM): N/A 
  Processes: 220 Uptime: 4h 06m Memory: 7.50 GiB used: 1.89 GiB (25.2%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38 

-> Output of dmesg_*.log here! dmesg --time-format iso > dmesg_$(date +"%Y%m%d%H%M%S").log
-> Output of dmesg-err_*.log here! dmesg --time-format iso -l err,crit,alert,emerg > dmesg-err_$(date +"%Y%m%d%H%M%S").log

That’s a JOB, not knowing what I’m doing. If I copy the arrow after the line, I get a new line error. I don’t know if the “dmesg” lines should give an output. Thanks to all who have replied, I’ll follow up on your suggestions as I get to them. My documents are back where they belong, I want to find an easy to restore way to keep them backed up.