Mouse right-click inoperative on Kubuntu 22.10

Have rebooted to Windows 10 to double-check, and sure enough, right-click for wireless mouse does not work on Kubuntu 22.10 (even after updates and reboots).

First time i encounter such an issue with a Linux desktop.

@danielson ,
Have you looked at the mouse configuration menu?
It may be on some strange setting? Like 2 button mouse for example.

Can’t seem to find more than this:

1 Like

Got it!

Switching to X11 Plasma Wayland did the trick, phew!

1 Like

Nice way to force you to use Wayland

2 Likes

Is Wayland that “bad”?

That’s what many people say…but “forcing” you to switch to it is really bad.

1 Like

Only tried it once in Void/KDE. It had a few hitches, so I stayed with Xorg.
I suspect it will be improving rapidly because Wayland is the future and is under rapid devlopment.

On the other hand it puzzles me why Xorg would suddenly fail to operate a mouse? Xorg has been stable for years, almost decades.

1 Like

Maybe, it would be a good question to ask on Ubuntu forum?
There are some smart guys there. I never liked Ubuntu or any of the buntus including their DE’s, KDE, Gnome and the others. I think it is a great system but only if other devs put their hands on it and make it better, like Mint. But, only my opinion…

3 Likes

Wayland KICKS ARSE…

I only don’t use it 'cause I can’t live without Synergy KVM (pro)… Same deal with Barrier… (neither software KVM work with Wayland compositor)

Saw something where you can make the Synergy client work under Wayland, but it looks like too much hardwork…

Seeing that this suggestion to post to Kubuntu forum is subordinate to initial post…
First, i don’t like the disposition, nor feel a certain “warmth” at their forum.
Second, guys here a savvy and cordial.

Must admit that Kubuntu 22.10 is lightweight on RAM (1.3Gs) and good on CPU usage (except when playing videos in the browser, but that’s everywhere right)! Thinking of using Freetube app more for this last reason.

1 Like

@danielson
Is this the bug?

They dont offer a solution, except to ‘click faster’

Neville

Fast or slow, right-click does nothing.

Left does, but options are quite limited.

My post was addressed to Neville because he was “puzzled” by this, my only point was if we have a specific problem with our Chevy then we won’t take it to a Honda dealer to fix it.
I didn’t feel comfortable many years ago at Ubuntu forum either, too many regulations, editing users’ posts, warnings to make questions short, etc.
Anyway, I found this:

It’s old but the problem looks similar.
I suppose you already tried to use a different mouse and it didn’t work either.

OK, that bug is irrelevent to your issue.
How is Wayland going? Any issues there?

Just fine on Wayland. :wink:

2 Likes

@danielson ,
Hi ,
Lets have another try. I had a look in my KDE/Void system. It is kde-5.26.0_1. My right button works.

In the file ~/.config/plasma-org.kde.plasma.desktop-appletsrc

the first three lines should look like this

[ActionPlugins][0]
RightButton;NoModifier=org.kde.contextmenu
wheel:Vertical;NoModifier=org.kde.switchdesktop

If the word contextmenu is something else, change it to contextmenu , then reboot and see what happens.

There is also this


To get it, you right click on background, choose Configure Desktop and Wallpaper, choose Mouse actions.

If right click not working that may be difficult. Does anyone know how to get the background menu in KDE without a right click?

Regards
Neville

Logging out after initial installation gives two options:
X11 and Plasma Wayland.

Logging into Plasma Wayland allows right-click with all the usual options.
And the mouse settings are as per initial screenshot i posted here.

It is clear that X11 does not have right-click option for the desktop.
Oddly enough, right-click toolbar to access “customize” and modify Firefox works fine.


Btw, not sure where to look for ~/.config/plasma-org.kde.plasma.desktop-appletsrc

I posted a link above about both questions. Post is old, but still KDE. It also has links that talk about it further more.

@shamu -Got lost in that thread.

Alt-D Alt-S does nothing for me.
and the link

didn’t seem have any pertinent info.

~/.config/plasma-org.kde.plasma.desktop-appletsrc
would be interesting, but don’t know where to find the folder/file.
But i guess you didn’t read my previous about that…

Besides… if Wayland does the trick, why should i bother going back to X11 which seems to be a retro move?