MP3 wont connect

I had posted that my Kindle Fire will not connect to Kubuntu 18.04 to upload files. Ive just tried to move music to my mp3 player and now it wont connect either. It will charge but will not come up in the folders menu. Any ideas as to what would cause this to happen? Oh, I tied a few different mp3’s that I have and none of them are coming up. Is there something like a software switch that would allow powering but not data transfer as all the mp3’s and the kindle will charge.

1 Like

When I had those problems (in Windows), the problem was that the cable was a cheap one for charging only. How many contacts are there? In a data transfer cable, all four should be connected, while only two are hot in the cheap ones.

1 Like

In Android based devices, you have to change the settings in device to use it for MTP (media transfer). By default, these devices stay in the charging mode.

I think it’s a security feature so that no one can access your devices’ data just by connecting it to a computer.

2 Likes

Try to use different cables and USB slots.

1 Like

This is cable works fine on the other computers.
I have another cable and it does not work.
Just before Christmas I put music on this specific
mp3 from here without problem. There are not many
things you can set on this device and I see no MTP
setting or anything similar.

1 Like

I have tried all ten usb ports - same thing.

1 Like

any luck with gMTP tool?

1 Like

No. When I plugged in the devices - none of them showed up. The “refresh” button was grayed out. It didnt see anything.

You know… I want to think this is some update related since it was working before Christmas. But… just a thought strung out there.

Have you called Amazon? The Kindle help desk may have an answer for you.

1 Like

Since it is happening with other items - they will not help.
Also - they only offer minor support for Windows, a little of Mac and NOTHING on linux.

1 Like

This might be a long shot.
Could it be the kernel? When I (foolishly) upgraded my kernel, it no longer read MTP devices.

1 Like

How can you add a sort by date to this?
$ dpkg --list | grep linux-image

so you can see when each one was installed?

1 Like

I have
linux-image-4.15.0-(20 thru 45)-generic installed.
If I can get these sorted by date then you might be onto something there.

Did you use the same cable that you used with Kindle as well? If yes, would it be possible to change the cable? Borrow it from a friend perhaps. Sometime the cable itself could be faulty.

If the cable is okay, changing the kernel could be worth a try.

You have two option, boot into an older kernel version (there should be at least one older kernel on your system)

or you can install a newer kernel. You can use Ukuu on Ubuntu and Linux Mint for this purpose. You should read this detailed article on using this tool: https://itsfoss.com/upgrade-linux-kernel-ubuntu/

1 Like

All three have different cables… well, the kindle and the mp3 use the same type of cable but I do not use the same cable for them.

Did you try with another kernel?

1 Like

No. I worked on my car until late last night. Just got up this morning… just 4 hours late. Ill look into that today.

1 Like

Coming back to this now …

Newer image installed and still the mp3(s) does not come up.
I did purchase another cable - just in case all of mine went bad at once - like before - powers fine but will not show up to move files.

I know this might sound completely off the wall, could you please tell me how many Kernel images you have installed, just put in Terminal sudo apt autoremove, the reason why I ask, is sometimes Linux saves too many Kernel Images and it can have an effect on software and hardware running properly.

0 upgraded

0 newly installed

0 to remove.