Need help finding a decent Linux compatible USB Wifi device


#1

I’m having trouble finding a USB wifi dongle/device that will work with Linux. I have tried a few in the past, and just tried another today. A TP-Link TL-WN821N, which states on the box, that it is Linux compatible.

Running KDE Neon 5.14. I can see the wifi router, yet when I try to connect, it just sits there saying “establishing interface” and then disconnects again. I’ve tried searching for a solution with this device, but didn’t find much. If it’s working, I don’t understand why it can’t connect.

System specs:
G3258, Asus H81 motherboard, 4GB ram, 128GB SSD.

I just bought this device today, so I can return it tomorrow. But does anyone know of USB wifi dongles that should work (for sure)? And that aren’t too expensive (preferably $30 CAD or less)? I would appreciate suggestions. :slight_smile:

On Reddit, I found a discussion about this and quite a few people were claiming the Panda PAU05/06 were good and work well with Linux. They are a bit more pricey ($41 on Amazon.ca), but if they work, I don’t mind paying a little more. Can anyone confirm these are good?

Thanks. :slight_smile:


#2

Good luck… trouble is vendors often change the chipset without changing the name of the product… I’ve got a few USB dongles, some work - some don’t… all the a/b/g/n dongles I’ve got work pretty much plug and play (even on ARM based SBC’s) but I’ve had trouble getting some 802.11a/c dongles working in Linux (got them to to work once by compiling the driver from source - but to me that’s not a practical solution, as I rebuild Linux desktop machines nearly as often as I cut my hair - e.g. every 4-6 weeks)…
Be interested to hear your progress/success… sorry can’t help much mate :slight_smile:


#3

I think that (This is a link to their network devices page) Think Penguin has tested their devices on Linux and has fair prices. If you can’t get the one you have working, I recommend Think Penguin. I bought 2 PCI WIFI adapters from them for my two desktops and they worked perfectly with at least 5 different Linux Distros AND Windows 7,8, and 10. Good luck. Oh yeah a tip that might prevent you more headaches. There are different flavors of WIFI: A, G, and N. N is the newest and fastest, G is next in line for newest and speed. You can read about it here Your Access Point AKA Your router needs to support the flavor of wifi your adapter is designed to talk to, so start there, call your ISP and ask them what flavor WIFI their router supports so you know what to buy. I hope this helps.


#4

Thanks for the suggestion. I’ll check out the Think Penguin products and see what they have. :slight_smile:

This is my router: http://ca.dlink.com/products/connect/ac1200-dual-band-router/
It’s a few years old, but still works well.

I thought N was an older wifi protocol and AC was the latest/fastest? I could be wrong?


#5

https://www.extremetech.com/computing/160837-what-is-802-11ac-and-how-much-faster-than-802-11n-is-it

That certainly seems to be what the issue is. I looked at the data sheet for your router/access point and it doesn’t seem to be backward compatible with N. So you may be stuck paying for an AC adapter and I don’t know if Think Penguin sells AC Adapters.


#6

https://www.newegg.com/Product/Product.aspx?Item=0XM-005U-00042&Description=802.11AC%20Usb%20Adapter&cm_re=802.11AC_Usb_Adapter--0XM-005U-00042--Product

It should be the 1200 flavor of AC which matches your router.

Also you may want to look here paying attention to AC and 1200:
https://www.microcenter.com/search/search_results.aspx?Ntk=all&sortby=match&N=4294966871+4294819955+4294819302&myStore=true


#7

Hi Mike,

Does your solution, require the wifi dongle to be it own wireless router, such as a wifi USB dongle I bought from O2 (UK telecoms company), which proved to be expensive with its monthly fee for unlimited use.

Or a USB device, that connects to your home router, the dual aerial model has excellent signal strength. Use the single aerial when out about with a laptop.

Both devices work, but require you to install the Realtek drivers and DKMS kernel support

Install Realtek rtl8812AU/8812AU USB wifi driver

  • su
  • apt install dkms
  • apt install git
  • git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux
  • cd rtl8812AU_8821AU_linux
  • cp -R . /usr/src/rtl8812AU_8821AU_linux-1.0
  • dkms add -m rtl8812AU_8821AU_linux -v 1.0
  • dkms build -m rtl8812AU_8821AU_linux -v 1.0
  • dkms install -m rtl8812AU_8821AU_linux -v 1.0

Test

  • dkms status
  • modinfo rtl8812au | egrep ‘filen|vers|0811’
  • su
  • modprobe -rfv rtl8812au
  • su
  • modprobe -v rtl8812au
  • iwconfig
  • iwlist chan
  • su
  • iwlist scan | egrep -i ‘cell|chan|essid|wpa|cipher|qual’

Once in use, (especially if laptop) go to wifi dash and switch between onboard and Realtek device.

:sunglasses:

Edit

As you are using a Ubuntu based distro use sudo su this gives you root privilege.

Most important, REBOOT and the driver and wifi magically autoboot itself


#8

Thanks for the replies. Appreciate it.

According to the spec sheet on Dlink’s website, my router dose support the N standard. It indicates it supports A/B/G/N. ftp://ftp.dlink.ca/PRODUCTS/DIR-822/DIR-822_DATASHEET_1.00_EN.PDF

I also have another PC in the house running Linux with an Intel B/G/N Wifi chip and it connects to the wifi without a hitch. https://www.gigabyte.com/Motherboard/GA-H87N-WIFI-rev-1x#sp

So other N USB wifi dongles should also work. I’ve also had an old Dell 530 desktop with an ancient PCI wifi card that was able to connect to my router and worked, so I know it works with older wifi standards. :wink:

The trick now is finding a USB wifi adapter that will work with modern Linux… Think Penguin does have a few options that I might try.


#9

All you have to do is find a dongle that is confirmed to work on a Raspberry Pi. If it works on a Raspberry Pi, it sure as hell will work on any Linux machine.


#10

Well, that’s why I bought the one I mentioned in my original post. It specifically says it’s Linux compatible. And while it “works” (that is: the OS sees it and can manipulate the settings), yet it will not connect to the router… :wink:

I do have a Pi with a wifi dongle that works fine. Perhaps I’ll try that one and if it works, just order another of those. Thanks for the - indirect - suggestion! :smiley:


#11

So yeah, the USB wifi dongle from my Raspberry Pi works, just like that! :slight_smile: It’s a little slow due to weak signal I think, but if I can get maybe one that’s a bit stronger but meant for a Pi, it should work just fine.

Thanks again, @Akito


#12

Sorry, my mistake. I thought I read it wasn’t backward compatible. Sorry.


#13

One thing I have to do with RPi (3B) - ensure I’ve got the correct country settings - they seem to default to UK - which can cause problems with wifi in Australia… with default settings in Raspbian - won’t connect to my WiFi - can’t remember exactly where you set the wifi country settings - it’s somewhere in the Raspbian GUI (not much help I guess with headless RPi - but I run mine on ethernet)…


#14
sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

#15

I would walk into a store that sells one, try it on my laptop and see if it is working. It will be costlier than buying online, but that is the best plan of action in such cases.


#16

No worries. :wink:

I returned the TP-Link adapter to the store and ordered a new adapter from Amazon.

This one:
https://www.amazon.ca/gp/product/B01KWQAQ00/ref=ppx_yo_dt_b_asin_title_o00__o00_s00?ie=UTF8&psc=1

Fingers crossed… :slight_smile:


#17

In the many years of using LINUX I have never had ANY issue with a wifi USB card working, I never understand when people have issues. You just have to find drivers that work with the wifi card.


#18

Also, honestly it’s not a linux thing, wifi standards are just that “standards” regardless of the OS. Just need the correct and working drivers. Now whether or not it is capable of injection or not depends on the wifi cards chipset…


#19

Panda PAU05 works for me, on multiple machines


#20

If that part were easy, nobody ever would have a problem with this type of device. :+1:t2: