New Configuration For PC

This is Gentoo installed with all needed use flags. Gentoo is now the boot drive.

My old standby W8.1.

Still have WXP but Manjaro had to be replaced with Debian. This had to be done because
of booting conflicts between Gentoo and Manjaro. Manjaro may be fine for dual boot
with Windows, but it sure has issues with other Linux Distros. Transferred all pertinent files
to another partitions and just copied and pasted to Debian.
@nevj should like this!!!

Swap should be the first partition of the disk for faster access on the hardware.

It’d be also better, if an extended partition would be used for all partitions, instead of making 3 primary ones first.

Though, it would be even much more better, if the disk were GPT, i.e. wouldn’t need extended partitions, in the first place.

Probably could do without a swap partition and gpt is no use on this pc. Besides, WXP
will not run on gpt.

1 Like

What do you mean by ’ booting conflicts’ ?
I dont see how one linux could interfere with another linux at boot time.

1 Like

I really do not why the compatibility issue, but I think Manjaro may depend more on UUID’s
for ID’s, unlike Gentoo, which still uses /dev/??? for ID’s. Gentoo and Debian work well together in
a dual boot. After about 3 days I finally gave up and trashed Manjaro.

That makes sense.
I changed my Debian to uuid’s , but it was not necessary, it worked ok with device names.
Another possibility, maybe Manjaro was looking for an efi boot.

I changed Manjaro’s UUID’s to /dev/, and that put Manjaro in rescue mode, I even tried using Manjaro grub to boot the PC and Gentoo, like Google said, but that did not work. I have had this issue with Arch based and Debian based distros, but was not expecting this, since the two share the same command for installing and updating grub. I really learned quite a bit about Gentoo, and using Gentoo use flags, with this install of Gentoo.

The trouble is, you have more than one disk, and it does not always discover them in order sda,sdb,sdc.
Will gentoo not use uuid’s? You should be using uuid’s if you can.

The rescue mode for manjaro was likely because it could not find one of the partitions it needed… maybe couldnt find /

when I get to gentoo, it is going to need to have uuid’s , so i have to solve this uuid question for gentoo.

Gentoo blkid command
Gentoo can indeed run using UUID’s !!!

Geneto fstab with UUID's
Gentoo running with UUID’s!!! Explain why this is important?

Because sometimes the order in wbich disks are found during booting changes. Lets call the disks 0,1,2. One day you might get 0=sda, 1=sdb, 2=sdc… The next day you might get 0=sdb, 1=sdc, 2=sda.
But the uuids would always be the same and would identify to 0,1,2

So when an os has its / on disk 0, if you use sda for / , it would go looking on disk 0 on day 1, but would look on disk 2 on day 2, which would be wrong. So booting would fail intermittantly.

I actually had this intermittant failure happening to me, until I changed all linuxes to uuid’s. That fixed it.

I dont understand why the boot process discovers disks in random order, but it does.

I think you should change both gentoo and debian to uuid’s, just to be safe… Just carefully edit the /etc/fstab files. Thats all you need to do.
It is only the automounts that are a problem. Anything you do later by hand, you can control.


They are both using UUID’s.

I think modern installers set it up that way anyway.

For me it is easier to setup Gentoo, if just using one drive, to use the /dev/ as the ID. After Gentoo is running and all other drives are running, one should then, maybe use the UUID’s.
With Gentoo it works either way, but with other Linux Distros, I am not so sure, although it is working well with Debian. I now have 7 entries in my grub menu.

1 Like

Hi @4dandl4,
I just tried out Manjaro during the past couple weeks. Loaded it to a laptop (no dual boot) and did not have any real problems. The live dive did not see my wifi cad, so I just connected the ethernet cable and finished the install. I must said, I was somewhat impress with the responsiveness of Manjaro. So much so, I decided to load it on my desktop as a second OS. Install went fine and I update grub form Mint.
Booted Manjaro and got “Kernel panic - not sync-”. Re-install Manjaro booted again and got the same panic message.
Did some searches and did not quite understand the possible resolution, so that ends my testing of Manjaro on dual-boot.

Their is a fix but I haven’t tried it, yet.

It may be the same thing I was discussing with @4dandl4
Have a look at /etc/fstab in Manjaro and see if it uses UUID’s or device names. If it is device names, convert it to UUID’s
The device name issue is only relevant in a machine with more than one disk. Doe your decktop have more than one disk?

My curiosity lies in what makes the Manjaro bootloader so different, and I do not believe it is all in the UUID’s. From what I read on Google, Manjaro does not like sharing it’s space, and this has been going on for sometime now. The fix I read about involves using a custom grub config file placed in /etc/default/grub, but using Debian has so for solved my problem.

What was the solution? Was it editing (making changes to) fstab on Manjaro?


This can explain better than I.

1 Like

Having read @4dandl4 's referdnce, it is not clear to me whether one needs to edit grub config files to fix a uuid issue, or whether one can just edit /etc/fstab.
It depends on how Manjaro boots. For most distros you dont need to fiddle with grub to fix it.
First thing I would do is look at /etc/ fstab, and see if the root filesystem is setup with a uuid.