No wifi adapter found


#1

I have a Toshiba Intel® Core™ i3-2350M CPU @ 2.30GHz × 4 laptop. Last month “Airplane mode” turned on even though I didn’t turn it on (perhaps I hit a button or something???)

So wifi is disabled and I have to use an ethernet cable instead. In settings under wifi, the message indicates “No Wifi adapter found”. So I googled and tried a few things but nothing worked. When I click on the plane icon in the taskbar and click on Airplane mode it says I need to “use hardware switch to turn off” which is FN + F. Does not work. I think this is all about Ubuntu not recognizing my Wifi adapter.

Using the command I got this:

0000000-f0003fff
*-network DISABLED
description: Wireless interface
product: Centrino Wireless-N 1000 [Condor Peak]
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 00
serial: 74:e5:0b:ad:ae:5e
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-36-generic firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:33 memory:f7e00000-f7e01fff

I went to the Intel website to download drivers for the Centrino Wireless-N 1000 but I got stuck on trying to figure out how to do that.

Here is a link: https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-1000-ucode-39.31.5.1.tgz

Also, my sound card is not recognized by Ubuntu…is this related??? I have no sound for about 2 days. In settings - sound there is no device listed. This has happened before and then corrects itself later.

Can someone assist in helping me figure this out? I would much appreciate this.

Thanks

Cheryl Lindsay


#2

is it possible there is an external wifi switch that got turned off? the one on my thinkpad is quite small and unobtrusive (maybe 2mm by 1 cm). i remember being a little surprised when i stumbled across it. a physical switch would be one reason a key combo wouldn’t fix the issue :slight_smile:


#3

Thanks for the insight! I carefully looked around and found some icons in a row next to the power button and lo and behold I found one with a wifi picture. I have only had this laptop for a few months that my brother gave me. Did not know you could shut your wifi on and off with a button.

Do you have any answers for why the sound doesn’t work?

Again thanks so much for the help


#4

like i said, my switch is so small and out of the way that i was a little surprised when i first found it. if i recall correctly, it was in a similar situation to yours where somehow it got turned off and i was baffled for a day or so :slight_smile:

i have had a similar sound issue since updating my ubuntu mate to 18.04. mine almost always happens when i wake it back up from suspend. so far the best “fix” i have come up with is a quick reboot.

what is your output for:
sudo lshw -C multimedia

edit: formatting


#5

here it is:

*-usb
description: Video
product: USB 2.0 Camera
vendor: Chicony Electronics Co., Ltd.
physical id: 4
bus info: usb@1:1.4
version: 55.43
serial: SN0001
capabilities: usb-2.00
configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
*-multimedia
description: Audio device
product: 6 Series/C200 Series Chipset Family High Definition Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 04
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:34 memory:f7f00000-f7f03fff


#6

my first suggestion is that if this next bit doesn’t help solve the issue, you might think about starting another topic for your sound issues. the little time i have spent in similar forums would seem to suggest that people might see that the wifi issue was solved if they pop their heads in and check the first few posts and miss that there is a different problem that they might be able to help with.

that being said, i found this post over on ask ubuntu which seems like it might offer some guidance. personally i liked the alsamixer command because it gave a bit of a graphical interface. though amixer (of course these two depend on your system using ALSA) and pactl might come in handy if that doesn’t get it done :slight_smile:


#7

I don’t know if this will help but in your BIOS is it set to ACHI or IDE if it is set to the latter try changing it to the former. I can’t remember where I saw it, but I have seen it recommended to change to ACHI as that solves many problems


#8

FYI…I downloaded a new copy of Kubuntu 18.04 and the issue is resolved.

Thanks!