No WiFi on mint is after new install

I cannot get WiFi to work on mint 19.1 on a new HP laptop

1 Like

Hi, @h.forsyth26 ! :wave:

Do you have any idea what Wifi chip you have? What is the model of your laptop?

Firstly welcome to the community. Did you not set it up during the install? During the install, you are asked if you want to connect or not, it usually wise to do so. If you’ve not done so you can easily do so through the connection settings which again is easy to do so. If you are still experiencing problems, this page should help you: https://easylinuxtipsproject.blogspot.com/p/internet-problems.html

1 Like

19.1 is not the latest Mint version. They ship 19.2 since 3 weeks with Kernel 4.15. So if this is a kernel issue you should try “latest greatest”.

Anyway … even with 19.1 in Mint there is a tool called System Reports. Maybe a good place to find out why your WiFi is not working and at least a good place to find out on which hardware you are running

Hi, @h.forsyth26
My usual question according to wifi problems on notebooks:
Is there a physical switch to turn wifi on/off? Or a special “function key” with a f-key? (e.g. “Fn-F2”)?
Did it function with the/any live-dvd? Or the pre-installed win10 (I suppose)?

Just not to overlook such little glitches…

2 Likes

I had the same problem with a slightly older laptop after a fresh 19.2 installation.
I went to the “Driver Manager” control panel, and activated the 3rd party driver there, as per this link:


That fixed it. :slight_smile:

2 Likes

What I don’t understand is why it wasn’t tried during the live version to check everything was working for that is the point of doing that. Or why the connection wasn’t made during the install which would have shown any problems?

1 Like

Nice.
Please set the solution tag on the post with the, well, solution.
And set the thread to “solved”.

Woops, that was supposed to go to @h.forsyth26

Hello , Sorry for the delay , here are the details ,
HP laptop , 15da,0998na , the WiFi adaptor is BUS 001 Device 002 , Ralink technology corp ., MT 7601 U . Hope this helps . This problem is well documented on the web for HP laptops , on the USB install there was no option for WiFi just a wired connection .
Regards , Hugh

Please go to a terminal and type this command and post the results here:
inxi -Nn

I Think ralink uses realtek chipset. if so you’ll need to install some third party drivers.

Hello , I have bought a WiFi dongle and stuck it into USB slot , works perfect , problem solved .

Will you please mark it as solved then. If you do not know how to do so, I will mark it solved for you. Thank you, it helps the community to know that you are not still looking for a solution

1 Like

Hello, Please will you close this issue as solved , for me , Thanks

Hi,
Yes I have done that for you :grinning:

dongle is the word I was looking for.

Hi @ElectricDandySlider

I am new here.
I have rewritten my three posts to make only one. post.

I came here to learn a solution about a driver problem with the
Ralink Rt3090 Half Mini Height Wireless N Card 802.11.

It seems that all Linux Mint version hate this card.

I have tried Linux Mint 20.1 “Ulyssa” MATE and
I had tried Linux Mint 19.3 “Tricia” MATE and both lost the WIFI connection.

I think that for some reason the driver rt3090PCIe is replaced with a generic rt2800pci in all Linix MInt ISO.

I looked all over the net and the only drivers I found are for Windows
[https://www.catalog.update.microsoft.com/Search.aspx?q=Ralink%20RT3090%20802.11n%20WiFi%20Adapter]

I bought a TL-WN725N at Dell.ca.
It is supposed to be compatible according to

Best USB WiFi Adapters for Linux (Review) in 2021

I received the TL-WN725N ordered from Dell.ca .
I put it in the first the USB port I saw.
I started the computer.
I got networks. :stuck_out_tongue_closed_eyes:

Now I think I’ll get a driver because the speed is tooo slow.

In the TL-WN725N box, there is a cd rom.
The following is the only note I found on that CD :

For Linux users, please visit the TP-Link support website, find and download the compatible version of driver for your network adapter at www.tp-link.com.

And, of course, on the TP-LINK website I find
Operating System: Linux (kernel 2.6.18 ~ 4.4.3) beta version
Operating System: Linux (kernel 2.6.18 ~ 3.19.3)
when mine is
Linux version 5.4.0-62-generic


I think I may go back to Windows 7 but before I will update the MX-19 ( patito feo ) this must be greek, right ?