No Wifi on recently installed Ubuntu

Hello everyone o/
I think this one is a bit worn out but I need some new input. I had a hardware (SSD) crash the other day and had to purchase a new hard drive and re-install both Win 10 and Ubuntu. During install I forgot I had a ethernet cable connected and it was used until both OS’s were completely installed. After I disconnected the cable Win 10 immediately found the home wifi and i could log on, but Ubuntu absolutely not. There is no Wifi icon apparent at the top right corner and if i disconnect the cable there will be no internet. See image:
Screenshot from 2022-12-08 00-09-48.
I have checked the additional driver repository and I’m using the same driver as before the crash when everything was working fine.
My wifi adapter is an Asus pce-ac68, with driver as pr image:

I have tried this:

and this:

Ubuntu does will not read .iso file from USB stick when mounted as cd-rom as pr description.
All drivers available comes as .tar files and advised links to .deb files/drivers does not work/is not correct.
Most of the commands when cut’n paste in terminal will end up in denials or “does not exist”.
So, I have an ethernet cable I keep snagging meself up in and Ubuntu otherwise works just fine, but it would be very nice not having this cable strewn out for the d…ed cat to play with and me snagged into and have some Wifi working - just as in Windows. Anyone?

Is the Wifi configured?
Look in your network settings menu
It will need a name and password for the modem
Linux does not normally configure Wifi at install time if you have an ethernet connection., it just assumes ethernet is the primary network connection and uses that.

Well, therein lies the problem. I can not find a wireless network to connect to, my only option is “wired” and that’s it.
As you say, and reading this description:
-the Wifi option should be available from the settings menu, but it’s not.
I’m considering calling it a bug, wipe the partition and do a new, fresh install, this time without the ethernet cable connected. Maybe the best solution before I start filling up the drive with more files than I already have.

Have you tried disabling the ether connection in Ubuntu and rebooting? I had to do that a while back.

OK, sorry, I did not understand.
That means the driver for the Wifi chip is not loaded into the kernel

  • try what @7blade suggests, that will load the driver module if it present as a package
    if that doesnt work, you may need to install a package
  • make sure non-free section of repository is enabled
  • use apt to search for drivers that may match your Wifi chip and install the appropriate package
  • reboot and it should load the driver module

You can check what modules are loaded into the kernel at any stage with lsmod

You can check if the most recent boot process detected the Wifi hardware with dmesg

I’m such a Noob, you could just have asked me to walk on the moon. :sweat_smile:
If you could explain a bit more I would be grateful.
I’ve done multiple re-starts with cable disconnected after each time I tried something new without any improvment.
By enabling non-free section of repository I assume you mean “Universe” and “Multiverse” which both have been added.
I have seen more people out there having the same problem/same adapter. Only thing I know it worked before the crash and no problems in windows. Found a driver at Asus, but again a .tar file - don’t know how to handle those.

The wifi network you need to connect to is the one Win10 found. I’d reinstall Ubuntu with the ethernet unplugged. You can use Rufus in Win10 to make a clean install USB.

That’s exactly what I tried here today, just finished shuffling all the files back into place in the home folder - But still no Wifi. What I will try next maybe find someone who can lend me a USB wifi stick to see if that will work, just to come a step further by adding one item to eliminate another. I’m going slightly mad here.

Dont look for drivers outside of Ubuntu, they will be there in the Ubuntu repository, and may even already be installed on your disk.

There are 3 tbings

  • drivers in the ubuntu repository
  • drivers in a package installed on your disk
  • drivers loaded as a module into the kernel

You have to determine where you are at…
so last one first… what kernel modules are loaded?
Use lsmod
it will list all modules loaded into the kernel at boot time
I bet the Wifi drivers are not there

Next … do you have the package installed?
dpkg -l
It will list every installed package. Look for some package name that might be Wifi related. I dont know the name of the package you need. You will have to guess

Next … if you dont have the required package installed, you need to find it in the repository and install it…
Use apt search wifi
or apt search driver
or apt search broadcom
again you have to guess what search criterion to use.
If you find a likely package name, then install it with
apt install packagename

Sorry it is so complicated.
The kernel can only use a driver if it is loaded as a module into the running kernel
The kernel can only load a module if it has been installed on your disk as a package containing the appropriate .ko file
To get the appropriate package installed you have to guess its name and install it from the repository.

and we dont yet know which of those three stages you are at?

Do some investigating… you will learn on the way.
If you dont want to learn, do what @berninghausen says and reinstall with the ethernet disconnected.


1 Like

Can’t disagree with that, but I feel there is progress and I’m learning :slight_smile:

First of all I must tell how grateful I am for all the help I get here.

I have already tried to re-install without cable connected and ended up with no wifi again, so it must be a driver issue.

So, using “lsmod”: As I have conjured up from the interweb I am looking for something called “brcm80211” which, as you are willing to bet, is not present.

I found quite a few packages in the repository and quite roundhandedly installed the lot using apt install. :sweat_smile:

After that i ran “dpkg -l” again and the new Broadcom packages were present.

Re-started the computer without cable and ended up without wifi – again.

Running “lsmod” and still no sign of a broadcom driver.

After my rather roundhanded approach I later found out that the 2008 released 802.11 Linux STA driver is the driver officially supporting Broadcom wireless devices on GNU/Linux and I should have been happy with that. It just isn’t present in with the kernel modules.

Can I use apt uninstall to get rid of the packages I installed? I mean they have not been registered/installed into the kernel – or does it really matter?

I guess none of those packages contained any .ko file - or maybe there is one more operation to open the packages to extract the appropriate files?

As I have stated before: I am a complete greenhorn, a noob, but willing to learn and I find this interesting. I like Linux (or shall I say Ubuntu) for the very un-intrusiveness, the speed, possibilities and freedom it offers – even if it is a bit troublesome for the moment :).

Seasons Greetings and Brgds


Apt remove or apt purge will do it
It doesnt matter, but better to be clean.

After my rather roundhanded approach I later found out that the 2008 released 802.11 Linux STA driver is the driver officially supporting Broadcom wireless devices on GNU/Linux and I should have been happy with that. It just isn’t present in with the kernel modules.

Then you need to load it into the kernel. That is easy. You can plug modules in and out of the kernel while it is running, and you can also configure things in /etc/modprobe.d to add modules as it boots.

If you have the Linux STA driver , there will be a .ko file present… look in /lib/modules/…,. Might take a bit of searching. you need to know its name.

Look here for how to load it

It is a bit of a mystery. You have the package containing the Linux STA driver present, but the system is not loading the module when it boots.
Maybe it is not detecting the Wifi device at boot time. To check that you do
dmesg as root
and search thru the output for the Wifi device. It should tell you if it finds the device, and if it can find a driver for it.


Years ago I opted to run Cat5 cable to my “office.” There, it’s plugged into a router to create a subnet. So I have several outlets for hardwired ethernet and full-strength wifi in my working area. Everything I try works without problems, hardware or software.

1 Like

I had this issue with an older Macbook Pro wifi card. This is the link that led me to the solution:

That said, I did have to get a working WIRED connection to fix the wifi (to get a clean driver download for the card). In my case, I had just moved and couldn’t find a CAT5 cable, so I actually just plugged my cell phone into my Macbook via usb connection and used it to connect to the internet to download the driver. Worked with minimal fuss and almost no setup at all.

Hi o/
Trying to answer both, leading the way further, I have run “lspci” in terminal and found network controller: Broadcom BCM4360 802.11 wireless network adapter in the list.
Then, in the process of installing the driver I meet this message (cut’n paste):
“Your system has UEFI Secure Boot enabled.
UEFI Secure Boot requires additional configuration to work with third-party drivers. The system will assist you in configuring UEFI Secure Boot. To permit the use of third-party drivers, a new Machine-Owner Key (MOK) has been generated. This key now needs to be enrolled in your system’s firmware.
To ensure that this change is being made by you as an authorized user, and not by an attacker, you must choose a password now and then confirm the change after reboot using the same password, in both the “Enroll MOK” and “Change Secure Boot state” menus that will be presented to you when this system reboots.
If you proceed but do not confirm the password upon reboot, Ubuntu will still be able to boot on your system but any hardware that requires third-party drivers to work correctly may not be usable.”
D’oh! :face_with_open_eyes_and_hand_over_mouth:
However much I try to install the driver there is no change in the list when i run “lsmod” after re-boot.
Did not think much over it, just set a password but was never asked for it at re-boot. I start suspecting I have found the culprit, guess I have to go in and tweak a bit in the UEFI settings, probably the “secure boot” thing, but like to ask your opinion first as you have been involved from the get-go.

1 Like

OK. Could not wait. It’s solved!
UEFI settings: Secure boot state set to “Other OS” and password removed. Re-booted the computer, started Ubuntu from boot loader and Wifi present at start.
Logged on to home network and removed cable, now to the next issue (will probably pop up within the next few days) :sweat_smile:
Thank you for all the good help! And, as Arnold said:
I’ll be back…


1 Like

Well done.
That is something I was not aware of

Same / Similar here…

But I don’t run ethernet cables through the house, I use Ethernet over Power with Powerline adapters… One in the kitchen where my VDSL comes in to my router / firewall / modem - I also keep my Pi4 gateway / OpenVPN server here too…

In my office - a 24 port unmanaged gigabit switch - and I have my NAS (FreeNAS), my desktop Linux machine, several Linux laptops, SBC’s (Orange Pi and Pi3) and both my MacBook pros - ALL with ethernet as primary interface - I’ll ALWAYS favour ethernet over WiFi…

e.g. even Synergy is CRAP on WiFi - even 5 Ghz WiFi - gimme gigabit full duplex anyday - even 500 Mbit ethernet over Powerline is better than WiFi…

Also - I don’t often come across wifi devices that don’t work with Ubuntu - but, when I do - I usually give up and buy something else that’s known to work with Ubuntu…

Note : Powerline adaptors are pretty much plug and play… never had any major issues with them…

1 Like

An afterthought:
The Broadcom driver as found in the kernel running “lsmod” after the wifi were finally found was not “brcm80211” as stated in the wiki article, but as follows:

cfg80211 size: 974848 used by: 1 wl



1 Like

Yes, lsmod output is never easy to interpret.
Room for imporovement… I would like it to list the name of the .ko file