Printers compatible with both Windows and Linux

Does anyone know which recently launched Brother, Canon and HP mono laser and ink tank printers are compatible with both Windows and Linux? I have tried a few but none appear to be compatible with Linux. All are only Windows compatible but not with Linux even with CUPS installed.

Mike, I’ve never had any trouble with any HP printer and any Linux distro. I’m currently using an HP Envy 4520, which works equally well with my home-built Linux machine and my HP Windows 11 gamer (wifi connected). I’m also using a Canon ImageCLASS MF4450 with my Linux machine. I downloaded my Linux driver from the Canon website since the printer’s pretty old.

The HP printer is usually picked up and connected by most distros as an automatic part of the install process. especially if I plug in the USB cable before the install. Then the install genius sets up both the USB and wifi printer instances in whatever the new distro is.

Some more detail or screen prints would help me see what’s not working.

Hi @MikeSA , I am currently using a HP Deskjet 1510 and have no problems using it with Windows or Linux Mint.

I just got an Epson ET-5180 ecotank printer. It works great, both scanner and Printer. “Epson Scan 2” is available for Linux from Epson. Vuescan works even better.

The only wrinkle was that the Ubuntu printer auto-setup didn’t work. Instead of choosing EPSON ET-5180 from the list of Discovered Network Printers, I had to choose “LPD/LPR Host or Printer” and then specify lpd://EPSON3CF7B5/BINARY_P1" as the connection. Ubuntu offered a choice of working drivers for the printer.

To get the proper connection name, I looked up the network address in the printer’s panel settings. It was 192.168.1.164. Then I looked up the connection name with avahi-resolve-host-name -a 192.168.1.164. Your network address may be different.

I had to do the same thing with my aging Epson WF-7620 printer. Epson printers on Ubuntu require special care these days.

I can’t speak to Windows.

@MikeSA ,
If you buy a postscript printer it will always be compatible with linux, regardless of the brand.
You also need to consider whether you want ethernet or wireless connectivity

1 Like

HP brand offer the least incompatibility for either Windows or Linus (most common distros) with Brother a close second.
Check the support sections of both manufacturers sites for more specific information relative to your potential model.

1 Like

Admittedly my Brother laser MFC is 6 years old…

But it works out of the box - i.e. 100% plug and play since around Ubuntu 17… i.e. I install Ubuntu and it just goes out (in the background - no human intervention) and finds my printer via WiFi or ethernet… and there it is - and it works, and it knows I’m in Australia and we don’t have weird arse paper sizes like “letter” (defaults to A4).

Note also - in my previous job, I used to support a regional energy provider across the whole state of WA (Western Australia - it’s bigger than Texas, by a factor of 4 or so), and their ERP system used CUPS and they had a bunch of brother MFC’s, later models than mine (and more expensive) and I never had any trouble whatsoever, going to Brother’s website, and grabbing the drivers for those models, even on EL5 (Oracle Linux 5 = Red Hat EL 5)… But eventually replaced all the EL 5 stuff with OEL 7, and much better - and Brother supplied drivers from their website just “worked” (note no such thing as plug and play on OEL 7 across 2.646 million square kilometres : Esperance in the south “east”, to Kununnurra near the Northern Territory border).

Gimme Brother anyday over any other printer vendor… Note : having written the above - I don’t use all the MFC features from Linux - only printing (duplexing and colour work out of the box). When I want to scan I save to my FTP server (on my NAS) directly from the the touch screen interface on the printer front panel, and we don’t have analog phone line, so no FAX functionality…

Did you confirm that on Brother’s website / driver downloads pages? They’re actually pretty good…

Just checked OfficeWorks (national office supplies chain in Au) and they have the Brother MFC-L3750CDW for sale for $469 (less than I paid for my similar device in 2016) and Brother downloads have Linux drivers for it :

Having written all the above - my Ubuntu 22.04 (Gnome 42) is telling me :
image

I blame Gnome and Canonical - not Brother…

I printed a multi-page document the other day no dramas…

I will echo that HP has worked well for me on both windows and Linux with no problems. Been Using HP’s for over 20 years. They for the most part just work.

My Canon driver seems to have come with some weird “uk?” settings and I have to go in and alter “A4” to “Letter” so the printer doesn’t blink its red “wrong size” light. After that little fix, all is fine. HP printers just set up properly with “Letter.”

Ubuntu 22.04 LTS for me and my HP OfficeJet Pro 8720 works great, even duplex printing and draft mode (to conserve ink).

image

A pox on Canonical and Ubuntu 22…

Tried a bunch of things and even rebooted (I LOATHE rebooting)… still got :
image
Least helpful message of the month for me anyway…

Man - what steenking pile of crap! For some reason (before the reboot) systemd had “masked” cups.service… unmasking (sudo systemctl unmask cups.service) it didn’t help… e.g. was unable to https://localhost:631

So - after the reboot - still nothing - no printing, unable to https://localhost:631/ (that’s the CUPS URL)…

Ended up doing this :

sudo apt install --reinstall cups

And lo and behold, it installed a bunch of stuff that wasn’t installed - I’m going to assume some other malformed (malign) package deemed them unnecessary and broke cups?

Now my printer shows up in the Printers section of Gnome Settings - and - I can now https://localhost:631 - and most importantly, my Brother Printer shows up (the driver of which, Ubuntu’s always just gone and installed without human intervention).

That happened to me in Debian, so it is not Ubuntu’s fault this time
I did a purge and install of cups. I guess reinstall is the same.

That media=iso_a4 happens with my Brother MFC640CW too.
How does it differ from plain A4?

I have absolutely no idea… that’s how it comes, “out of the box” when Ubuntu automatically (no human intervention) finds it via WiFi (or ethernet) and sets it up…

It’s 100% “plug and play” (hook it up to wifi or ethernet)… More so than anything I’ve ever experienced in Windows or Mac…

Better than my Brother. I have to manually install drivers, they are not in the CUPS driver database. But it does autodetect .
A4 amd iso_a4 are the same size. Just terminology. Why CUPS lists both is beyond me?

1 Like

I have a Canon G4200 series printer that works just fine with Linuxmint.

Wow! I’m impressed - I just looked up that printer and it’s from the first half of the noughties!

I hope my Brother’s still going strong in 10 years!

I reckon the $150 I paid to have it (MFC-9335CDW) fixed (sensor board needed replacing) was a bargain, rather than turn a reliable workhorse into landfill…

Yeah, Brother are built like tanks. Its an inkjet… most important thing with inkjets is to use them regularly… avoids ink drying out and clogging jets. It takes aftermarket cartridges without problem so it is cheap to run. I use the scanner as well as printing. Have to install drivers for scanner separately. They are just .deb files.

Your Brother MFC9335cdw is a laser.
I have an OKI 12i… its an led printer ( like a laser but uses led array) and it supports postscript. I can drive it from any Linux just with the generic postscript driver. It is even older than the MFC640cw. I paid $300 to put a new drum in it at one stage, and that was a good decision. Cant remember the original cost but it was something like $1000 in about year 2000.

I paid ~$900 for a Brother laser in 1994… seemed like a huge sum back in the day, and I guess in real terms it was… It was a great little laser printer… a workhorse… till my wife put a transparency through it and basically destroyed it… after I’d reminded her repeatedly ONLY USE PHOTOCOPIER safe transparencies… Oh well… She’ not studying now, nor working as a teacher’s aid, so will probably never happen, in fact, the whole transparencies and the overhead projector thing is pretty much defunct these days, with powerpoint and projectors…

I don’t bother installing scanner drivers for my MFC, I just scan to an FTP server running on my NAS, or to a USB thumb drive… One thing Epson have Brother “beat” over, is scanning to the cloud… I had an Epson Inkject MFC (never used it as a printer) that I inherited from my brother when he passed away - it was VERY useful I could scan pretty decent quality straight to my gmail inbox!

1 Like

I wonder if a dedicated scanner is the way to go for me in future.?

Your Brother Laser was probably had a postscript engine. Postscript printers seem to have gone out of fashion. They are more expensive. I wonder if it is still the best option?

My answer to all printer problems with either linux or windows is to purchase’TurboPrint’, a controller for any printer used by Linux.
Windows has the same printer controler called ‘PrintFab’ which works for Mac OS too. Since that purchase my printer problems vanished - and I don’t spend money easily!
Remember, any printer, any version of linux, no more worries.