Problem with Libre Office Writer

I hope someone here can help with this as it is rather urgent. I am currently typing up a talk on ancient Egypt that I am going to give in the near future and half way through the document it is suddenly displaying very tiny print. Does anyone know why this could happen?

can you post a screenshot?

I am sorry to say that I do not know how to take a screen shot and I have been using Linux for five years and Windows for many years before that. I had another look at the page I was typing and already I discovered a work round. the last things I typed before the problem occurred was Ramses 1st – 11th - and of course the st and th were in a smaller font size automatically so what I typed after that was also very small. I erased them and typed the next line of text and then went back again and reinserted the 1st and 11th. I do not know why this happens but at least I know what to do in the future if the situation arises again. Thanks for the quick reply though.

1 Like

What about the PrintScreen button?

2 Likes

I use the mate screenshot utility and shutter for screenshots.

1 Like

In English language, it is a common practice to write 1st with st in small fonts on the top. LibreOffice did the correct thing by (possibly) automatically converting it to that format.

As far as solving the problem goes, I suggest use the right arrow key to move to the next white space after ‘st’ and start typing letters here. This might work.

2 Likes

In most of the mainstream distros, the PrtScn button takes a screenshot by default.

As for the issue in Libre, see abhishek’s reply above.

expanding a bit on what @abhishek explained, i found that writer was converting these ordinal number suffixes to superscript which you can see in the toolbar as the letter a with a smaller b beside and above it like so:

in my trial, writer stopped converting to superscript after i hit the space bar. have you tried saving the document, closing writer and then continuing with editing? if yours continues to convert, it seems like you have a couple of options.

if the way you have been doing it works for you, it makes sense to continue. another way is to turn off the conversion formatting. in the Tools menu there is an AutoCorrect submenu. the last item on that menu is AutoCorrect Options. there is a tab in that window titled Localized Options which looks like this:


deselecting the bottom two options in front of “Format ordinal number suffixes” gets writer to stop converting the suffixes.

if you feel like the superscript is helpful and isn’t occurring so often that this options is burdensome, you can switch back to regular font by pressing shift + ctrl + p as indicated in the first screenshot before you start typing again.

2 Likes

@cpast, under Linux Mint Cinnamon you can find Screenshot under Accessories.

I run Linux Mint Cinnamon, and the PrintScreen button works for me.

I tried that but it obviously did not make any difference but know matter I found a simple work round. I just deleted the 1st - 11th, typed the next sentence and then went back and inserted the deleted text again. That worked fine.

1 Like

I have found it now but never even realised it was there. Never had to use it before. Thanks

2 Likes

Yeah sounds obvious but as I had never used it before I did not even know it was there. I know where it is now so thanks all for your help.

1 Like

I did save the document, and close writer but nothing changed. It is odd that I had been typing all the Dynasties relevant to my talk the same way and the problem did not occur, only when I wrote two consecutively did the problem show up. There is a Libre Office manual that I saw advertised in Linux Magazine so I tried to buy in on line only to find out that it is not sold to Australia which I though was very odd. I tried Amazon and they said the same thing. Most annoying.

1 Like

This is a feature that drives me to a rage several times a day! And swear, a lot, in an open plan office…

In nearly EVERYTHING these days where you can type formatted text, there is computer software making arbitrary decisions about what your intentions might be :

Me : types “:”
Computer : “no you didn’t really want a colon, you really wanted to type a sideways emoji smiley, because I know you better than you do…”
Me : types “ctrl + Z” (undo)
Me : “you @%$#ing computer! - I wanted a %#$ing colon character!”

Five minutes later
Me : types “(SMB)” (in an email about windows file sharing), and keeps typing away…
Computer : “no you didn’t really want to type (SMB), you really wanted to type “(SM” then a sideways emoji smiley wearing sunglasses, because I know you better than you do…”
Me : reaches for sledgehammer…

Only kidding - but it does seem all pervasive… I spend so much time undoing (or backspacing if I’m too late and have lost that particular undo “step” I wanted to undo) and backspacing, whatever time these features were designed to save, they actually cost me more, exponentially… I can touch type - I did typing in high school in the 1970’s (on manuals and IBM golfball electrics), I’d much rather just power through with the ascii / ansi characters, then go back later and format… I almost NEVER want to format as I type (or even spell check for that matter).

And - it seems even harder to turn off in Libre Office than it does in MS Word… well it’s obfuscated deeper into the configuration than with Microsoft’s “competitor” anyway, from memory… I hate having to try and find where it’s buried when I need to turn it off (I might bookmark this forum post)… really needs a big button somewhere “turn off ALL big brother features from this application”.

My little slightly exaggerated anecdote above, is me typing emails in Microsoft Outlook web client (in Chromium)…

Even this forum’s sofware “discourse” tries to be too clever by half :smiley: (thinking “:” means you want to type a smiley). Dang! It even does 66 99 quotation marks :rage:

2 Likes