Questions regarding openbox session

Hi all, :wave:

running Linux Lite 6.2 as my daily driver I know that it uses the xfce DE.
A dektop environment - as far as I know - consists of several items.

  • window manager
  • display manager
  • panels and docks
  • xserver ?
  • file manager ?

Perhaps I´ve forgotten something.

Well, the important part to me is that the window manager is just one part of an entire DE.

I know that a dedicated session can also be started with only a window manager running, e.g. i3wm (i3 tiling window manager).

I already installed i3wm in Linux Lite and can choose this option on the login screen. I works well and I get no problems with using either the default login option (Linux Lite with its modified xfce DE) or i3wm. :smiley:

In the meantime I´ve learnt that a dedicated openbox session can also be run (like an i3wm session) on an installed system.

On Openbox › Wiki › ubuntuusers.de it says:

Openbox is a very fast window manager, which is characterized by its high adaptability and low resource needs.
By editing only three files, you can adapt it to your own preferences.
[…]
The following packages must be installed:

sudo apt-get install openbox obconf openbox-menu

Openbox is automatically entered into the session selection of the respective display manager and can be started from there. However, you can also use Openbox on the console

openbox-session

(translation via “TranslateLocally for Firefox” add-on)

Sounds interesting so far. :smiley:

I´d like to give it a try but I´m not completely sure I won´t run into any problems. :thinking:

Basically my questions are:

  • is an openbox session comparable to an i3 tiling window manager session, as both are “just” window managers, not an entire DE?
  • so: is it probably safe to use?

I´d like to avoid potential problems like those ones documented on gnome - Will I have problems installing multiple desktop environments? - Ask Ubuntu :

However, desktop environments will often “argue” with each other and overwrite settings.
For example, installing KDE on a system will very often break a Unity installation by overwriting GTK or similar properties.
Similarly, installing Unity will break KDE most of the time.

Thanks a lot for your opinions in advance.

Many greetings from Rosika :slightly_smiling_face:

I use i3 and OpenBox on Gentoo, Arch and Slackware which I triple boot and there are no conflicts per se, there’s more of a symbiosis in that often the same tools are used to configure both (ie, Nitrogen for wallpaper, dmenu, rofi, etc) and changes in one makes the same change in the other. Choices can be made to prevent that such as using feh rather than Nitrogen, but personally, I like the consistency. Both use the GTK toolkit so the problems that occur when KDE is installed and ran under the same user account as Gnome or other GTK DE’s isn’t an issue.

I use KDE as my primary DE so I run OpenBox and i3 under a separate user account. The way I assure there are no conflicts or bad behavior between the competing toolkits while maintaining consistent access to files is to keep all the usual folders in my /home directories (Documents, Downloads, Pictures, Videos, and Music) on a separate partition which gets mounted by each distro. The I delete those folders from each /home directory and symlink in the ones from my /files partition.

Doing this is the best way I’ve found to have access to the files I need while keeping the .dot files separated for each distro. No interaction between local configs - no conflicts.The screenshot below shows the mounted partitions for arch and symlinks in to /home that keep things in their lanes.

1 Like

Also, in addition to the packages you listed for installing with OpenBox, I would suggest Picom as the compositor, Nitrogen to manage wallpaper, menumaker to run following new installation of software to dynamically update menus, tint2 panel, or if you want a panel that works without configuration, the XFCE4 panel works great in openbox. For applying themes, icon packs, etc., while OpenBox provides its own tool, installing LXAppearance will probably make for a better user experience. Your existing display config should set set the proper resolution without intervention. If not, don’t bother with adding tools for setting the resolution, just add:

xrandr -s (your desired resolution) &

to ~/.config/openbox/autostart

along with other entries needed to apply your desired config such as
picom &
tint2 & – or
xfce4-panel &
nitrogen --restore &
mmaker -f openbox -t xterm & (to update menus if using menumaker)

and whatever else you like.

Since you’re adding it as an additional choice, you really don’t need to do anything as far as X or the display manager are concerned. It will automatically show up as a session choice in the DM and your existing network configuration (I’m assuming NetworkManager in Xfce) should automatically connect to ethernet or wifi just as it would in xfce without any intervention on your part and all your installed programs will be available in openbox.

2 Likes

I do the same thing, not to use another window manager, but just to make user files accessible to all distros in a multiboot. It works exactly as you describe… keeps all the dot files separate for each distro.

2 Likes

It also makes backing up a multiboot system more efficient.

2 Likes

Yes, it simplifies user backup. I just rsync the shared area frequently
Multiboot system backups are messy. I gave up being selective and just Clonezilla the whole disk to an image.

1 Like

Hi all, :wave:

thanks a lot for your great help. :heart:

@Kenneth_Dotson :

Wow, you´ve done a perfect setup of your system, I must say. :+1:

That sounds good. Thanks for the confirmation.

Pretty much the same with me. :blush:

That sounds interesting.
To be honest, I wouldn´t have thought of that.
I guess that would be a wise path to follow for me as well.

So I create another user account for a user like “rosika3”.
Hmm, as I´ve never done that before I had to read up on it. :thinking:

For ubuntu and ubuntu-based systems I found here :

For the “simple” creation of a user, you do not need any options at all, i.e., for example, you want the user otto the command is enough:

sudo adduser otto

(translation via “TranslateLocally for Firefox” add-on)

O.K. that seems simple enough.

So when I have created a new user account I choose this new user at the login screen together with openbox as “desktop environment”.
I hope I´m getting it right.

That´s a very elegant soultion. :+1:

I have 3 partitions on my system: root, home and a 3rd (data-partition).

I just looked up what I have on my actual home partition and its 113 MB worth of data all in all.
I make extensive use of my data partition. So that wouldn´t be a big problem for me, I guess.

But I think I could follow your way of doing it like this: I could symlink e.g. the pictures folder on my 3rd partition to the pictures folder on the home partition of my new user and so on.

I must admit Iwouldn´t have thought of that. :blush:
Thanks a lot.

Thanks for the suggestions, Kenneth.

Good idea using xrandr for setting the resolution. I have some experience with that already as I use it for setting the correct resolution in my virtual machines.

Thank you very much for your kind help. :heart:

@nevj :

That´s exactly how I do it as well, Neville. :wink: :+1:

Thank and many greetings to you all.
Rosika :slightly_smiling_face:

1 Like

@Kenneth_Dotson :

Hi again, :wave:

In the meantime I managed to set up another user account rosika_3 and I also installed openbox obconf openbox-menu (as a start, I´ll do picom and the other items you suggested later).

That went well :+1: .

From my first user account rosika I also did:

sudo rm /home/rosika_3/.local/share/fish/fish_history
sudo ln -s /home/rosika/.local/share/fish/fish_history /home/rosika_3/.local/share/fish/
sudo rm /home/rosika_3/.bash_history
sudo ln -s /home/rosika/.bash_history /home/rosika_3/

in order to get all the fish and bash history from the first user to the second user (with the help of symbolic links).

But when I logged into the openbox session (new user: rosika_3) that wouldn´t work as
I don´t seem to have access to the original files. :thinking:

I fired up thunar and realized I have no access to other partitions either. :roll_eyes:

Although all of my 3 usb-sticks are mounted (as is my third data partition) I cannot access them.

I guess there has to be a problem with permissions in general.

Any ideas why that is?

Many thanks and many greetings
Rosika :slightly_smiling_face:

P.S.:

I just checked groups:

groups rosika
rosika : rosika adm cdrom sudo dip plugdev kvm lpadmin sambashare libvirt

groups rosika_3 
rosika_3 : rosika_3

Maybe there´s something to be done here…

UPDATE:

Hi again, :wave:

in the meantime I added the new user (rosika_3) to the same groups user rosika belongs to:

id -nG rosika
rosika adm cdrom sudo dip plugdev kvm lpadmin sambashare libvirt

 id -nG rosika_3
rosika_3 adm cdrom sudo dip plugdev kvm lpadmin sambashare libvirt

So the only group rosika_3 doesn´t belong to is rosika. Apart from that they´re identical.

But it seems it hasn´t helped much. When logging into the new user account and trying to access any of the usb-sticks or the third aprtition I´m still not allowed to do so. :slightly_frowning_face:

Message: “cannot open [device]”

Hmm, I´m not sure what I´ve done wrong. :thinking:

Many greetings from Rosika :slightly_smiling_face:

Hi Rosika

If those partitions are owned by rosika and permissions are 640 or 750 rosika3 will need to be in group rosika to access them.
If permisdions are 644 or 744, it should be able to access them

Regards
Neville

1 Like

Hi Neville, :wave:

thanks for the suggestion.

Permissions look like this:

exa -lg

drwxr-xr-x - rosika rosika  1 Jan  1970 28BC-DAFC
drwxr-xr-x - rosika rosika  1 Jan  1970 74C1-30C7
drwxr-xr-x - rosika rosika  1 Jan  1970 A492-CD29
drwxrwxrwx - rosika root   14 Jan 13:01 f14a27c2-0b49-4607-94ea-2e56bbf76fe1

So I guess they´d be

  • 755
  • 755
  • 755
  • 777

Hmm, I guess I´ll have to make rosika_3 part of group rosika:thinking:

Many greetings from Rosika :slightly_smiling_face:

UPDATE:

Hi, :wave:

Well, I´ve done it and the permissions look like this now:

groups rosika
rosika : rosika adm cdrom sudo dip plugdev kvm lpadmin sambashare libvirt

groups rosika_3
rosika_3 : rosika_3 adm cdrom sudo dip plugdev kvm lpadmin sambashare rosika libvirt

But still no success:

Now that user rosika_3 is part of groups rosika i would´ve assumed there wouldn´t be any problems.
But I still get the message. “cannot open [device]”. :slightly_frowning_face:

So I looked at permissions when using the new user account in openbox:

Here´s a screenshot I took during the openbox session:

As you can see as the new user rosika_3 I can access old user rosika ´s home directory but not the third partition and not the usb-sticks under /media .
For this I need to be root.

That´s surely the reason why I get the message. “cannot open [device]”. :thinking:

But: I would´ve thought being part of group rosika was taking care of that.
But obviously it doesn´t…
But why… :question:

Many greetings from Rosika :slightly_smiling_face:

Hi Rosika,
Agree.

What does
ls -l /media
show?

I get similar stuff with mounts. Only root can access them.

Regards
Neville

Hi Neville, :wave:

thanks for your reply.

Here´s the respective output:

ls -l /media
total 8
drwxr-xr-x  2 root root 4096 Okt 31 03:53 cdrom
drwxr-x---+ 6 root root 4096 Feb 16 13:44 rosika

but:

ls -l /media/rosika/
total 44
drwxr-xr-x 36 rosika rosika 16384 Jan  1  1970 28BC-DAFC
drwxr-xr-x 79 rosika rosika 16384 Jan  1  1970 74C1-30C7
drwxr-xr-x 30 rosika rosika  8192 Jan  1  1970 A492-CD29
drwxrwxrwx 30 rosika root    4096 Jan 14 13:01 f14a27c2-0b49-4607-94ea-2e56bbf76fe1

Many greetings
Rosika :slightly_smiling_face:

Hi Rosika,

That ‘+’ after the permissions stands for Alternate Access Method
https://wiki.archlinux.org/title/File_permissions_and_attributes
Never seen it before… Dont know what it is in your case.
Is that filesystem mounted with ACL enabled?

Rosika has to be in same group as root to access that directory. Same for Rosika3
It still does not make sense

Update:
I did some trials. Mounted /dev/sda4 with Thunar and I get

nevj@mary ~ $ ls -l /run/media
total 0
drwxr-x---+ 3 root root 60 Feb 17 02:44 nevj

Then mounted /dev/sda3 manually

mary /mnt # ls -l
total 0
mary /mnt # mkdir nevj
mary /mnt # ls -l
total 4
drwxr-xr-x 2 root root 4096 Feb 17 02:47 nevj
mary /mnt # mount /dev/sda3 /mnt/nevj
mary /mnt # ls -l
total 4
drwxrwxrwx 24 99 99 4096 Dec 12 01:08 nevj

So that ‘+’ comes from Thunar. A manual mount does not do it.
The manual mount changes the user and group to 99, there is no such user? It must mean something special. If I unmount, it changes it back again

mary /mnt # umount /mnt/nevj
mary /mnt # ls -l
total 4
drwxr-xr-x 2 root root 4096 Feb 17 02:47 nevj

If I umount the one mounted with Thunar I get

mary ~ # umount /run/media/nevj/LinuxRoot1
mary ~ # ls -l /run/media
total 0
drwxr-x---+ 2 root root 40 Feb 17 03:07 nevj

So the nevj subdir stays there and retains the +. So maybe it does not come from Thunar?.

Regards
Neville

1 Like

Hi Neville, :wave:

thanks for investigating on my behalf. :heart:

O.K., you´re right. I saw the plus sign as well but I didn´t pay any attention to it.

Thanks for the link. I also found a quite lengthy article regarding ACL on
ACL › Wiki › ubuntuusers.de .
It´s in German but as always:
English translation available via “TranslateLocally for Firefox” add-on

Editing ACLs:

The ACL management runs via two programs:
setfacl is used to set and delete ACLs
getfacl is used for reading ACLs

So I tried the latter command on /media

ls -l /media/
total 8
drwxr-xr-x  2 root root 4096 Okt 31 03:53 cdrom
drwxr-x---+ 6 root root 4096 Feb 17 13:19 rosika

vs.

getfacl /media
getfacl: Removing leading '/' from absolute path names
# file: media
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

vs.

getfacl /media/rosika/
getfacl: Removing leading '/' from absolute path names
# file: media/rosika/
# owner: root
# group: root
user::rwx
user:rosika:r-x
user:libvirt-qemu:--x
group::---
mask::r-x
other::---

I guess it seems so. :thinking:

Hmm, root is only in group root:


groups root
root : root

User rosika is not in group root (just in group sudo):

groups rosika
rosika : rosika adm cdrom sudo dip plugdev kvm lpadmin sambashare libvirt

… but everything works fine.

Quite.
I don´t get it either as new user rosika_3 is in the same groups as old user rosika plus in group rosika…
So why on earth can´t rosika_3 access the same files as rosika:question:

Thanks a lot anyway for your help, Neville.

Many greetings
Rosika :slightly_smiling_face:

P.S.:

UPDATE:

So I´ve done a bit of experimenting and found out the following:

  • logged out from my present user (i.e. old user rosika with xfce DE)

  • logged in as new user rosika_3 (openbox session)

  • in openbox session : started thunar. Clicked on any of the three usb-sticks and also 3rd HDD partition: None of them could be accessed. This was to be expected.

  • unmounted the three USB-sticks and 3rd HDD partition via terminal commands

  • mounted all those again via terminal

  • all of them could now be accessed (also via thunar) :+1:

If I remember correctly it was enough to unmount them.Then mounting those drives via clicking actions in thunar worked as well.

So a bit of success so far. :smile:

  • Now I logged out of the openbox session

  • logged into xfce session (user rosika again) once more and:

  • couldn´t access either the usb-sticks or the third HDD partition .

  • yet they seem to have been mounted.

  • I tried to unmount them from within thunar

  • was not allowed to do so

  • message popped up saying: […]was mounted by another user :smiling_face:

  • could unmount them with the right privileges …

  • … and mount them again from within thunar :+1:

Now everything worked as before.

So to sum up:

It seems like logging out from one user account leaves the sticks and 3rd HDD partition
in a mounted state when logging in to another user account.
So the “new” user has no rights to access them as they were mounted by another user.

Unmounting them with elevated privileges and mounting them again as the new user will get them going again.

The only thing I don´t understand is:
When powering down the system and then rebooting it will have the same effect of denial of access.
Although I still have to check how things behave after a cold start. That might be different then… :thinking:

Many thanks and many greetings from Rosika :slightly_smiling_face:

Hi Rosika,
Very clever. That makes sense now. Thunar mounts filesystems as the current user. So the current user has access but noone else

If you mount with sudo mount ..... it belongs to uid=99, and users can only read access. I think that means any user, oit just the one who did the sudo mount?

I wonder what happens if you use Gnome Disk utility to mount?

I think we both need to read the section in the man mount page about non-superuser mounts

Regards
Neville

Regards
Neville

1 Like

Hi Neville, :wave:

thanks for your reply.

Yes, it seems that way although it´s the same whenever I right-click on the repective desktop icon (“mount disk”). So I guess the mounting procedure is desktop-environment-related.

Thanks, Neville.

Here it says:

Normally, only the superuser can mount filesystems.
However, when fstab contains the user option on a line, anybody can mount the corresponding filesystem.

Here´s what my fstab looks like:

cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb1 during installation
UUID=411331c4-730c-4a53-963b-e58f5733e688 /               ext3    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=FC63-685C  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sdb2 during installation
UUID=7f7b5dd9-60ef-4dd1-98dd-f585c921f2cf /home           ext3    defaults        0       2

Not sure about the “the user option on a line”… :thinking:

Well, apart from all that I think now that we know the reason of the error message the easiest way of solving the issue is just unmounting the 4 disks before logging out of xfce. That shouldn´t be too inconvenient for me. :blush:

When logging in as another user there´s no way that the disks were mounted “by another user”…

Plus: After a cold start - when logging into new user “rosika_3” in an openbox session the problem shouldn´t present itself in the first place.

Many greetings from Rosika :slightly_smiling_face:

I think it would mean that the nominated user could issue a mount starement.
Nothing to do with what Thunar or the icons do.

I dont think I would have “user option” and certainly not “users option”

Regards
Neville

1 Like

Hi Neville, :wave:

thanks for your comments.

I see.
I also found something here (as far as fstab-entries are concerned):

[…] If you now connect the USB backup disk, it is mounted every time under /media/backup.
The option user is also interesting in this context. It ensures that you do not need any root privileges to mount or unmount the partition

(translation via “TranslateLocally for Firefox” add-on)

O.K., I think we solved the mystery about the partition mounts. :+1:

Thanks a lot for your help, Neville. :heart:

There still remain some other things to be sorted out in an openbox session though.
One phenomenon I encountered yesterday was I couldn´t get some particular command to work as new user rosika_3.
I´ll have to look up how to run commands as another user. I know it can be done… :wink:

Many greetings from Rosika :slightly_smiling_face: